summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2016-11-27 17:07:47 +0000
committerJames Le Cuirot <chewi@gentoo.org>2016-11-27 17:09:16 +0000
commit0e6593d74a46fa1b6bdbf6bc24e728fb59af7e5b (patch)
tree3987b88c1cf9187026c6da2bc52ea22ccd4e2d21 /dev-java/commons-vfs/commons-vfs-1.0-r1.ebuild
parentgnome-extra/gnome-do: remove unused patches. (diff)
downloadgentoo-0e6593d74a46fa1b6bdbf6bc24e728fb59af7e5b.tar.gz
gentoo-0e6593d74a46fa1b6bdbf6bc24e728fb59af7e5b.tar.bz2
gentoo-0e6593d74a46fa1b6bdbf6bc24e728fb59af7e5b.zip
dev-java/commons-vfs: EAPI 6, fixes bug #600964
r0 used EAPI 0 and therefore lacked SLOT dependencies. Rewritten with java-pkg-simple and fixed the SRC_URI. Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-java/commons-vfs/commons-vfs-1.0-r1.ebuild')
-rw-r--r--dev-java/commons-vfs/commons-vfs-1.0-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-java/commons-vfs/commons-vfs-1.0-r1.ebuild b/dev-java/commons-vfs/commons-vfs-1.0-r1.ebuild
new file mode 100644
index 000000000000..1c29728acc1c
--- /dev/null
+++ b/dev-java/commons-vfs/commons-vfs-1.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="A single Java API for accessing various different file systems"
+HOMEPAGE="https://commons.apache.org/vfs/"
+SRC_URI="https://archive.apache.org/dist/${PN/-//}/source/${P}-src.tar.gz" # Not on Apache mirrors.
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+RESTRICT="test" # Some failures, can't figure them out.
+
+CP_DEPEND="
+ dev-java/ant-core:0
+ dev-java/commons-collections:0
+ dev-java/commons-httpclient:3
+ dev-java/commons-logging:0
+ dev-java/commons-net:0
+ dev-java/jsch:0
+"
+
+RDEPEND=">=virtual/jre-1.7
+ ${CP_DEPEND}"
+
+DEPEND=">=virtual/jdk-1.7
+ ${CP_DEPEND}"
+
+S="${WORKDIR}/${P}-src"
+JAVA_SRC_DIR="core/src/main"
+
+src_install() {
+ java-pkg-simple_src_install
+ dodoc {NOTICE,RELEASE_NOTES}.txt
+}