summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-09-10 16:44:57 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-09-10 16:46:39 +0000
commitcb6db330ff3228973a50d393566f368a16852de8 (patch)
treefb653d73f633ac00d46d13a6931d3a29f2916fc4 /dev-java/guava
parentwww-apps/guacamole: Bump to 0.9.8 with better instructions (diff)
downloadgentoo-cb6db330ff3228973a50d393566f368a16852de8.tar.gz
gentoo-cb6db330ff3228973a50d393566f368a16852de8.tar.bz2
gentoo-cb6db330ff3228973a50d393566f368a16852de8.zip
dev-java/guava: Raise {jre,jdk} reqs to 1.7. Drop ppc64. Fixes bug 560042.
Package-Manager: portage-2.2.18 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-java/guava')
-rw-r--r--dev-java/guava/guava-13.0.1-r2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-java/guava/guava-13.0.1-r2.ebuild b/dev-java/guava/guava-13.0.1-r2.ebuild
new file mode 100644
index 000000000000..2d8d4719e128
--- /dev/null
+++ b/dev-java/guava/guava-13.0.1-r2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="A collection of Google's core Java libraries"
+HOMEPAGE="https://code.google.com/p/guava-libraries/"
+SRC_URI="http://search.maven.org/remotecontent?filepath=com/google/${PN}/${PN}/${PV}/${P}-sources.jar"
+
+LICENSE="Apache-2.0"
+SLOT="13"
+KEYWORDS="~amd64 ~x86 ~ppc ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+
+CDEPEND="
+ dev-java/jsr305:0
+ java-virtuals/jdk-with-com-sun:0"
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.7"
+DEPEND="${CDEPEND}
+ app-arch/unzip
+ >=virtual/jdk-1.7"
+
+JAVA_GENTOO_CLASSPATH="jsr305"