summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2022-06-20 16:19:58 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-07-22 19:36:27 +0200
commit72bbc52d7df5f4fc998a609cca8b594864a821f4 (patch)
tree54112acee3a9936f75904916981c9e5b58813944 /dev-java/jakarta-annotations-api/jakarta-annotations-api-2.1.1.ebuild
parentvala.eclass: Raise minimum supported version to 0.50 (diff)
downloadgentoo-72bbc52d7df5f4fc998a609cca8b594864a821f4.tar.gz
gentoo-72bbc52d7df5f4fc998a609cca8b594864a821f4.tar.bz2
gentoo-72bbc52d7df5f4fc998a609cca8b594864a821f4.zip
dev-java/jakarta-annotations-api: new package, add 2.1.1
Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-java/jakarta-annotations-api/jakarta-annotations-api-2.1.1.ebuild')
-rw-r--r--dev-java/jakarta-annotations-api/jakarta-annotations-api-2.1.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-java/jakarta-annotations-api/jakarta-annotations-api-2.1.1.ebuild b/dev-java/jakarta-annotations-api/jakarta-annotations-api-2.1.1.ebuild
new file mode 100644
index 000000000000..fd5d5e54e46c
--- /dev/null
+++ b/dev-java/jakarta-annotations-api/jakarta-annotations-api-2.1.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+MAVEN_ID="jakarta.annotation:jakarta.annotation-api:2.1.1"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Jakarta Annotations API"
+HOMEPAGE="https://projects.eclipse.org/projects/ee4j.ca"
+SRC_URI="https://github.com/eclipse-ee4j/${PN/jakarta/common}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="EPL-2.0 GPL-2-with-classpath-exception"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ >=virtual/jdk-11:*
+"
+
+RDEPEND="
+ >=virtual/jre-1.8:*
+"
+
+DOCS=( {CONTRIBUTING,NOTICE,README}.md )
+
+S="${WORKDIR}/${P/jakarta/common}"
+
+JAVA_SRC_DIR="api/src/main/java"