summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jnr-enxio
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jnr-enxio')
-rw-r--r--dev-java/jnr-enxio/Manifest1
-rw-r--r--dev-java/jnr-enxio/files/jnr-enxio-0.7-build.xml320
-rw-r--r--dev-java/jnr-enxio/jnr-enxio-0.7.ebuild41
-rw-r--r--dev-java/jnr-enxio/metadata.xml8
4 files changed, 370 insertions, 0 deletions
diff --git a/dev-java/jnr-enxio/Manifest b/dev-java/jnr-enxio/Manifest
new file mode 100644
index 000000000000..73ec25501444
--- /dev/null
+++ b/dev-java/jnr-enxio/Manifest
@@ -0,0 +1 @@
+DIST jnr-enxio-0.7.tar.gz 10520 SHA256 6fa9757b7bea93e780f536a124d73dbabecfe0a3badd78cca33021a9ac8244ee SHA512 ed8c13ae4de2334aa9ddd9a13534e0c49fb1bde48e3bd5085a62c96f2b9fe6970b4ba08fe6b27901c5e6db1b360511265ac276ca56f89fddf5e18db9726bd834 WHIRLPOOL e5d0d4f3408578e5f92e2b7dd330f19b484018ed1ab90221164a947e938adbe6e8b679796f5e21a2c031484fb974c2b5bca591b5d3ef6cc0a0c9cd9be65b2b18
diff --git a/dev-java/jnr-enxio/files/jnr-enxio-0.7-build.xml b/dev-java/jnr-enxio/files/jnr-enxio-0.7-build.xml
new file mode 100644
index 000000000000..efdb518451e1
--- /dev/null
+++ b/dev-java/jnr-enxio/files/jnr-enxio-0.7-build.xml
@@ -0,0 +1,320 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<!-- ====================================================================== -->
+<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
+<!-- ====================================================================== -->
+<!-- -->
+<!-- Any modifications will be overwritten. -->
+<!-- -->
+<!-- Generated by Maven Ant Plugin on 6/6/13 12:27 PM -->
+<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
+<!-- -->
+<!-- ====================================================================== -->
+
+<project name="jnr-enxio-from-maven" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environment properties -->
+ <!-- ====================================================================== -->
+
+ <property file="${user.home}/.m2/maven.properties"/>
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="jnr-enxio-0.7"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src/main/java"/>
+ <property name="maven.build.resourceDir.0" value="src/main/resources"/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="src/test/java"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
+ <property name="maven.settings.offline" value="false"/>
+ <property name="maven.settings.interactiveMode" value="true"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath">
+ <pathelement location="${maven.repo.local}/com/github/jnr/jnr-constants/0.8.4/jnr-constants-0.8.4.jar"/>
+ <pathelement location="${maven.repo.local}/com/github/jnr/jnr-ffi/1.0.3/jnr-ffi-1.0.3.jar"/>
+ <pathelement location="${maven.repo.local}/com/github/jnr/jffi/1.2.7/jffi-1.2.7.jar"/>
+ <pathelement location="${maven.repo.local}/org/ow2/asm/asm/4.0/asm-4.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/ow2/asm/asm-commons/4.0/asm-commons-4.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/ow2/asm/asm-analysis/4.0/asm-analysis-4.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/ow2/asm/asm-tree/4.0/asm-tree-4.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/ow2/asm/asm-util/4.0/asm-util-4.0.jar"/>
+ <pathelement location="${maven.repo.local}/com/github/jnr/jnr-x86asm/1.0.2/jnr-x86asm-1.0.2.jar"/>
+ </path>
+ <path id="build.test.classpath">
+ <pathelement location="${maven.repo.local}/junit/junit/4.11/junit-4.11.jar"/>
+ <pathelement location="${maven.repo.local}/org/hamcrest/hamcrest-core/1.3/hamcrest-core-1.3.jar"/>
+ <pathelement location="${maven.repo.local}/com/github/jnr/jnr-constants/0.8.4/jnr-constants-0.8.4.jar"/>
+ <pathelement location="${maven.repo.local}/com/github/jnr/jnr-ffi/1.0.3/jnr-ffi-1.0.3.jar"/>
+ <pathelement location="${maven.repo.local}/com/github/jnr/jffi/1.2.7/jffi-1.2.7.jar"/>
+ <pathelement location="${maven.repo.local}/com/github/jnr/jffi/1.2.7/jffi-1.2.7-native.jar"/>
+ <pathelement location="${maven.repo.local}/org/ow2/asm/asm/4.0/asm-4.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/ow2/asm/asm-commons/4.0/asm-commons-4.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/ow2/asm/asm-analysis/4.0/asm-analysis-4.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/ow2/asm/asm-tree/4.0/asm-tree-4.0.jar"/>
+ <pathelement location="${maven.repo.local}/org/ow2/asm/asm-util/4.0/asm-util-4.0.jar"/>
+ <pathelement location="${maven.repo.local}/com/github/jnr/jnr-x86asm/1.0.2/jnr-x86asm-1.0.2.jar"/>
+ </path>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" depends="get-deps" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ nowarn="false"
+ debug="true"
+ optimize="false"
+ deprecation="true"
+ target="1.1"
+ verbose="false"
+ fork="false"
+ source="1.3">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ depends="compile"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="compile-tests, junit-missing"
+ unless="junit.skipped"
+ description="Run the test cases"/>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present"/>
+ </target>
+
+ <target name="test-junit-status"
+ depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}"/>
+ <isfalse value="${maven.test.skip}"/>
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}"/>
+ <istrue value="${maven.test.skip}"/>
+ </or>
+ </condition>
+ </target>
+
+ <target name="junit-missing"
+ depends="test-junit-status"
+ if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ version="true"
+ use="true"
+ author="true"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ linksource="false"
+ breakiterator="false"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile,test" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+ <!-- ====================================================================== -->
+ <!-- Download dependencies target -->
+ <!-- ====================================================================== -->
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true"/>
+ </condition>
+ </target>
+
+ <target name="get-deps"
+ depends="test-offline"
+ description="Download all dependencies"
+ unless="maven.mode.offline">
+ <mkdir dir="${maven.repo.local}"/>
+ <mkdir dir="${maven.repo.local}/junit/junit/4.11"/>
+ <get src="https://oss.sonatype.org/content/repositories/snapshots/junit/junit/4.11/junit-4.11.jar"
+ dest="${maven.repo.local}/junit/junit/4.11/junit-4.11.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/junit/junit/4.11/junit-4.11.jar"
+ dest="${maven.repo.local}/junit/junit/4.11/junit-4.11.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/org/hamcrest/hamcrest-core/1.3"/>
+ <get src="https://oss.sonatype.org/content/repositories/snapshots/org/hamcrest/hamcrest-core/1.3/hamcrest-core-1.3.jar"
+ dest="${maven.repo.local}/org/hamcrest/hamcrest-core/1.3/hamcrest-core-1.3.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/org/hamcrest/hamcrest-core/1.3/hamcrest-core-1.3.jar"
+ dest="${maven.repo.local}/org/hamcrest/hamcrest-core/1.3/hamcrest-core-1.3.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/com/github/jnr/jnr-constants/0.8.4"/>
+ <get src="https://oss.sonatype.org/content/repositories/snapshots/com/github/jnr/jnr-constants/0.8.4/jnr-constants-0.8.4.jar"
+ dest="${maven.repo.local}/com/github/jnr/jnr-constants/0.8.4/jnr-constants-0.8.4.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/com/github/jnr/jnr-constants/0.8.4/jnr-constants-0.8.4.jar"
+ dest="${maven.repo.local}/com/github/jnr/jnr-constants/0.8.4/jnr-constants-0.8.4.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/com/github/jnr/jnr-ffi/1.0.3"/>
+ <get src="https://oss.sonatype.org/content/repositories/snapshots/com/github/jnr/jnr-ffi/1.0.3/jnr-ffi-1.0.3.jar"
+ dest="${maven.repo.local}/com/github/jnr/jnr-ffi/1.0.3/jnr-ffi-1.0.3.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/com/github/jnr/jnr-ffi/1.0.3/jnr-ffi-1.0.3.jar"
+ dest="${maven.repo.local}/com/github/jnr/jnr-ffi/1.0.3/jnr-ffi-1.0.3.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/com/github/jnr/jffi/1.2.7"/>
+ <get src="https://oss.sonatype.org/content/repositories/snapshots/com/github/jnr/jffi/1.2.7/jffi-1.2.7.jar"
+ dest="${maven.repo.local}/com/github/jnr/jffi/1.2.7/jffi-1.2.7.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/com/github/jnr/jffi/1.2.7/jffi-1.2.7.jar"
+ dest="${maven.repo.local}/com/github/jnr/jffi/1.2.7/jffi-1.2.7.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/com/github/jnr/jffi/1.2.7"/>
+ <get src="https://oss.sonatype.org/content/repositories/snapshots/com/github/jnr/jffi/1.2.7/jffi-1.2.7-native.jar"
+ dest="${maven.repo.local}/com/github/jnr/jffi/1.2.7/jffi-1.2.7-native.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/com/github/jnr/jffi/1.2.7/jffi-1.2.7-native.jar"
+ dest="${maven.repo.local}/com/github/jnr/jffi/1.2.7/jffi-1.2.7-native.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/org/ow2/asm/asm/4.0"/>
+ <get src="https://oss.sonatype.org/content/repositories/snapshots/org/ow2/asm/asm/4.0/asm-4.0.jar"
+ dest="${maven.repo.local}/org/ow2/asm/asm/4.0/asm-4.0.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/org/ow2/asm/asm/4.0/asm-4.0.jar"
+ dest="${maven.repo.local}/org/ow2/asm/asm/4.0/asm-4.0.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/org/ow2/asm/asm-commons/4.0"/>
+ <get src="https://oss.sonatype.org/content/repositories/snapshots/org/ow2/asm/asm-commons/4.0/asm-commons-4.0.jar"
+ dest="${maven.repo.local}/org/ow2/asm/asm-commons/4.0/asm-commons-4.0.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/org/ow2/asm/asm-commons/4.0/asm-commons-4.0.jar"
+ dest="${maven.repo.local}/org/ow2/asm/asm-commons/4.0/asm-commons-4.0.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/org/ow2/asm/asm-analysis/4.0"/>
+ <get src="https://oss.sonatype.org/content/repositories/snapshots/org/ow2/asm/asm-analysis/4.0/asm-analysis-4.0.jar"
+ dest="${maven.repo.local}/org/ow2/asm/asm-analysis/4.0/asm-analysis-4.0.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/org/ow2/asm/asm-analysis/4.0/asm-analysis-4.0.jar"
+ dest="${maven.repo.local}/org/ow2/asm/asm-analysis/4.0/asm-analysis-4.0.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/org/ow2/asm/asm-tree/4.0"/>
+ <get src="https://oss.sonatype.org/content/repositories/snapshots/org/ow2/asm/asm-tree/4.0/asm-tree-4.0.jar"
+ dest="${maven.repo.local}/org/ow2/asm/asm-tree/4.0/asm-tree-4.0.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/org/ow2/asm/asm-tree/4.0/asm-tree-4.0.jar"
+ dest="${maven.repo.local}/org/ow2/asm/asm-tree/4.0/asm-tree-4.0.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/org/ow2/asm/asm-util/4.0"/>
+ <get src="https://oss.sonatype.org/content/repositories/snapshots/org/ow2/asm/asm-util/4.0/asm-util-4.0.jar"
+ dest="${maven.repo.local}/org/ow2/asm/asm-util/4.0/asm-util-4.0.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/org/ow2/asm/asm-util/4.0/asm-util-4.0.jar"
+ dest="${maven.repo.local}/org/ow2/asm/asm-util/4.0/asm-util-4.0.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/com/github/jnr/jnr-x86asm/1.0.2"/>
+ <get src="https://oss.sonatype.org/content/repositories/snapshots/com/github/jnr/jnr-x86asm/1.0.2/jnr-x86asm-1.0.2.jar"
+ dest="${maven.repo.local}/com/github/jnr/jnr-x86asm/1.0.2/jnr-x86asm-1.0.2.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/com/github/jnr/jnr-x86asm/1.0.2/jnr-x86asm-1.0.2.jar"
+ dest="${maven.repo.local}/com/github/jnr/jnr-x86asm/1.0.2/jnr-x86asm-1.0.2.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ </target>
+
+</project>
diff --git a/dev-java/jnr-enxio/jnr-enxio-0.7.ebuild b/dev-java/jnr-enxio/jnr-enxio-0.7.ebuild
new file mode 100644
index 000000000000..b360fc1e8b9d
--- /dev/null
+++ b/dev-java/jnr-enxio/jnr-enxio-0.7.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc examples source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Java Native Runtime Enhanced X-platform I/O"
+SRC_URI="http://github.com/jnr/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://github.com/jnr/jnr-enxio"
+
+SLOT="0"
+KEYWORDS="amd64 x86"
+LICENSE="Apache-2.0"
+
+CDEPEND="dev-java/jnr-constants:0
+ dev-java/jnr-ffi:2"
+
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.6"
+
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.6"
+
+java_prepare() {
+ cp "${FILESDIR}"/${P}-build.xml build.xml || die
+}
+
+JAVA_ANT_REWRITE_CLASSPATH="true"
+EANT_GENTOO_CLASSPATH="jnr-constants,jnr-ffi-2"
+
+src_install() {
+ java-pkg_newjar target/${P}.jar ${PN}.jar
+
+ use source && java-pkg_dosrc src/main/java/jnr
+ use examples && java-pkg_doexamples src/main/java/jnr/enxio/example
+ use doc && java-pkg_dojavadoc target/site/apidocs
+}
diff --git a/dev-java/jnr-enxio/metadata.xml b/dev-java/jnr-enxio/metadata.xml
new file mode 100644
index 000000000000..a491448173c8
--- /dev/null
+++ b/dev-java/jnr-enxio/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <upstream>
+ <remote-id type="github">jnr/jnr-enxio</remote-id>
+ </upstream>
+</pkgmetadata>