summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jsch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jsch')
-rw-r--r--dev-java/jsch/Manifest2
-rw-r--r--dev-java/jsch/jsch-0.1.49.ebuild45
-rw-r--r--dev-java/jsch/jsch-0.1.52.ebuild45
-rw-r--r--dev-java/jsch/metadata.xml8
4 files changed, 100 insertions, 0 deletions
diff --git a/dev-java/jsch/Manifest b/dev-java/jsch/Manifest
new file mode 100644
index 000000000000..3346a5659185
--- /dev/null
+++ b/dev-java/jsch/Manifest
@@ -0,0 +1,2 @@
+DIST jsch-0.1.49.zip 312322 SHA256 c017dfd2533b86dd751a8b1caea0ab4f19bfb9199c207c94fbdddcfd2ba9bbfe SHA512 6f21db4b561da65d4d22ecaecdc784aaca26b2dc625646a18a27b5dd7ef0eef5596786553e65b2d7f118b4993c4bb4e9561616052d15edf1a1ee1a3a7fd6b4ed WHIRLPOOL 4d09f8d122d1948400825d286718a2ee5cb42df55fbda059ff6c1260c88a5e6318ae9704d2bd7afc1f655b55d9347b39d158a01eaab1d77c506a6b99f117217e
+DIST jsch-0.1.52.zip 363648 SHA256 ceda29572f9bd670e425e48772b066e62e7a728edc6a6e23ba75f10444832ab5 SHA512 a5a998b6139638eee403e120f5f217112a5c09e81db8e1b1240d53ca311df4540b56aaa5f67f7a5c40cbc8420535d72d456e4fbfc95fe86d46376a00295bec4d WHIRLPOOL b820f35aab95e385bf457fbbd3ea4fc3c30057114c5c7025ac56dc435a4c708c51b450bfbac9b8202e23b90f062cced194def4aa8b479d629f1bef8121c66e5b
diff --git a/dev-java/jsch/jsch-0.1.49.ebuild b/dev-java/jsch/jsch-0.1.49.ebuild
new file mode 100644
index 000000000000..2e129d2cddcb
--- /dev/null
+++ b/dev-java/jsch/jsch-0.1.49.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+JAVA_PKG_IUSE="doc source examples"
+
+inherit java-pkg-2 java-ant-2 java-osgi
+
+DESCRIPTION="JSch is a pure Java implementation of SSH2"
+HOMEPAGE="http://www.jcraft.com/jsch/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="zlib"
+
+RDEPEND=">=virtual/jdk-1.5
+ zlib? ( dev-java/jzlib:0 )"
+DEPEND=">=virtual/jdk-1.5
+ app-arch/unzip
+ ${RDEPEND}"
+
+EANT_BUILD_TARGET="dist"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+
+src_compile() {
+ if use zlib; then
+ EANT_EXTRA_ARGS="-Djzlib.available=true"
+ EANT_GENTOO_CLASSPATH="jzlib"
+ fi
+
+ java-pkg-2_src_compile
+}
+
+src_install() {
+ java-osgi_newjar dist/lib/jsch*.jar "com.jcraft.jsch" "JSch" \
+ "com.jcraft.jsch, com.jcraft.jsch.jce;x-internal:=true, \
+com.jcraft.jsch.jcraft;x-internal:=true"
+
+ dodoc README ChangeLog || die
+ use doc && java-pkg_dojavadoc javadoc
+ use source && java-pkg_dosrc src/*
+ use examples && java-pkg_doexamples examples
+}
diff --git a/dev-java/jsch/jsch-0.1.52.ebuild b/dev-java/jsch/jsch-0.1.52.ebuild
new file mode 100644
index 000000000000..96a541c3d102
--- /dev/null
+++ b/dev-java/jsch/jsch-0.1.52.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+JAVA_PKG_IUSE="doc source examples"
+
+inherit java-pkg-2 java-ant-2 java-osgi
+
+DESCRIPTION="JSch is a pure Java implementation of SSH2"
+HOMEPAGE="http://www.jcraft.com/jsch/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="zlib"
+
+RDEPEND=">=virtual/jdk-1.6
+ zlib? ( dev-java/jzlib:0 )"
+DEPEND=">=virtual/jdk-1.6
+ app-arch/unzip
+ ${RDEPEND}"
+
+EANT_BUILD_TARGET="dist"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+
+src_compile() {
+ if use zlib; then
+ EANT_EXTRA_ARGS="-Djzlib.available=true"
+ EANT_GENTOO_CLASSPATH="jzlib"
+ fi
+
+ java-pkg-2_src_compile
+}
+
+src_install() {
+ java-osgi_newjar dist/lib/jsch*.jar "com.jcraft.jsch" "JSch" \
+ "com.jcraft.jsch, com.jcraft.jsch.jce;x-internal:=true, \
+ com.jcraft.jsch.jcraft;x-internal:=true"
+
+ dodoc README ChangeLog || die
+ use doc && java-pkg_dojavadoc javadoc
+ use source && java-pkg_dosrc src/*
+ use examples && java-pkg_doexamples examples
+}
diff --git a/dev-java/jsch/metadata.xml b/dev-java/jsch/metadata.xml
new file mode 100644
index 000000000000..50449828380b
--- /dev/null
+++ b/dev-java/jsch/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <upstream>
+ <remote-id type="sourceforge">jsch</remote-id>
+ </upstream>
+</pkgmetadata>