summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/osgi-enterprise-api/osgi-enterprise-api-5.0.0.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/osgi-enterprise-api/osgi-enterprise-api-5.0.0.ebuild')
-rw-r--r--dev-java/osgi-enterprise-api/osgi-enterprise-api-5.0.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-java/osgi-enterprise-api/osgi-enterprise-api-5.0.0.ebuild b/dev-java/osgi-enterprise-api/osgi-enterprise-api-5.0.0.ebuild
new file mode 100644
index 000000000000..f4049e618f61
--- /dev/null
+++ b/dev-java/osgi-enterprise-api/osgi-enterprise-api-5.0.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="OSGi Enterprise Release 5 Companion Code"
+SRC_URI="http://www.osgi.org/download/r5/osgi.enterprise-${PV}.jar"
+HOMEPAGE="http://www.osgi.org/Main/HomePage"
+
+LICENSE="Apache-2.0 OSGi-Specification-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RESTRICT="bindist fetch"
+
+CDEPEND="dev-java/glassfish-persistence:0
+ dev-java/osgi-core-api:0
+ java-virtuals/servlet-api:2.5"
+
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.5"
+
+DEPEND="${CDEPEND}
+ >=virtual/jdk-1.5
+ app-arch/unzip"
+
+JAVA_SRC_DIR="OSGI-OPT/src"
+
+JAVA_GENTOO_CLASSPATH="glassfish-persistence,osgi-core-api,servlet-api-2.5"
+
+pkg_nofetch() {
+ einfo "Please download osgi.enterprise-${PV}.jar from"
+ einfo " http://www.osgi.org/Download/Release5"
+ einfo "which you can find listed as"
+ einfo " OSGi Enterprise Release 5 Companion Code"
+ einfo "after accepting the license."
+}
+
+java_prepare() {
+ rm -r org || die
+}