summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-04-04 09:48:59 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-04-04 09:49:52 +0000
commitc57dec28d040736c69a4503d8a84b53110692479 (patch)
tree146766a923d5d75b33b784b4a5663bda4044f40c /dev-java/sablecc-anttask/sablecc-anttask-1.1.0-r2.ebuild
parentdev-java/sablecc: Clean up old. (diff)
downloadgentoo-c57dec28d040736c69a4503d8a84b53110692479.tar.gz
gentoo-c57dec28d040736c69a4503d8a84b53110692479.tar.bz2
gentoo-c57dec28d040736c69a4503d8a84b53110692479.zip
dev-java/sablecc-anttask: Switch to java-pkg-simple.
--straight-to-stable because the previous version is bogus. Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-java/sablecc-anttask/sablecc-anttask-1.1.0-r2.ebuild')
-rw-r--r--dev-java/sablecc-anttask/sablecc-anttask-1.1.0-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-java/sablecc-anttask/sablecc-anttask-1.1.0-r2.ebuild b/dev-java/sablecc-anttask/sablecc-anttask-1.1.0-r2.ebuild
new file mode 100644
index 000000000000..43b5c7f85c7e
--- /dev/null
+++ b/dev-java/sablecc-anttask/sablecc-anttask-1.1.0-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Ant task for sablecc"
+HOMEPAGE="http://sablecc.org/"
+SRC_URI="mirror://sourceforge/sablecc/${P}-src.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="
+ >=virtual/jre-1.6"
+
+DEPEND="
+ >=virtual/jdk-1.6
+ source? ( app-arch/zip )"
+
+S="${WORKDIR}/${P}"
+
+JAVA_SRC_DIR="src"
+
+src_install() {
+ java-pkg-simple_src_install
+ java-pkg_register-ant-task
+}