summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/sun-dtdparser
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/sun-dtdparser')
-rw-r--r--dev-java/sun-dtdparser/Manifest1
-rw-r--r--dev-java/sun-dtdparser/metadata.xml5
-rw-r--r--dev-java/sun-dtdparser/sun-dtdparser-1.0.ebuild34
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-java/sun-dtdparser/Manifest b/dev-java/sun-dtdparser/Manifest
new file mode 100644
index 000000000000..0b19ddcadaa0
--- /dev/null
+++ b/dev-java/sun-dtdparser/Manifest
@@ -0,0 +1 @@
+DIST dtd-parser-1.0-src.zip 67545 SHA256 b420d57ed98ed3d8e56198bf15e0be6b5495ea81656e8f2f00113149573a578a SHA512 7a8b2d27316121e33640ff51819e9edb362197b5af340a92e24b5fcd7cd885efdf3951e12cf5056670273eceffc17c3860b56d437c7cfb2fc12b47abcf82ecfa WHIRLPOOL cadcb0aaca8617ecbf21e474b2418b7e4dac6e99b6e0039d99332abcd4be65ba44298c7c91f6c31affcffbd5ded8676e569adf132d1c019e207403361e847f40
diff --git a/dev-java/sun-dtdparser/metadata.xml b/dev-java/sun-dtdparser/metadata.xml
new file mode 100644
index 000000000000..250f2d1940ea
--- /dev/null
+++ b/dev-java/sun-dtdparser/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+</pkgmetadata>
diff --git a/dev-java/sun-dtdparser/sun-dtdparser-1.0.ebuild b/dev-java/sun-dtdparser/sun-dtdparser-1.0.ebuild
new file mode 100644
index 000000000000..45ab45f87f2d
--- /dev/null
+++ b/dev-java/sun-dtdparser/sun-dtdparser-1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Sun DTDParser"
+HOMEPAGE="https://jaxb2-sources.dev.java.net/"
+# Downloadable from https://jaxb2-sources.dev.java.net/
+SRC_URI="mirror://gentoo/dtd-parser-${PV}-src.zip"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-fbsd"
+
+IUSE=""
+
+COMMON_DEP=""
+
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip
+ ${COMMON_DEP}"
+
+S="${WORKDIR}/dtd-parser-${PV}"
+
+src_install() {
+ java-pkg_newjar "${S}/target/dtd-parser-1.0.jar"
+ use source && java-pkg_dosrc src/*
+ use doc && java-pkg_dojavadoc dist/docs/api
+}