summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2022-02-25 21:45:31 +0100
committerSam James <sam@gentoo.org>2022-02-26 02:32:38 +0000
commit4da7fd1fc1504d6739db7e8885904fda58e2be46 (patch)
tree2781ce2298eeedec76937cf3d0596afd54e04e58 /dev-java/xpp3/xpp3-1.1.4c-r6.ebuild
parentprofiles/default/linux/riscv/20.0/rv64gc/lp64d/musl: update copyright header (diff)
downloadgentoo-4da7fd1fc1504d6739db7e8885904fda58e2be46.tar.gz
gentoo-4da7fd1fc1504d6739db7e8885904fda58e2be46.tar.bz2
gentoo-4da7fd1fc1504d6739db7e8885904fda58e2be46.zip
dev-java/xpp3: Restrict to virtual/jdk:1.8
Bug: https://bugs.gentoo.org/831709 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/24348 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-java/xpp3/xpp3-1.1.4c-r6.ebuild')
-rw-r--r--dev-java/xpp3/xpp3-1.1.4c-r6.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-java/xpp3/xpp3-1.1.4c-r6.ebuild b/dev-java/xpp3/xpp3-1.1.4c-r6.ebuild
new file mode 100644
index 000000000000..3b9eb1d77ff8
--- /dev/null
+++ b/dev-java/xpp3/xpp3-1.1.4c-r6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source"
+MAVEN_ID="xpp3:xpp3:1.1.4c"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="An implementation of XMLPULL V1 API"
+HOMEPAGE="https://www.extreme.indiana.edu/xgws/xsoap/xpp/mxp1/index.html"
+SRC_URI="https://repo1.maven.org/maven2/${PN}/${PN}/${PV}/${P}-sources.jar -> ${P}.jar"
+
+LICENSE="Apache-1.1 IBM JDOM LGPL-2.1+"
+SLOT="0"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+
+# Restriction to java 1.8
+# Otherwise jdk 11+ would fail to build javadoc:
+# ./javax/xml/namespace/QName.java:55: error: package exists in another module: java.xml
+# package javax.xml.namespace;
+# ^
+# 1 error
+RDEPEND=">=virtual/jre-1.8:*"
+DEPEND="virtual/jdk:1.8"
+
+JAVA_RESOURCE_DIRS="resources"
+
+src_prepare() {
+ default
+ mkdir "resources" || die
+ cp -r "META-INF" "resources" || die
+}