summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-02-14 09:28:00 +0100
committerPatrice Clement <monsieurp@gentoo.org>2016-02-17 08:27:30 +0000
commit0bee90a525093787b39f829b41c18e4f5f0916da (patch)
tree1e07d0c46d2cbca5efc93fe579afd396ac9be640 /dev-java
parentapp-editors/gvim: Bump version to 7.4.1342 (diff)
downloadgentoo-0bee90a525093787b39f829b41c18e4f5f0916da.tar.gz
gentoo-0bee90a525093787b39f829b41c18e4f5f0916da.tar.bz2
gentoo-0bee90a525093787b39f829b41c18e4f5f0916da.zip
dev-java/laf-plugin: EAPI 5 bump.
Force because EAPI 0 ebuilds really need to go. Package-Manager: portage-2.2.26 RepoMan-Options: --force
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/laf-plugin/laf-plugin-0.2-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-java/laf-plugin/laf-plugin-0.2-r1.ebuild b/dev-java/laf-plugin/laf-plugin-0.2-r1.ebuild
new file mode 100644
index 000000000000..7cad2c21179b
--- /dev/null
+++ b/dev-java/laf-plugin/laf-plugin-0.2-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="A generic plugin framework for look-and-feels"
+HOMEPAGE="http://laf-plugin.dev.java.net/"
+SRC_URI="mirror://gentoo/${P}-src.tar.bz2"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+DEPEND=">=virtual/jdk-1.4"
+RDEPEND=">=virtual/jre-1.4"
+
+EANT_BUILD_TARGET="dist"
+
+java_prepare() {
+ cp "${FILESDIR}/${P}-build.xml" build.xml || die
+}
+
+src_install() {
+ java-pkg_dojar "dist/${PN}.jar"
+
+ use doc && java-pkg_dojavadoc api
+ use source && java-pkg_dosrc src/org
+}