summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2022-08-31 10:47:35 +0200
committerFlorian Schmaus <flow@gentoo.org>2022-09-19 14:12:29 +0200
commit5b872c75f255217f89eec4c218d2f9f6f521e6f4 (patch)
treef0a3e45b9912f35033bb6faffc62c1d692a9b95f /dev-java
parentnet-fs/cvmfs: stabilize 2.9.2 for amd64, x86 (diff)
downloadgentoo-5b872c75f255217f89eec4c218d2f9f6f521e6f4.tar.gz
gentoo-5b872c75f255217f89eec4c218d2f9f6f521e6f4.tar.bz2
gentoo-5b872c75f255217f89eec4c218d2f9f6f521e6f4.zip
dev-java/xerial-core: add 2.1
Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/27088 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/xerial-core/Manifest1
-rw-r--r--dev-java/xerial-core/xerial-core-2.1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-java/xerial-core/Manifest b/dev-java/xerial-core/Manifest
index 3c03563fd0be..9e1361d1c318 100644
--- a/dev-java/xerial-core/Manifest
+++ b/dev-java/xerial-core/Manifest
@@ -1 +1,2 @@
DIST xerial-core-2.0.1.tar.bz2 519709 BLAKE2B 3d81bda265e3b3b37a50a62061298f23de7c2947a9d50ba6eac336c3ec09fcaaeea84d456e344b0d2ae16710870025a869c2359a17f0956c8dda557804e9d5ff SHA512 39236e8a653301a6899ce80d3240d505e91f0cfc8878fa1a698113d06f3af3fd7adef540d72da1c0e1fb7101542c43e92fb9388243d95c3185a561532c18c6fb
+DIST xerial-core-2.1.tar.gz 20598090 BLAKE2B d93021b1becb90a62aacc7337294fb71b0da769461947e935091c65e3e5fda2e454ebda295b7ad37d3b47993472b535588698a618d50243e00d58d1ea500284b SHA512 c762fda93e3da1efe110c667cf84cace7fd7c9b3ac35a764edd2b5e1996034a16a4a43ff5c3e298ff0b96cfc83d18994463c534301e0fab5a75c91cf03b6f89b
diff --git a/dev-java/xerial-core/xerial-core-2.1.ebuild b/dev-java/xerial-core/xerial-core-2.1.ebuild
new file mode 100644
index 000000000000..f0300c6eb27a
--- /dev/null
+++ b/dev-java/xerial-core/xerial-core-2.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+# Skeleton command:
+# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri mirror://gentoo/distfiles/4f/xerial-core-2.0.1.tar.bz2 --slot 0 --keywords "~amd64 ~x86" --ebuild xerial-core-2.0.1-r1.ebuild
+
+EAPI=8
+
+JAVA_PKG_IUSE="doc source test"
+MAVEN_ID="org.xerial:xerial-core:2.1"
+JAVA_TESTING_FRAMEWORKS="junit-4"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="Core library of the Xerial project."
+HOMEPAGE="https://xerial.org"
+SRC_URI="https://github.com/xerial/xerial-java/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+DEPEND=">=virtual/jdk-1.8:*"
+RDEPEND=">=virtual/jre-1.8:*"
+
+DOCS=( NOTICE README )
+
+S="${WORKDIR}/xerial-java-${PV}/xerial-core"
+
+JAVA_SRC_DIR="src/main/java"
+JAVA_RESOURCE_DIRS="src/main/resources"
+
+JAVA_TEST_GENTOO_CLASSPATH="junit-4"
+JAVA_TEST_SRC_DIR="src/test/java"
+JAVA_TEST_RESOURCE_DIRS="src/test/resources"
+
+src_test() {
+ # 1) listResoucesInJAR(org.xerial.util.FileResourceTest)
+ # java.lang.AssertionError: at least one resource must be found in org.junit.runner
+ local vm_version="$(java-config -g PROVIDES_VERSION)"
+ if ver_test "${vm_version}" -ge 11; then
+ sed \
+ -e '/import org.junit.Test/a import org.junit.Ignore;' \
+ -e '/listResoucesInJAR/i @Ignore' \
+ -i src/test/java/org/xerial/util/FileResourceTest.java || die
+ sed \
+ -e '/import org.junit.Test/a import org.junit.Ignore;' \
+ -e '/addPackage/i @Ignore' \
+ -e '/recursive/i @Ignore' \
+ -i src/test/java/org/xerial/util/opt/CommandLauncherTest.java || die
+ fi
+ java-pkg-simple_src_test
+}