summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2021-04-30 15:59:27 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2021-04-30 15:59:27 +0200
commit981daaafc1b4a9b249184ac223791e3a31a58401 (patch)
tree45ff10712120bab6bfab26cc4928f9eba7560d1a /dev-java
parentdev-java/libg: min java 1.8 (diff)
downloadgentoo-981daaafc1b4a9b249184ac223791e3a31a58401.tar.gz
gentoo-981daaafc1b4a9b249184ac223791e3a31a58401.tar.bz2
gentoo-981daaafc1b4a9b249184ac223791e3a31a58401.zip
dev-java/libg: dropped obsolete 2.1.0-r1
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/libg/libg-2.1.0-r1.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-java/libg/libg-2.1.0-r1.ebuild b/dev-java/libg/libg-2.1.0-r1.ebuild
deleted file mode 100644
index 8b7b14cea8d2..000000000000
--- a/dev-java/libg/libg-2.1.0-r1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-JAVA_PKG_IUSE="test"
-
-inherit java-pkg-2 java-ant-2
-
-DESCRIPTION="Lots of small utilities for bndlib, a swiss army knife for OSGi"
-HOMEPAGE="http://www.aqute.biz/Bnd/Bnd"
-SRC_URI="https://github.com/bndtools/bnd/archive/${PV}.REL.tar.gz -> bndlib-${PV}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~ppc64 x86"
-
-# Tests depend on biz.aQute.junit, which depends on biz.aQute.bndlib, which on
-# its own turn again depends on aQute.libg again; we can temporarily assume that
-# if bndlib tests pass that libg is sufficiently tested, in the future we should
-# look whether it is feasible to combine the packages or otherwise temporarily
-# build biz.aquite.bndlib and biz.aqute.junit in this package.
-RESTRICT="test"
-
-DEPEND=">=virtual/jdk-1.5"
-RDEPEND=">=virtual/jre-1.5"
-
-S="${WORKDIR}/bnd-${PV}.REL/aQute.${PN}"
-
-EANT_BUILD_TARGET="build"
-
-java_prepare() {
- # Move the correct build.xml into place, needed for testing.
- cp ../cnf/build.xml . || die "Failed to move build file into the right place."
-
- # Remove bundled jar files.
- find . -name '*.jar' -delete
-
- # Remove test files
- if ! use test ; then
- find src/test -name '*.java' -delete || die "Failed to remove test files."
- fi
-}
-
-src_install() {
- java-pkg_newjar generated/aQute.${PN}.jar
-}