summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-09-20 02:03:48 +0000
committerSam James <sam@gentoo.org>2020-09-20 02:03:55 +0000
commitbb5fa84dec248027e8f1aa59818836f4b429f3ad (patch)
treebb082e15057a75cf2600b8d010516449e79ede58 /dev-java
parentdev-java/swt: port to EAPI 7 (diff)
downloadgentoo-bb5fa84dec248027e8f1aa59818836f4b429f3ad.tar.gz
gentoo-bb5fa84dec248027e8f1aa59818836f4b429f3ad.tar.bz2
gentoo-bb5fa84dec248027e8f1aa59818836f4b429f3ad.zip
dev-java/xsdlib: port to EAPI 7
Closes: https://bugs.gentoo.org/741026 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/xsdlib/xsdlib-20090415.ebuild25
1 files changed, 13 insertions, 12 deletions
diff --git a/dev-java/xsdlib/xsdlib-20090415.ebuild b/dev-java/xsdlib/xsdlib-20090415.ebuild
index 0cb2aba0120a..9be3fe0b7cb5 100644
--- a/dev-java/xsdlib/xsdlib-20090415.ebuild
+++ b/dev-java/xsdlib/xsdlib-20090415.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
+EAPI=7
JAVA_PKG_IUSE="doc source"
@@ -14,33 +14,33 @@ SRC_URI="http://java.net/downloads/msv/releases/${PN}.${PV}.zip"
LICENSE="BSD Apache-1.1"
SLOT="0"
KEYWORDS="amd64 ~arm arm64 ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
COMMON_DEP="
dev-java/xerces:2
dev-java/relaxng-datatype:0"
+BDEPEND="app-arch/unzip"
RDEPEND="${COMMON_DEP}
>=virtual/jre-1.4"
DEPEND="${COMMON_DEP}
- >=virtual/jdk-1.4
- app-arch/unzip"
+ >=virtual/jdk-1.4"
S="${WORKDIR}/${P}"
-java_prepare() {
- find -name '*.jar' -exec rm -v {} + || die
-}
-
JAVA_SRC_DIR=( "src" "src-apache" )
JAVA_GENTOO_CLASSPATH="relaxng-datatype,xerces-2"
+src_prepare() {
+ default
+ find -name '*.jar' -delete || die
+}
+
src_compile() {
java-pkg-simple_src_compile
local dir; for dir in "${JAVA_SRC_DIR[@]}"; do
pushd ${dir} > /dev/null || die
- jar -uf "${S}"/${PN}.jar $(find -name '*.properties') || die
- popd > /dev/null
+ jar -uf "${S}"/${PN}.jar $(find -name '*.properties') || die
+ popd > /dev/null || die
done
}
@@ -48,5 +48,6 @@ src_install() {
java-pkg-simple_src_install
dodoc README.txt
- dohtml HowToUse.html
+ docinto html
+ dodoc HowToUse.html
}