summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2024-01-09 14:27:10 -0600
committerWilliam Hubbs <williamh@gentoo.org>2024-01-09 14:33:19 -0600
commit23bb07f11cf8d45db7d7409da2b0b73576c27fbc (patch)
tree1f1009c2c372f8b4efa1c12ae409cff4f9e867eb /dev-lang/cue/cue-0.7.0.ebuild
parentdev-embedded/platformio: add 6.1.11, drop 6.1.6-r2 (diff)
downloadgentoo-23bb07f11cf8d45db7d7409da2b0b73576c27fbc.tar.gz
gentoo-23bb07f11cf8d45db7d7409da2b0b73576c27fbc.tar.bz2
gentoo-23bb07f11cf8d45db7d7409da2b0b73576c27fbc.zip
dev-lang/cue: new package, add 0.7.0
Cue is an open-source data validation language and inference engine. Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-lang/cue/cue-0.7.0.ebuild')
-rw-r--r--dev-lang/cue/cue-0.7.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-lang/cue/cue-0.7.0.ebuild b/dev-lang/cue/cue-0.7.0.ebuild
new file mode 100644
index 000000000000..810334738868
--- /dev/null
+++ b/dev-lang/cue/cue-0.7.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module
+
+DESCRIPTION="open-source data validation language and inference engine"
+HOMEPAGE="https://cuelang.org"
+SRC_URI="https://github.com/cue-lang/cue/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ ego build -o bin/cue ./cmd/cue
+}
+
+src_install() {
+ dobin bin/*
+ einstalldocs
+dodoc -r doc
+}