summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-02-10 23:03:28 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2016-02-10 23:03:36 +0000
commit9bc66f191869fb05fcdd07973782b2097497a7fc (patch)
treea4d702f983a95740683b9afe40fb9276ac56c25a /dev-lang/ghc/ghc-7.10.2-r1.ebuild
parentapp-text/atril: Fix missing configure option. Thanks to joost_op (diff)
downloadgentoo-9bc66f191869fb05fcdd07973782b2097497a7fc.tar.gz
gentoo-9bc66f191869fb05fcdd07973782b2097497a7fc.tar.bz2
gentoo-9bc66f191869fb05fcdd07973782b2097497a7fc.zip
dev-lang/ghc: move QA_PREBUILT to pkg_setup(), bug #566534
Should fix paludis users. The change requires yet unreleased portage 2.2.28 to make QA_PREBUILT work as expected. Bug: https://bugs.gentoo.org/566534 Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-lang/ghc/ghc-7.10.2-r1.ebuild')
-rw-r--r--dev-lang/ghc/ghc-7.10.2-r1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/dev-lang/ghc/ghc-7.10.2-r1.ebuild b/dev-lang/ghc/ghc-7.10.2-r1.ebuild
index fe3ce0db6d69..c010b36d0746 100644
--- a/dev-lang/ghc/ghc-7.10.2-r1.ebuild
+++ b/dev-lang/ghc/ghc-7.10.2-r1.ebuild
@@ -107,9 +107,6 @@ PDEPEND="!ghcbootstrap? ( =app-admin/haskell-updater-1.2* )"
REQUIRED_USE="?? ( ghcbootstrap binary )"
-# yeah, top-level 'use' sucks. I'd like to have it in 'src_install()'
-use binary && QA_PREBUILT="*"
-
# haskell libraries built with cabal in configure mode, #515354
QA_CONFIGURE_OPTIONS+=" --with-compiler --with-gcc"
@@ -317,6 +314,9 @@ relocate_ghc() {
}
pkg_setup() {
+ # quiet portage about prebuilt binaries
+ use binary && QA_PREBUILT="*"
+
[[ ${MERGE_TYPE} == binary ]] && return
if use ghcbootstrap; then