summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2018-11-17 15:07:47 +0100
committerTupone Alfredo <tupone@gentoo.org>2018-11-17 15:08:24 +0100
commit8bcf1b9a496f83e7e3fc9f98c6fad7d50f202867 (patch)
treef3c96f8782a80b8c2e8459a61cd6d4a88ee49d13 /dev-lang/gnat-gpl
parentdev-libs/cyrus-sasl: amd64 stable wrt bug #647786 (diff)
downloadgentoo-8bcf1b9a496f83e7e3fc9f98c6fad7d50f202867.tar.gz
gentoo-8bcf1b9a496f83e7e3fc9f98c6fad7d50f202867.tar.bz2
gentoo-8bcf1b9a496f83e7e3fc9f98c6fad7d50f202867.zip
dev-lang/gnat-gpl: Add Finalization_Size su gnatcoll-2017 can build
Signed-off-by: Alfredo Tupone <tupone@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-lang/gnat-gpl')
-rw-r--r--dev-lang/gnat-gpl/files/gnat-gpl-2016-finalization.patch220
-rw-r--r--dev-lang/gnat-gpl/gnat-gpl-2016-r2.ebuild216
2 files changed, 436 insertions, 0 deletions
diff --git a/dev-lang/gnat-gpl/files/gnat-gpl-2016-finalization.patch b/dev-lang/gnat-gpl/files/gnat-gpl-2016-finalization.patch
new file mode 100644
index 000000000000..44503ae6b72e
--- /dev/null
+++ b/dev-lang/gnat-gpl/files/gnat-gpl-2016-finalization.patch
@@ -0,0 +1,220 @@
+--- a/gcc/ada/exp_attr.adb 2018-11-16 20:23:21.775906196 +0100
++++ b/gcc/ada/exp_attr.adb 2018-11-16 20:25:57.418211404 +0100
+@@ -3121,6 +3121,121 @@
+ Analyze_And_Resolve (N, Standard_String);
+ end External_Tag;
+
++ -----------------------
++ -- Finalization_Size --
++ -----------------------
++
++ when Attribute_Finalization_Size => Finalization_Size : declare
++ function Calculate_Header_Size return Node_Id;
++ -- Generate a runtime call to calculate the size of the hidden header
++ -- along with any added padding which would precede a heap-allocated
++ -- object of the prefix type.
++
++ ---------------------------
++ -- Calculate_Header_Size --
++ ---------------------------
++
++ function Calculate_Header_Size return Node_Id is
++ begin
++ -- Generate:
++ -- Universal_Integer
++ -- (Header_Size_With_Padding (Pref'Alignment))
++
++ return
++ Convert_To (Universal_Integer,
++ Make_Function_Call (Loc,
++ Name =>
++ New_Occurrence_Of (RTE (RE_Header_Size_With_Padding), Loc),
++
++ Parameter_Associations => New_List (
++ Make_Attribute_Reference (Loc,
++ Prefix => New_Copy_Tree (Pref),
++ Attribute_Name => Name_Alignment))));
++ end Calculate_Header_Size;
++
++ -- Local variables
++
++ Size : Entity_Id;
++
++ -- Start of Finalization_Size
++
++ begin
++ -- An object of a class-wide type first requires a runtime check to
++ -- determine whether it is actually controlled or not. Depending on
++ -- the outcome of this check, the Finalization_Size of the object
++ -- may be zero or some positive value.
++ --
++ -- In this scenario, Pref'Finalization_Size is expanded into
++ --
++ -- Size : Integer := 0;
++ --
++ -- if Needs_Finalization (Pref'Tag) then
++ -- Size :=
++ -- Universal_Integer
++ -- (Header_Size_With_Padding (Pref'Alignment));
++ -- end if;
++ --
++ -- and the attribute reference is replaced with a reference to Size.
++
++ if Is_Class_Wide_Type (Ptyp) then
++ Size := Make_Temporary (Loc, 'S');
++
++ Insert_Actions (N, New_List (
++
++ -- Generate:
++ -- Size : Integer := 0;
++
++ Make_Object_Declaration (Loc,
++ Defining_Identifier => Size,
++ Object_Definition =>
++ New_Occurrence_Of (Standard_Integer, Loc),
++ Expression => Make_Integer_Literal (Loc, 0)),
++
++ -- Generate:
++ -- if Needs_Finalization (Pref'Tag) then
++ -- Size :=
++ -- Universal_Integer
++ -- (Header_Size_With_Padding (Pref'Alignment));
++ -- end if;
++
++ Make_If_Statement (Loc,
++ Condition =>
++ Make_Function_Call (Loc,
++ Name =>
++ New_Occurrence_Of (RTE (RE_Needs_Finalization), Loc),
++
++ Parameter_Associations => New_List (
++ Make_Attribute_Reference (Loc,
++ Prefix => New_Copy_Tree (Pref),
++ Attribute_Name => Name_Tag))),
++
++ Then_Statements => New_List (
++ Make_Assignment_Statement (Loc,
++ Name => New_Occurrence_Of (Size, Loc),
++ Expression => Calculate_Header_Size)))));
++
++ Rewrite (N, New_Occurrence_Of (Size, Loc));
++
++ -- The prefix is known to be controlled at compile time. Calculate
++ -- Finalization_Size by calling function Header_Size_With_Padding.
++
++ elsif Needs_Finalization (Ptyp) then
++ Rewrite (N, Calculate_Header_Size);
++
++ -- The prefix is not an object with controlled parts, so its
++ -- Finalization_Size is zero.
++
++ else
++ Rewrite (N, Make_Integer_Literal (Loc, 0));
++ end if;
++
++ -- Due to cases where the entity type of the attribute is already
++ -- resolved the rewritten N must get re-resolved to its appropriate
++ -- type.
++
++ Analyze_And_Resolve (N, Typ);
++ end Finalization_Size;
++
+ -----------
+ -- First --
+ -----------
+--- a/gcc/ada/snames.ads-tmpl 2016-05-16 11:29:28.000000000 +0200
+--- b/gcc/ada/snames.ads-tmpl 2016-05-16 11:29:28.000000000 +0200
+@@ -884,6 +884,7 @@
+ Name_Exponent : constant Name_Id := N + $;
+ Name_External_Tag : constant Name_Id := N + $;
+ Name_Fast_Math : constant Name_Id := N + $; -- GNAT
++ Name_Finalization_Size : constant Name_Id := N + $; -- GNAT
+ Name_First : constant Name_Id := N + $;
+ Name_First_Bit : constant Name_Id := N + $;
+ Name_First_Valid : constant Name_Id := N + $; -- Ada 12
+@@ -1523,6 +1524,7 @@
+ Attribute_Exponent,
+ Attribute_External_Tag,
+ Attribute_Fast_Math,
++ Attribute_Finalization_Size,
+ Attribute_First,
+ Attribute_First_Bit,
+ Attribute_First_Valid,
+--- a/gcc/ada/sem_attr.ads 2018-11-16 21:35:46.821279875 +0100
++++ b/gcc/ada/sem_attr.ads 2018-11-16 21:36:00.028057464 +0100
+@@ -242,6 +242,16 @@
+ -- enumeration value. Constraint_Error is raised if no value of the
+ -- enumeration type corresponds to the given integer value.
+
++ -----------------------
++ -- Finalization_Size --
++ -----------------------
++
++ Attribute_Finalization_Size => True,
++ -- For every object or non-class-wide-type, Finalization_Size returns
++ -- the size of the hidden header used for finalization purposes as if
++ -- the object or type was allocated on the heap. The size of the header
++ -- does take into account any extra padding due to alignment issues.
++
+ -----------------
+ -- Fixed_Value --
+ -----------------
+--- a/gcc/ada/sem_attr.adb 2018-11-16 21:35:49.698231429 +0100
++++ b/gcc/ada/sem_attr.adb 2018-11-16 21:36:00.028057464 +0100
+@@ -3828,6 +3828,42 @@
+ Check_Standard_Prefix;
+ Rewrite (N, New_Occurrence_Of (Boolean_Literals (Fast_Math), Loc));
+
++ -----------------------
++ -- Finalization_Size --
++ -----------------------
++
++ when Attribute_Finalization_Size =>
++ Check_E0;
++
++ -- The prefix denotes an object
++
++ if Is_Object_Reference (P) then
++ Check_Object_Reference (P);
++
++ -- The prefix denotes a type
++
++ elsif Is_Entity_Name (P) and then Is_Type (Entity (P)) then
++ Check_Type;
++ Check_Not_Incomplete_Type;
++
++ -- Attribute 'Finalization_Size is not defined for class-wide
++ -- types because it is not possible to know statically whether
++ -- a definite type will have controlled components or not.
++
++ if Is_Class_Wide_Type (Etype (P)) then
++ Error_Attr_P
++ ("prefix of % attribute cannot denote a class-wide type");
++ end if;
++
++ -- The prefix denotes an illegal construct
++
++ else
++ Error_Attr_P
++ ("prefix of % attribute must be a definite type or an object");
++ end if;
++
++ Set_Etype (N, Universal_Integer);
++
+ -----------
+ -- First --
+ -----------
+@@ -8264,6 +8300,13 @@
+ Fold_Uint (N,
+ Eval_Fat.Exponent (P_Base_Type, Expr_Value_R (E1)), Static);
+
++ -----------------------
++ -- Finalization_Size --
++ -----------------------
++
++ when Attribute_Finalization_Size =>
++ null;
++
+ -----------
+ -- First --
+ -----------
diff --git a/dev-lang/gnat-gpl/gnat-gpl-2016-r2.ebuild b/dev-lang/gnat-gpl/gnat-gpl-2016-r2.ebuild
new file mode 100644
index 000000000000..8474d085bc1d
--- /dev/null
+++ b/dev-lang/gnat-gpl/gnat-gpl-2016-r2.ebuild
@@ -0,0 +1,216 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PATCH_VER="1.3"
+UCLIBC_VER="1.0"
+
+# Hardened gcc 4 stuff
+PIE_VER="0.6.4"
+SPECS_VER="0.2.0"
+SPECS_GCC_VER="4.4.3"
+# arch/libc configurations known to be stable with {PIE,SSP}-by-default
+PIE_GLIBC_STABLE="x86 amd64 mips ppc ppc64 arm ia64"
+PIE_UCLIBC_STABLE="x86 arm amd64 mips ppc ppc64"
+SSP_STABLE="amd64 x86 mips ppc ppc64 arm"
+# uclibc need tls and nptl support for SSP support
+# uclibc need to be >= 0.9.33
+SSP_UCLIBC_STABLE="x86 amd64 mips ppc ppc64 arm"
+#end Hardened stuff
+
+TOOLCHAIN_GCC_PV=4.9.4
+
+inherit eutils toolchain-funcs toolchain
+
+REL=4.9
+MYP=gcc-${REL}-gpl-${PV}-src
+BTSTRP_X86=gnat-gpl-2014-x86-linux-bin
+BTSTRP_AMD64=gnat-gpl-2014-x86_64-linux-bin
+
+DESCRIPTION="GNAT Ada Compiler - GPL version"
+HOMEPAGE="http://libre.adacore.com/"
+SRC_URI+="
+ http://mirrors.cdn.adacore.com/art/57399304c7a447658e0aff7f
+ -> ${P}-src.tar.gz
+ http://mirrors.cdn.adacore.com/art/573992d4c7a447658d00e1db
+ -> ${MYP}.tar.gz
+ http://mirrors.cdn.adacore.com/art/57399232c7a447658e0aff7d
+ -> gcc-interface-${REL}-gpl-${PV}-src.tar.gz
+ bootstrap? (
+ amd64? (
+ http://mirrors.cdn.adacore.com/art/564b3ebec8e196b040fbe66c ->
+ ${BTSTRP_AMD64}.tar.gz
+ )
+ x86? (
+ http://mirrors.cdn.adacore.com/art/564b3e9dc8e196b040fbe248 ->
+ ${BTSTRP_X86}.tar.gz
+ )
+ )"
+
+LICENSE+=" GPL-2 GPL-3"
+SLOT="${TOOLCHAIN_GCC_PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="bootstrap"
+
+RDEPEND="!sys-devel/gcc:${TOOLCHAIN_GCC_PV}"
+DEPEND="${RDEPEND}
+ elibc_glibc? ( >=sys-libs/glibc-2.8 )
+ >=sys-devel/binutils-2.20"
+
+PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.8 )"
+
+S="${WORKDIR}"/${MYP}
+
+FSFGCC=gcc-${TOOLCHAIN_GCC_PV}
+
+pkg_setup() {
+ toolchain_pkg_setup
+
+ if use amd64; then
+ BTSTRP=${BTSTRP_AMD64}
+ else
+ BTSTRP=${BTSTRP_X86}
+ fi
+ if use bootstrap; then
+ GCC="${WORKDIR}"/${BTSTRP}/bin/gcc
+ else
+ GCC=${ADA:-$(tc-getCC)}
+ fi
+ CC=${GCC}
+ local base=$(basename ${GCC})
+ CXX="${base/gcc/g++}"
+ GNATMAKE="${base/gcc/gnatmake}"
+ GNATBIND="${base/gcc/gnatbind}"
+ if [[ ${base} != ${GCC} ]] ; then
+ local path=$(dirname ${GCC})
+ GNATMAKE="${path}/${GNATMAKE}"
+ GNATBIND="${path}/${GNATBIND}"
+ CXX="${path}/${CXX}"
+ fi
+}
+
+src_unpack() {
+ if ! use bootstrap && [[ -z "$(type ${GNATMAKE} 2>/dev/null)" ]] ; then
+ eerror "You need a gcc compiler that provides the Ada Compiler:"
+ eerror "1) use gcc-config to select the right compiler or"
+ eerror "2) set the bootstrap use flag"
+ die "ada compiler not available"
+ fi
+
+ GCC_A_FAKEIT="${P}-src.tar.gz
+ ${MYP}.tar.gz
+ ${FSFGCC}.tar.bz2
+ gcc-interface-${REL}-gpl-${PV}-src.tar.gz"
+ if use bootstrap; then
+ GCC_A_FAKEIT="${GCC_A_FAKEIT} ${BTSTRP}.tar.gz"
+ fi
+
+ toolchain_src_unpack
+ if use bootstrap; then
+ rm ${BTSTRP}/libexec/gcc/${CHOST}/4.7.4/ld || die
+ fi
+}
+
+src_prepare() {
+ mv ../${P}-src/src/ada gcc/ || die
+ mv ../gcc-interface-${REL}-gpl-${PV}-src gcc/ada/gcc-interface || die
+
+ sed -i \
+ -e "s:gnatmake:${GNATMAKE}:g" \
+ gcc/ada/Make-generated.in || die "sed failed"
+
+ sed -i \
+ -e "/xoscons/s:gnatmake:${GNATMAKE}:g" \
+ gcc/ada/gcc-interface/Makefile.in || die "sed failed"
+
+ mv ../${FSFGCC}/gcc/doc/gcc.info gcc/doc/ || die
+ mv ../${FSFGCC}/libjava . || die
+ rm -r ../${FSFGCC} || die
+
+ cd ..
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ rm patch/10_all_default-fortify-source.patch
+ rm piepatch/34_all_gcc48_config_i386.patch
+ cd -
+
+ if has_version '<sys-libs/glibc-2.12' ; then
+ ewarn "Your host glibc is too old; disabling automatic fortify."
+ ewarn "Please rebuild gcc after upgrading to >=glibc-2.12 #362315"
+ EPATCH_EXCLUDE+=" 10_all_default-fortify-source.patch"
+ fi
+
+ # Bug 638056
+ epatch "${FILESDIR}/${P}-bootstrap.patch"
+ # add Finalization_Size Attribute
+ epatch "${FILESDIR}/${P}-finalization.patch"
+
+ toolchain_src_prepare
+
+ use vanilla && return 0
+ # Use -r1 for newer piepatchet that use DRIVER_SELF_SPECS for the hardened specs.
+ [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env-r1.patch
+}
+
+src_configure() {
+ local trueGCC_BRANCH_VER=${GCC_BRANCH_VER}
+ GCC_BRANCH_VER=$(gcc-version)
+ downgrade_arch_flags
+ GCC_BRANCH_VER=${trueGCC_BRANCH_VER}
+ toolchain_src_configure \
+ --enable-languages=ada \
+ --disable-libada \
+ CC=${GCC} \
+ GNATBIND=${GNATBIND} \
+ GNATMAKE=yes
+}
+
+src_compile() {
+ unset ADAFLAGS
+ toolchain_src_compile
+ gcc_do_make "-C gcc gnatlib-shared"
+ ln -s gcc ../build/prev-gcc || die
+ ln -s ${CHOST} ../build/prev-${CHOST} || die
+ gcc_do_make "-C gcc gnattools"
+}
+
+src_install() {
+ toolchain_src_install
+ cd "${D}"${BINPATH}
+ for x in gnat*; do
+ # For some reason, g77 gets made instead of ${CTARGET}-g77...
+ # this should take care of that
+ if [[ -f ${x} ]] ; then
+ # In case they're hardlinks, clear out the target first
+ # otherwise the mv below will complain.
+ rm -f ${CTARGET}-${x}
+ mv ${x} ${CTARGET}-${x}
+ fi
+
+ if [[ -f ${CTARGET}-${x} ]] ; then
+ if ! is_crosscompile ; then
+ ln -sf ${CTARGET}-${x} ${x}
+ dosym ${BINPATH#${EPREFIX}}/${CTARGET}-${x} \
+ /usr/bin/${x}-${GCC_CONFIG_VER}
+ fi
+ # Create versioned symlinks
+ dosym ${BINPATH#${EPREFIX}}/${CTARGET}-${x} \
+ /usr/bin/${CTARGET}-${x}-${GCC_CONFIG_VER}
+ fi
+
+ if [[ -f ${CTARGET}-${x}-${GCC_CONFIG_VER} ]] ; then
+ rm -f ${CTARGET}-${x}-${GCC_CONFIG_VER}
+ ln -sf ${CTARGET}-${x} ${CTARGET}-${x}-${GCC_CONFIG_VER}
+ fi
+ done
+}
+
+pkg_postinst () {
+ toolchain_pkg_postinst
+ einfo "This provide the GNAT compiler with gcc for ada/c/c++ and more"
+ einfo "The compiler binary is gcc-${TOOLCHAIN_GCC_PV}"
+ einfo "Even if the c/c++ compilers are using almost the same patched"
+ einfo "source as the sys-devel/gcc package its use is not extensively"
+ einfo "tested, and not supported for updating your system, except for ada"
+ einfo "related packages"
+}