summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2017-06-15 21:14:42 +0200
committerDavid Seifert <soap@gentoo.org>2017-07-01 20:05:18 -0700
commitb7a831e509fcfc0300fc6d026de2c65934667fe3 (patch)
tree1f7e1b7b2e32aa76ba16b25fdb96562f6bd64f78 /dev-lang/nasm/nasm-2.13.01.ebuild
parentdev-lang/nasm: add bugs-to to metadata (diff)
downloadgentoo-b7a831e509fcfc0300fc6d026de2c65934667fe3.tar.gz
gentoo-b7a831e509fcfc0300fc6d026de2c65934667fe3.tar.bz2
gentoo-b7a831e509fcfc0300fc6d026de2c65934667fe3.zip
dev-lang/nasm: bump to 2.13.01, EAPI=6, fix doc dependencies
Bug: https://bugs.gentoo.org/show_bug.cgi?id=619360 Closes: https://github.com/gentoo/gentoo/pull/4938 Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-lang/nasm/nasm-2.13.01.ebuild')
-rw-r--r--dev-lang/nasm/nasm-2.13.01.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-lang/nasm/nasm-2.13.01.ebuild b/dev-lang/nasm/nasm-2.13.01.ebuild
new file mode 100644
index 000000000000..6fc9f52cb0a1
--- /dev/null
+++ b/dev-lang/nasm/nasm-2.13.01.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic
+
+DESCRIPTION="groovy little assembler"
+HOMEPAGE="http://www.nasm.us/"
+SRC_URI="http://www.nasm.us/pub/nasm/releasebuilds/${PV/_}/${P/_}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="doc"
+
+DEPEND="
+ dev-lang/perl
+ doc? (
+ app-text/ghostscript-gpl
+ dev-perl/Font-TTF
+ dev-perl/Sort-Versions
+ media-fonts/clearsans
+ virtual/perl-File-Spec
+ )
+"
+
+S=${WORKDIR}/${P/_}
+PATCHES=( "${FILESDIR}"/${PN}-2.13.01-fix-docdir.patch )
+
+src_configure() {
+ strip-flags
+ default
+}
+
+src_compile() {
+ default
+ use doc && emake doc
+}
+
+src_install() {
+ default
+ emake DESTDIR="${D}" install_rdf $(usex doc install_doc '')
+}