summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2019-11-09 15:10:14 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2019-11-09 15:49:43 +0000
commitdec24f1704ec201fb34aec886136992424646b78 (patch)
tree6af69130acf0a369d67bffa1dbf54b0f4be92c56 /dev-lang/nim
parentnet-dns/avahi: remove older versions (diff)
downloadgentoo-dec24f1704ec201fb34aec886136992424646b78.tar.gz
gentoo-dec24f1704ec201fb34aec886136992424646b78.tar.bz2
gentoo-dec24f1704ec201fb34aec886136992424646b78.zip
dev-lang/nim: drop old
Package-Manager: Portage-2.3.78, Repoman-2.3.17 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-lang/nim')
-rw-r--r--dev-lang/nim/Manifest2
-rw-r--r--dev-lang/nim/nim-0.20.2.ebuild82
-rw-r--r--dev-lang/nim/nim-1.0.0.ebuild82
3 files changed, 0 insertions, 166 deletions
diff --git a/dev-lang/nim/Manifest b/dev-lang/nim/Manifest
index bc63be803522..68c8fb8a0ae9 100644
--- a/dev-lang/nim/Manifest
+++ b/dev-lang/nim/Manifest
@@ -1,3 +1 @@
-DIST nim-0.20.2.tar.xz 5032768 BLAKE2B 583e0b5cede279a0c0a60d4209f9be6237ff5ac070c0e82a075a242d08086e59c88c2ab29cbf3d2c6d7a455709b64086afd11e4928fcc9e81979d5296ef38b64 SHA512 231d95950ca5a7abe86175f93085ea27fae493e4f8dde3c9e086993431f9517781ceffeb4f9e761eb524523df3703d0a315fe53e32bc6daea6a684bf90589282
-DIST nim-1.0.0.tar.xz 5136624 BLAKE2B 6c87755f66ace6de44aa80d78840572d3ff96c07c97c7af73cdfe395cdbbfb614ad816b7e2c6b91519dcd341694ab48390d80ac97d82db3c1c9a111e0cbadaa4 SHA512 951bbec06a6a1059214b485c5eddfa3c1be0a4ccf6ba98ac3ee624f57d36e86ae1212ffcb6d1bb7ea0938aabbe95a8a6587b140f3219ddb24ec7c93f5672266f
DIST nim-1.0.2.tar.xz 5139712 BLAKE2B bcb0f0fa2ed6069021a6359e453def7beccb6e767e3e1111ff27d8fb2adb7351336f219a88e2450df3d4aece1dd7f6e1a8fb891aa31581c32bb2535d2cf604a7 SHA512 5d7a45efcf656d5467554c3bbf42d0c62a760ccd107cec439d8375839d2e80baadfb3f598598748ef8e1b32d3eb931caaa273f8e41bbf6f4e16c7afbef745349
diff --git a/dev-lang/nim/nim-0.20.2.ebuild b/dev-lang/nim/nim-0.20.2.ebuild
deleted file mode 100644
index bb41a8721feb..000000000000
--- a/dev-lang/nim/nim-0.20.2.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit bash-completion-r1 multiprocessing toolchain-funcs
-
-DESCRIPTION="compiled, garbage-collected systems programming language"
-HOMEPAGE="https://nim-lang.org/"
-SRC_URI="https://nim-lang.org/download/${P}.tar.xz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="doc +readline test"
-
-RESTRICT=test # need to sort out depends and numerous failures
-
-RDEPEND="
- readline? ( sys-libs/readline:0= )
-"
-DEPEND="
- ${DEPEND}
- test? ( net-libs/nodejs )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.20.0-paths.patch
-)
-
-_run() {
- echo "$@"
- "$@" || die "'$*' failed"
-}
-
-nim_use_enable() {
- [[ -z $2 ]] && die "usage: nim_use_enable <USE flag> <compiler flag>"
- use $1 && echo "-d:$2"
-}
-
-src_compile() {
- export XDG_CACHE_HOME=${T}/cache #667182
- tc-export CC LD
-
- _run ./build.sh
-
- _run ./bin/nim --parallelBuild:$(makeopts_jobs) c koch
- _run ./koch boot --parallelBuild:$(makeopts_jobs) -d:release $(nim_use_enable readline useGnuReadline)
- # build nimble and friends
- # --stable to avoid pulling HEAD nimble
- PATH="./bin:$PATH" _run ./koch --stable tools
-
- if use doc; then
- PATH="./bin:$PATH" _run ./koch doc
- fi
-}
-
-src_test() {
- PATH="./bin:$PATH" _run ./koch test
-}
-
-src_install() {
- PATH="./bin:$PATH" _run ./koch install "${ED%/}"
- rm -r "${ED%/}/usr/share/nim/doc" || die "failed to remove 'doc'"
-
- exeinto /usr/bin
-
- local bin_exe
- for bin_exe in bin/*; do
- # './koch install' installs only 'nim' binary
- # but not the rest
- [[ ${bin_exe} == bin/nim ]] && continue
- doexe "${bin_exe}"
- done
-
- if use doc; then
- insinto /usr/share/doc/${PF}
- dodoc doc/html/*.html
- fi
-
- newbashcomp tools/nim.bash-completion ${PN}
-}
diff --git a/dev-lang/nim/nim-1.0.0.ebuild b/dev-lang/nim/nim-1.0.0.ebuild
deleted file mode 100644
index bb41a8721feb..000000000000
--- a/dev-lang/nim/nim-1.0.0.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit bash-completion-r1 multiprocessing toolchain-funcs
-
-DESCRIPTION="compiled, garbage-collected systems programming language"
-HOMEPAGE="https://nim-lang.org/"
-SRC_URI="https://nim-lang.org/download/${P}.tar.xz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="doc +readline test"
-
-RESTRICT=test # need to sort out depends and numerous failures
-
-RDEPEND="
- readline? ( sys-libs/readline:0= )
-"
-DEPEND="
- ${DEPEND}
- test? ( net-libs/nodejs )
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.20.0-paths.patch
-)
-
-_run() {
- echo "$@"
- "$@" || die "'$*' failed"
-}
-
-nim_use_enable() {
- [[ -z $2 ]] && die "usage: nim_use_enable <USE flag> <compiler flag>"
- use $1 && echo "-d:$2"
-}
-
-src_compile() {
- export XDG_CACHE_HOME=${T}/cache #667182
- tc-export CC LD
-
- _run ./build.sh
-
- _run ./bin/nim --parallelBuild:$(makeopts_jobs) c koch
- _run ./koch boot --parallelBuild:$(makeopts_jobs) -d:release $(nim_use_enable readline useGnuReadline)
- # build nimble and friends
- # --stable to avoid pulling HEAD nimble
- PATH="./bin:$PATH" _run ./koch --stable tools
-
- if use doc; then
- PATH="./bin:$PATH" _run ./koch doc
- fi
-}
-
-src_test() {
- PATH="./bin:$PATH" _run ./koch test
-}
-
-src_install() {
- PATH="./bin:$PATH" _run ./koch install "${ED%/}"
- rm -r "${ED%/}/usr/share/nim/doc" || die "failed to remove 'doc'"
-
- exeinto /usr/bin
-
- local bin_exe
- for bin_exe in bin/*; do
- # './koch install' installs only 'nim' binary
- # but not the rest
- [[ ${bin_exe} == bin/nim ]] && continue
- doexe "${bin_exe}"
- done
-
- if use doc; then
- insinto /usr/share/doc/${PF}
- dodoc doc/html/*.html
- fi
-
- newbashcomp tools/nim.bash-completion ${PN}
-}