summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-17 12:16:48 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-19 14:34:08 +0100
commit9939442407c5a141eb70af5fd98ebed7bb6af691 (patch)
treefef041f64543570b8915d20b9a317965b1650457 /dev-lang/python-exec-conf/python-exec-conf-2.4.6.ebuild
parentprofiles/base: Mask app-cdr/burncdda[mp3] (diff)
downloadgentoo-9939442407c5a141eb70af5fd98ebed7bb6af691.tar.gz
gentoo-9939442407c5a141eb70af5fd98ebed7bb6af691.tar.bz2
gentoo-9939442407c5a141eb70af5fd98ebed7bb6af691.zip
dev-lang/python-exec-conf: New package for python-exec.conf
Split python-exec.conf file to a separate package, so that we can use PYTHON_TARGETS to control its default contents. This can be used to ensure that newer Python implementations are not used by default unless the user actually enables the relevant target. Note that we can't reuse PYTHON_TARGETS in dev-lang/python-exec this way. They are used to ensure that dev-lang/python-exec is rebuilt with the correct implementation list. Closes: https://bugs.gentoo.org/765598 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-lang/python-exec-conf/python-exec-conf-2.4.6.ebuild')
-rw-r--r--dev-lang/python-exec-conf/python-exec-conf-2.4.6.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-lang/python-exec-conf/python-exec-conf-2.4.6.ebuild b/dev-lang/python-exec-conf/python-exec-conf-2.4.6.ebuild
new file mode 100644
index 000000000000..db918e82c65e
--- /dev/null
+++ b/dev-lang/python-exec-conf/python-exec-conf-2.4.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit python-utils-r1
+
+MY_P=${P/-conf}
+DESCRIPTION="Configuration file for dev-lang/python-exec"
+HOMEPAGE="https://github.com/mgorny/python-exec/"
+SRC_URI="https://github.com/mgorny/python-exec/releases/download/v${PV}/${MY_P}.tar.bz2"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+# Internal Python project hack. Do not copy it. Ever.
+IUSE="${_PYTHON_ALL_IMPLS[@]/#/python_targets_}"
+
+RDEPEND="!<dev-lang/python-exec-2.4.6-r4"
+
+src_configure() {
+ :
+}
+
+src_install() {
+ local pyimpls=() i EPYTHON
+ for i in "${_PYTHON_ALL_IMPLS[@]}"; do
+ if use "python_targets_${i}"; then
+ _python_export "${i}" EPYTHON
+ pyimpls+=( "${EPYTHON}" )
+ fi
+ done
+
+ # Prepare and own the template
+ insinto /etc/python-exec
+ newins - python-exec.conf \
+ < <(sed -n -e '/^#/p' config/python-exec.conf.example &&
+ printf '%s\n' "${pyimpls[@]}" | tac)
+}