summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-04-26 15:51:26 -0500
committerAustin English <wizardedit@gentoo.org>2016-04-26 17:26:32 -0500
commita3fae170fa82e65aa481c6d0db8618da20f52432 (patch)
treeec4c10ac69eae4637567a304695ae06dd59905a7 /dev-lang/regina-rexx
parentdev-lang/regina-rexx: remove old unused initscript (diff)
downloadgentoo-a3fae170fa82e65aa481c6d0db8618da20f52432.tar.gz
gentoo-a3fae170fa82e65aa481c6d0db8618da20f52432.tar.bz2
gentoo-a3fae170fa82e65aa481c6d0db8618da20f52432.zip
dev-lang/regina-rexx: use #!/sbin/openrc-run instead of #!/sbin/runscript
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=573846 Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-lang/regina-rexx')
-rw-r--r--dev-lang/regina-rexx/files/rxstack-r12
-rw-r--r--dev-lang/regina-rexx/regina-rexx-3.6-r3.ebuild48
-rw-r--r--dev-lang/regina-rexx/regina-rexx-3.9.1-r1.ebuild46
3 files changed, 95 insertions, 1 deletions
diff --git a/dev-lang/regina-rexx/files/rxstack-r1 b/dev-lang/regina-rexx/files/rxstack-r1
index da4299d84e40..668af5ec0a46 100644
--- a/dev-lang/regina-rexx/files/rxstack-r1
+++ b/dev-lang/regina-rexx/files/rxstack-r1
@@ -1,4 +1,4 @@
-#!/sbin/runscript
+#!/sbin/openrc-run
start() {
ebegin "Starting Regina stack"
diff --git a/dev-lang/regina-rexx/regina-rexx-3.6-r3.ebuild b/dev-lang/regina-rexx/regina-rexx-3.6-r3.ebuild
new file mode 100644
index 000000000000..b3f95488eca9
--- /dev/null
+++ b/dev-lang/regina-rexx/regina-rexx-3.6-r3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools eutils toolchain-funcs
+
+DESCRIPTION="Portable Rexx interpreter"
+HOMEPAGE="http://regina-rexx.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/Regina-REXX-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1 MPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ppc x86"
+IUSE=""
+
+S=${WORKDIR}/Regina-REXX-${PV}
+
+MAKEOPTS+=" -j1"
+
+DOCS=( BUGS HACKERS.txt README.Unix README_SAFE TODO )
+
+src_prepare() {
+ sed -e 's/CFLAGS=/UPSTREAM_CFLAGS=/' -i common/incdebug.m4 || die
+
+ epatch "${FILESDIR}"/${PN}-3.6-gentoo.patch
+
+ eautoconf
+ tc-export CC #don't move it as tc-getCC
+}
+
+src_compile() {
+ emake LIBEXE="$(tc-getAR)"
+}
+
+src_install() {
+ default
+ newinitd "${FILESDIR}"/rxstack-r1 rxstack
+}
+
+pkg_postinst() {
+ elog "You may want to run"
+ elog
+ elog "\trc-update add rxstack default"
+ elog
+ elog "to enable Rexx queues (optional)."
+}
diff --git a/dev-lang/regina-rexx/regina-rexx-3.9.1-r1.ebuild b/dev-lang/regina-rexx/regina-rexx-3.9.1-r1.ebuild
new file mode 100644
index 000000000000..ef5d773d3cae
--- /dev/null
+++ b/dev-lang/regina-rexx/regina-rexx-3.9.1-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools eutils toolchain-funcs
+
+DESCRIPTION="Portable Rexx interpreter"
+HOMEPAGE="http://regina-rexx.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/Regina-REXX-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1 MPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+S=${WORKDIR}/Regina-REXX-${PV}
+
+MAKEOPTS+=" -j1"
+
+DOCS=( BUGS HACKERS.txt README.Unix README_SAFE TODO )
+
+src_prepare() {
+ sed -e 's/CFLAGS=/UPSTREAM_CFLAGS=/' -i common/incdebug.m4 || die
+
+ eautoconf
+ tc-export CC #don't move it as tc-getCC
+}
+
+src_compile() {
+ emake LIBEXE="$(tc-getAR)"
+}
+
+src_install() {
+ default
+ newinitd "${FILESDIR}"/rxstack-r1 rxstack
+}
+
+pkg_postinst() {
+ elog "You may want to run"
+ elog
+ elog "\trc-update add rxstack default"
+ elog
+ elog "to enable Rexx queues (optional)."
+}