summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirkjan Ochtman <djc@gentoo.org>2018-04-11 14:59:22 +0200
committerDirkjan Ochtman <djc@gentoo.org>2018-04-11 15:05:00 +0200
commit4e3cbcb0c323f81e9f5c772e82ae89a643cc992d (patch)
tree920ff0a7da45ae740320a2ee8462b491b5cc752a /dev-lang/rust-bin
parentdev-lang/rust: version bump to 1.25.0 (diff)
downloadgentoo-4e3cbcb0c323f81e9f5c772e82ae89a643cc992d.tar.gz
gentoo-4e3cbcb0c323f81e9f5c772e82ae89a643cc992d.tar.bz2
gentoo-4e3cbcb0c323f81e9f5c772e82ae89a643cc992d.zip
dev-lang/rust-bin: version bump to 1.25.0
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-lang/rust-bin')
-rw-r--r--dev-lang/rust-bin/Manifest2
-rw-r--r--dev-lang/rust-bin/rust-bin-1.25.0.ebuild102
2 files changed, 104 insertions, 0 deletions
diff --git a/dev-lang/rust-bin/Manifest b/dev-lang/rust-bin/Manifest
index ac734c239028..8611ee429627 100644
--- a/dev-lang/rust-bin/Manifest
+++ b/dev-lang/rust-bin/Manifest
@@ -14,3 +14,5 @@ DIST rust-1.19.0-i686-unknown-linux-gnu.tar.gz 143010900 BLAKE2B fd47fc710f151d7
DIST rust-1.19.0-x86_64-unknown-linux-gnu.tar.gz 151087058 BLAKE2B 796bd295393669cd55cf0a0b25f28a85b2d86394cb637b4de468c1095c5757212dda52f7d5d5ca30cfb69c0b5719d6bdce71c0ad7ed8f9ed7a40f7705f8ba550 SHA512 fc98ad7728a72c9bc93505458f7558405cc6a608eb19aa6c609e0155e7c081123f116cf023d19af2f0cd9cb81b8e1bbe69efd88f7bb61cca2d258d5fa2ed6bba
DIST rust-1.23.0-i686-unknown-linux-gnu.tar.gz 180646185 BLAKE2B 1f4653141722baffdfc9114979ac7b3abd01a8d3bf879c1e57e26daef28af39d2d64f2eea1bfadfee37f7ec9d91be06251a0dccdac1bf817f850b60bb6a1eec4 SHA512 b4b5a26b6416ceb81cbb7202c42481bfa10ef2afabfa46c2eefc89d58f87b1b4785c1f65e2f58ea863ae3d3e794aa06e101f9097d5aa757e6749d891006a7542
DIST rust-1.23.0-x86_64-unknown-linux-gnu.tar.gz 187313088 BLAKE2B eaef537506106b4cdb4c26652cc322ca7cc5f47fe15bd8551c07334bdaccdd98b14c1f91153e96ca79c22c88dfb69d2a7823fc3ac90e27b0a2c36c6559cda04b SHA512 71c0a893b25f6498bfd73104f006b79b5d6a31e4a4bcc6dcbe1b48183120afca28c12404b436417e010e3c449845c98e27e76d2b0f33498bcb35d2434b1fa821
+DIST rust-1.25.0-i686-unknown-linux-gnu.tar.gz 169267482 BLAKE2B 8fb18c95adf7edd74cd305683ab2ee33d59cce1a0f515e9ba63dfd105ffaf9150444e281502747856fa5164f24707b4bbbe110a2b1b7a1cf65c96b883a6f2ede SHA512 76bcd978b9b23b0fc6315f91bed153e59616aa62f520aae8e8d3587b5f5fae74fef15f8b0a749b02a69be56fad4df9a413019438135481917bca1fb1a7704de7
+DIST rust-1.25.0-x86_64-unknown-linux-gnu.tar.gz 178696930 BLAKE2B 0f82e837494d394c86462583f3d65f1ad839a97eda00fbc00476d06255831088cb7e554cc14edbf9dd23fbebf75078dc78204bdbec4795781f7fae0cbb6de63d SHA512 544e85bb69359d8ff6059d0f470b5995822f73e6d361be43f69f87d394b7252a11686f835336930bc257ba4347c0498abf5b1fbd751180d96bd9ca872b76d65c
diff --git a/dev-lang/rust-bin/rust-bin-1.25.0.ebuild b/dev-lang/rust-bin/rust-bin-1.25.0.ebuild
new file mode 100644
index 000000000000..9e2dadd1a193
--- /dev/null
+++ b/dev-lang/rust-bin/rust-bin-1.25.0.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils bash-completion-r1
+
+MY_P="rust-${PV}"
+
+DESCRIPTION="Systems programming language from Mozilla"
+HOMEPAGE="http://www.rust-lang.org/"
+SRC_URI="amd64? ( http://static.rust-lang.org/dist/${MY_P}-x86_64-unknown-linux-gnu.tar.gz )
+ x86? ( http://static.rust-lang.org/dist/${MY_P}-i686-unknown-linux-gnu.tar.gz )"
+
+LICENSE="|| ( MIT Apache-2.0 ) BSD-1 BSD-2 BSD-4 UoI-NCSA"
+SLOT="stable"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND=">=app-eselect/eselect-rust-0.3_pre20150425
+ !dev-lang/rust:0
+"
+RDEPEND="${DEPEND}"
+
+QA_PREBUILT="
+ opt/${P}/bin/rustc-bin-${PV}
+ opt/${P}/bin/rustdoc-bin-${PV}
+ opt/${P}/lib/*.so
+ opt/${P}/lib/rustlib/*/lib/*.so
+ opt/${P}/lib/rustlib/*/lib/*.rlib*
+"
+
+src_unpack() {
+ default
+
+ local postfix
+ use amd64 && postfix=x86_64-unknown-linux-gnu
+ use x86 && postfix=i686-unknown-linux-gnu
+ mv "${WORKDIR}/${MY_P}-${postfix}" "${S}" || die
+}
+
+src_install() {
+ local std=$(grep 'std' ./components)
+ local components="rustc,${std}"
+ use doc && components="${components},rust-docs"
+ ./install.sh \
+ --components="${components}" \
+ --disable-verify \
+ --prefix="${D}/opt/${P}" \
+ --mandir="${D}/usr/share/${P}/man" \
+ --disable-ldconfig \
+ || die
+
+ local rustc=rustc-bin-${PV}
+ local rustdoc=rustdoc-bin-${PV}
+ local rustgdb=rust-gdb-bin-${PV}
+
+ mv "${D}/opt/${P}/bin/rustc" "${D}/opt/${P}/bin/${rustc}" || die
+ mv "${D}/opt/${P}/bin/rustdoc" "${D}/opt/${P}/bin/${rustdoc}" || die
+ mv "${D}/opt/${P}/bin/rust-gdb" "${D}/opt/${P}/bin/${rustgdb}" || die
+
+ dosym "../../opt/${P}/bin/${rustc}" "/usr/bin/${rustc}"
+ dosym "../../opt/${P}/bin/${rustdoc}" "/usr/bin/${rustdoc}"
+ dosym "../../opt/${P}/bin/${rustgdb}" "/usr/bin/${rustgdb}"
+
+ cat <<-EOF > "${T}"/50${P}
+ LDPATH="/opt/${P}/lib"
+ MANPATH="/usr/share/${P}/man"
+ EOF
+ doenvd "${T}"/50${P}
+
+ cat <<-EOF > "${T}/provider-${P}"
+ /usr/bin/rustdoc
+ /usr/bin/rust-gdb
+ EOF
+ dodir /etc/env.d/rust
+ insinto /etc/env.d/rust
+ doins "${T}/provider-${P}"
+}
+
+pkg_postinst() {
+ eselect rust update --if-unset
+
+ elog "Rust installs a helper script for calling GDB now,"
+ elog "for your convenience it is installed under /usr/bin/rust-gdb-bin-${PV},"
+
+ if has_version app-editors/emacs || has_version app-editors/emacs-vcs; then
+ elog "install app-emacs/rust-mode to get emacs support for rust."
+ fi
+
+ if has_version app-editors/gvim || has_version app-editors/vim; then
+ elog "install app-vim/rust-vim to get vim support for rust."
+ fi
+
+ if has_version 'app-shells/zsh'; then
+ elog "install app-shells/rust-zshcomp to get zsh completion for rust."
+ fi
+}
+
+pkg_postrm() {
+ eselect rust unset --if-invalid
+}