summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTupone Alfredo <tupone@gentoo.org>2018-07-15 10:21:33 +0200
committerTupone Alfredo <tupone@gentoo.org>2018-07-15 10:21:33 +0200
commit228032327ba5efdef41a23138d9c4cd2dd74c5e4 (patch)
tree58a6dbe2d81761f6a3eec92f7a689fcf7addf198 /dev-lang/spark
parentdev-util/cucumber-3.0.2: fix test dependency. (diff)
downloadgentoo-228032327ba5efdef41a23138d9c4cd2dd74c5e4.tar.gz
gentoo-228032327ba5efdef41a23138d9c4cd2dd74c5e4.tar.bz2
gentoo-228032327ba5efdef41a23138d9c4cd2dd74c5e4.zip
dev-lang/spark: Version bump to 2018
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-lang/spark')
-rw-r--r--dev-lang/spark/Manifest2
-rw-r--r--dev-lang/spark/spark-2018.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-lang/spark/Manifest b/dev-lang/spark/Manifest
index 459039cb881c..e73c276d0b19 100644
--- a/dev-lang/spark/Manifest
+++ b/dev-lang/spark/Manifest
@@ -1,2 +1,4 @@
DIST gnat-gpl-2017-src.tar.gz 8783473 BLAKE2B b0415b42f4d3a5e8675591a5602ff0a96945670104064671a232c0c12271ee141a3a5d148b8507bdab83cb8a0677c57b78e690060088308c51732bad3715964f SHA512 ae7314a2241107ed4d962dce08306eeb34c5f11e26183935bbb1ccf3a5eb011d6457c1b6fcded93dd0ee9ba31d791971ebe2a5a5a0ae04ff80d87a670325a098
+DIST gnat-gpl-2018-src.tar.gz 8706578 BLAKE2B ba245fd91cc5263d5b8c159d9e75caf6bed21dcaa5fa43734af8775a4008ce5f96bfb84a8b5e6e734ff883314ab3219dacec3fe95a5baa33fb712bfb5ff8bce8 SHA512 0ff7e848ef77f7e772e2a1b01905307a91c332f32329456f5238c4b7eb46cc118709e8682a5fc826d98a7d99fd15a92c194f4a278f04bc465165cfa616cc3c2e
DIST spark-gpl-2017-src.tar.gz 19750595 BLAKE2B 840eb9044b732aad16d2b6be9972e4805caf1e1b521ba40cc2a234871775d0212153ed9e9f84b4a2ddbeefc2b9c7d7556db943153655df6051cf4dc3f1be2e01 SHA512 90e7644daa6a935c839da9799c6dc5fe0a566f29c5f5d0a964ef5c888581f18c11adf6aa0151ae72437b91430fae06604dab8c3f1fd3222d749cfd330293ff6e
+DIST spark-gpl-2018-src.tar.gz 20244517 BLAKE2B efb8120a869eaf79aa513ea3b3393dcefdb548e66a00a630bfb9d28a59785c15362c111df3635423a7312c491c9929a7bcd8e7161607dc4d3acd6d1c27f3ca3e SHA512 83490a95c2d6401bcd077a8ec508eaf18609b5b480ccd9f247f4bb61164b5e52e34473526cd49ebdf5fd15ac422ed4a121dc50cab96241db02af9e32812a4df8
diff --git a/dev-lang/spark/spark-2018.ebuild b/dev-lang/spark/spark-2018.ebuild
new file mode 100644
index 000000000000..e25af28a4b13
--- /dev/null
+++ b/dev-lang/spark/spark-2018.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs multiprocessing
+
+MYP=${PN}-gpl-${PV}
+
+DESCRIPTION="Software development for high-reliability applications."
+HOMEPAGE="http://libre.adacore.com"
+SRC_URI="http://mirrors.cdn.adacore.com/art/5b0819dec7a447df26c27a47
+ -> ${MYP}-src.tar.gz
+ http://mirrors.cdn.adacore.com/art/5b0819dfc7a447df26c27aa5
+ -> gnat-gpl-2018-src.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-lang/gnat-gpl:7.3.1
+ dev-ada/gnatcoll-core[gnat_2018,shared]
+ sci-mathematics/alt-ergo
+ sci-mathematics/why3-for-spark"
+DEPEND="${RDEPEND}
+ dev-ada/gprbuild[gnat_2018]"
+
+S="${WORKDIR}"/${MYP}-src
+
+PATCHES=( "${FILESDIR}"/${PN}-2017-gentoo.patch )
+
+src_prepare() {
+ ln -sf "${WORKDIR}"/gnat-gpl-2018-src/src/ada gnat2why/gnat_src || die
+ GCC_PV=7.3.1
+ sed -i \
+ -e "s:gnatmake:gnatmake-${GCC_PV}:g" \
+ -e "s:gnatls:gnatls-${GCC_PV}:g" \
+ Makefile \
+ gnat2why/Makefile || die
+ default
+}
+
+src_compile() {
+ emake GPRARGS="-XLIBRARY_TYPE=relocatable" gnat2why
+ emake PROD="-XLIBRARY_TYPE=relocatable" gnatprove
+}
+
+src_install() {
+ emake INSTALLDIR="${D}"/usr install
+ einstalldocs
+ dosym ../../../lib64/why3/why3server /usr/libexec/spark/bin/why3server
+ dobin install/bin/gnatprove
+ mv install/share/doc/spark/* "${D}"/usr/share/doc/${PF} || die
+ exeinto /usr/libexec/spark/bin
+ doexe install/bin/gnat2why
+ doexe install/bin/spark_memcached_wrapper
+ doexe install/bin/spark_report
+ doexe install/bin/spark_codepeer_wrapper
+ mv "${D}"/usr/bin/target.atp "${D}"/usr/libexec/spark/bin || die
+}