summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2021-06-18 14:55:44 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-06-18 14:56:51 -0700
commit23eb01987ea2ac2c32d3d3c037714e0d35655320 (patch)
tree0dbe3495f6bccc818af63e2473f02777a75175a2 /dev-lang/typescript
parentdev-perl/HTTP-Headers-Fast: Remove old (diff)
downloadgentoo-23eb01987ea2ac2c32d3d3c037714e0d35655320.tar.gz
gentoo-23eb01987ea2ac2c32d3d3c037714e0d35655320.tar.bz2
gentoo-23eb01987ea2ac2c32d3d3c037714e0d35655320.zip
dev-lang/typescript: add 4.3.3
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-lang/typescript')
-rw-r--r--dev-lang/typescript/Manifest1
-rw-r--r--dev-lang/typescript/typescript-4.3.3.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-lang/typescript/Manifest b/dev-lang/typescript/Manifest
index 8bf7068eda85..abb9addfd30b 100644
--- a/dev-lang/typescript/Manifest
+++ b/dev-lang/typescript/Manifest
@@ -1 +1,2 @@
DIST typescript-4.3.2.tgz 10624314 BLAKE2B b980fbabc60e143470d437a93247b874823353b7e7e9691b2a35abdfc2c5323fc7184f9ca8adca5211cebc329eac467900a7a54af8435e8955c8d76903a3f14a SHA512 cd9e214a19e69e8567007a551d6a5373176fedd58feb44b616cc9d40b57c5793db4b71627e3585151887496a4325a865cbcf0f472579b5e4d22e8ab8786ee62b
+DIST typescript-4.3.3.tgz 10627663 BLAKE2B 94678f3400f3098a52ed58a5d3af4308c4bdddd258a56d1155c490e3ecdc69c027c22456c06a185e14c00e17e4b1be46d775a9ab2356ab10ee8093448a412619 SHA512 ad4bcb5b45ad17b3c5d9bf727a7c16522f436bd7aebc3461987ec12f2046e030857ce27ce742c63649e6469a7c67c9173543ce6dd65011f28e887b57b901c728
diff --git a/dev-lang/typescript/typescript-4.3.3.ebuild b/dev-lang/typescript/typescript-4.3.3.ebuild
new file mode 100644
index 000000000000..dcbc71b38d89
--- /dev/null
+++ b/dev-lang/typescript/typescript-4.3.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Superset of JavaScript with optional static typing, classes and interfaces"
+HOMEPAGE="https://www.typescriptlang.org"
+SRC_URI="https://registry.npmjs.org/${PN}/-/${P}.tgz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64"
+
+DEPEND=""
+RDEPEND="net-libs/nodejs"
+BDEPEND=">=net-libs/nodejs-16[npm]"
+
+S="${WORKDIR}/package"
+
+src_compile() {
+ # nothing to compile here
+ :
+}
+
+src_install() {
+ npm \
+ --audit false \
+ --color false \
+ --foreground-scripts \
+ --global \
+ --offline \
+ --omit dev \
+ --prefix "${ED}"/usr \
+ --progress false \
+ --verbose \
+ install "${DISTDIR}/${P}".tgz || die "npm install failed"
+
+ einstalldocs
+}