summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2016-03-25 16:50:28 +0100
committerDennis Lamm <expeditioneer@gentoo.org>2016-03-25 16:50:28 +0100
commit2d228e21f642734a74f89323b489bb2d8a8db4bf (patch)
tree3cd85c8f4c840e92cc50edfba1187ef56efd6354 /dev-lang/vala/vala-0.32.0.ebuild
parentdev-libs/vala-common: Version bump (diff)
downloadgentoo-2d228e21f642734a74f89323b489bb2d8a8db4bf.tar.gz
gentoo-2d228e21f642734a74f89323b489bb2d8a8db4bf.tar.bz2
gentoo-2d228e21f642734a74f89323b489bb2d8a8db4bf.zip
dev-lang/vala: Version bump
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-lang/vala/vala-0.32.0.ebuild')
-rw-r--r--dev-lang/vala/vala-0.32.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-lang/vala/vala-0.32.0.ebuild b/dev-lang/vala/vala-0.32.0.ebuild
new file mode 100644
index 000000000000..8ca7901b4a21
--- /dev/null
+++ b/dev-lang/vala/vala-0.32.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="Compiler for the GObject type system"
+HOMEPAGE="https://wiki.gnome.org/Projects/Vala"
+
+LICENSE="LGPL-2.1"
+SLOT="0.32"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~arm-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-libs/glib-2.24:2
+ >=dev-libs/vala-common-${PV}
+"
+DEPEND="${RDEPEND}
+ !${CATEGORY}/${PN}:0
+ dev-libs/libxslt
+ sys-devel/flex
+ virtual/pkgconfig
+ virtual/yacc
+ test? (
+ dev-libs/dbus-glib
+ >=dev-libs/glib-2.26:2 )
+"
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README"
+ gnome2_src_configure --disable-unversioned
+}