summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2021-12-05 21:40:06 +0100
committerMaciej Barć <xgqt@gentoo.org>2021-12-05 21:41:22 +0100
commit229147d070a9c5d32533e577029dfe661edaaef1 (patch)
treed3e0b8990e5093877d62c60319b54a696a53492f /dev-lang
parentdev-lang/haxe: fix BDEPEND (diff)
downloadgentoo-229147d070a9c5d32533e577029dfe661edaaef1.tar.gz
gentoo-229147d070a9c5d32533e577029dfe661edaaef1.tar.bz2
gentoo-229147d070a9c5d32533e577029dfe661edaaef1.zip
dev-lang/haxe: make - ensure correct ocamlopt(.opt)
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/haxe/haxe-4.2.4-r2.ebuild (renamed from dev-lang/haxe/haxe-4.2.4-r1.ebuild)7
1 files changed, 6 insertions, 1 deletions
diff --git a/dev-lang/haxe/haxe-4.2.4-r1.ebuild b/dev-lang/haxe/haxe-4.2.4-r2.ebuild
index b391ef467182..6a8441c77ab2 100644
--- a/dev-lang/haxe/haxe-4.2.4-r1.ebuild
+++ b/dev-lang/haxe/haxe-4.2.4-r2.ebuild
@@ -48,7 +48,11 @@ QA_FLAGS_IGNORED="usr/bin/haxelib"
QA_PRESTRIPPED="usr/bin/haxelib"
src_configure() {
- use ocamlopt && export OCAMLOPT=ocamlopt.opt
+ if use ocamlopt ; then
+ export OCAMLOPT=ocamlopt.opt
+ else
+ export OCAMLOPT=ocamlopt
+ fi
}
src_compile() {
@@ -56,6 +60,7 @@ src_compile() {
BRANCH=""
COMMIT_DATE=""
COMMIT_SHA=""
+ OCAMLOPT=${OCAMLOPT}
INSTALL_DIR=/usr
)
emake -j1