summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2016-07-13 09:26:33 -0600
committerChristoph Junghans <ottxor@gentoo.org>2016-07-13 09:26:33 -0600
commit8311eeaaa22e347a3651464d5cbb2a5cc6f5a537 (patch)
treeae36d1b4dae3a80a9bb7903aa423a8df5fd308cc /dev-lang
parentdev-lang/ispc: added live ebuild (diff)
downloadgentoo-8311eeaaa22e347a3651464d5cbb2a5cc6f5a537.tar.gz
gentoo-8311eeaaa22e347a3651464d5cbb2a5cc6f5a537.tar.bz2
gentoo-8311eeaaa22e347a3651464d5cbb2a5cc6f5a537.zip
dev-lang/ispc: remove old
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ispc/Manifest3
-rw-r--r--dev-lang/ispc/ispc-1.8.2-r2.ebuild54
-rw-r--r--dev-lang/ispc/ispc-1.8.2-r4.ebuild59
-rw-r--r--dev-lang/ispc/ispc-1.9.0.ebuild52
4 files changed, 0 insertions, 168 deletions
diff --git a/dev-lang/ispc/Manifest b/dev-lang/ispc/Manifest
index 159d89eb09a8..4b6902bd5a10 100644
--- a/dev-lang/ispc/Manifest
+++ b/dev-lang/ispc/Manifest
@@ -1,4 +1 @@
-DIST ispc-1.8.2-llvm-3.7.patch.gz 15723 SHA256 8fc724b7076b0d288cf1ffeb1d71cfdbba8bf54e5923c1b862572646f6f29931 SHA512 7ad3997e8c0168d83bdc9cd0444e48467c31f9f497105ea6a98c358f8dd1db5c9acba636e5d86e6aed77c16f2a9d776142a3f2f9d2e3780ffddbb116e6679054 WHIRLPOOL 9f92edb0dbec381f43dea9b929683186254a8824cbf8b213d460166b03bf952555b0386f9346732e1ad5bd8ba90dac3c7ef531be94b30dd3288918026ae60064
-DIST ispc-1.8.2.tar.gz 19259133 SHA256 d17ea68b7192d261a2830d6e00df656a73fbccd08a249433fcaf24a886902a9d SHA512 bb1f64afe41af138c386fb12a2a7f477f7bc8df2543191bbe7e5d7624e6b00dfec11ba422f6f396cd91af1c7b4cb5d2b3febf7902740d85c6d068de8ab94765a WHIRLPOOL 45ba7c52b3ada111f518b2a94d71d8c259040114ae84881c693f6e3491bd4b6897563eba4bccb6ae83a7cb90901bf1723bcbfeb9a124267ed235b1b8fdf61d69
-DIST ispc-1.9.0.tar.gz 19271046 SHA256 b151e50f80754d81302f968c66cc7444c65010c20d1f83382b94c22491bb3971 SHA512 d886697fd0390017ee0b8c8682834d8b600b10c08eb069eea53eba7cc68788ec5a8e3f50366636add362c5a0508ef38fc0789f6a349d913b972f325830c78c28 WHIRLPOOL 63020bc499e16655bed565187d97ca7810aea294ca32ec8bef5344e4fb11ecc109cf6af7018d820ed28674b82c2a50148bb2d598d0d3cee848d990072bedb717
DIST ispc-1.9.1.tar.gz 19276043 SHA256 c52910a007f1b0c732dd1cb981e7c22f3b9b575f0b097a49f4e43fc7a3e7e976 SHA512 4acd9e99dadba684829235a267e15ca8ff4cf33c4cadaa2983006bcb2c2f45fce49e8b11963f4bce78c256aaf8ece0583cf6cb729c6bc75af32b7fa4238ca743 WHIRLPOOL 3eabea7e671ba4383f517b05c47409ec11dabc822e56ec2d909a6bb37f5d56ac7bb94be6b3059edb8ad7bc036d7bebe5061772c4fd0650f1e7c04f4d2ce12cdf
diff --git a/dev-lang/ispc/ispc-1.8.2-r2.ebuild b/dev-lang/ispc/ispc-1.8.2-r2.ebuild
deleted file mode 100644
index 235e5846f5f9..000000000000
--- a/dev-lang/ispc/ispc-1.8.2-r2.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit toolchain-funcs python-any-r1
-
-DESCRIPTION="Intel SPMD Program Compiler"
-HOMEPAGE="https://ispc.github.com/"
-
-if [[ ${PV} = *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="git://github.com/ispc/ispc.git"
- KEYWORDS=""
-else
- SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="BSD BSD-2 UoI-NCSA"
-SLOT="0"
-IUSE="examples"
-
-RDEPEND="
- >=sys-devel/clang-3.4
- >=sys-devel/llvm-3.4
- <sys-devel/clang-3.7
- <sys-devel/llvm-3.7
- "
-DEPEND="
- ${RDEPEND}
- ${PYTHON_DEPS}
- sys-devel/bison
- sys-devel/flex
- "
-
-src_compile() {
- sed -i '/^\t@/s/@//' Makefile || die #make all slient commands ("@") verbose
- emake LDFLAGS="${LDFLAGS}" OPT="${CXXFLAGS}" CXX="$(tc-getCXX)" CPP="$(tc-getCPP)"
-}
-
-src_install() {
- dobin ispc
- dodoc README.rst
-
- if use examples; then
- insinto "/usr/share/doc/${PF}/examples"
- docompress -x "/usr/share/doc/${PF}/examples"
- doins -r examples/*
- fi
-}
diff --git a/dev-lang/ispc/ispc-1.8.2-r4.ebuild b/dev-lang/ispc/ispc-1.8.2-r4.ebuild
deleted file mode 100644
index 6c8034610070..000000000000
--- a/dev-lang/ispc/ispc-1.8.2-r4.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit eutils toolchain-funcs python-any-r1
-
-DESCRIPTION="Intel SPMD Program Compiler"
-HOMEPAGE="https://ispc.github.com/"
-
-if [[ ${PV} = *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="git://github.com/ispc/ispc.git"
- KEYWORDS=""
-else
- SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
- http://dev.gentoo.org/~ottxor/dist/${P}-llvm-3.7.patch.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="BSD BSD-2 UoI-NCSA"
-SLOT="0"
-IUSE="examples"
-
-RDEPEND="
- >=sys-devel/clang-3.7
- >=sys-devel/llvm-3.7
- <sys-devel/clang-3.8
- <sys-devel/llvm-3.8
- "
-DEPEND="
- ${RDEPEND}
- ${PYTHON_DEPS}
- sys-devel/bison
- sys-devel/flex
- "
-
-src_prepare(){
- epatch "${WORKDIR}/${P}-llvm-3.7.patch"
-}
-
-src_compile() {
- sed -i '/^\t@/s/@//' Makefile || die #make all slient commands ("@") verbose
- emake LDFLAGS="${LDFLAGS}" OPT="${CXXFLAGS}" CXX="$(tc-getCXX)" CPP="$(tc-getCPP)"
-}
-
-src_install() {
- dobin ispc
- dodoc README.rst
-
- if use examples; then
- insinto "/usr/share/doc/${PF}/examples"
- docompress -x "/usr/share/doc/${PF}/examples"
- doins -r examples/*
- fi
-}
diff --git a/dev-lang/ispc/ispc-1.9.0.ebuild b/dev-lang/ispc/ispc-1.9.0.ebuild
deleted file mode 100644
index 53edbc7adc3a..000000000000
--- a/dev-lang/ispc/ispc-1.9.0.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit toolchain-funcs python-any-r1
-
-DESCRIPTION="Intel SPMD Program Compiler"
-HOMEPAGE="https://ispc.github.com/"
-
-if [[ ${PV} = *9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="git://github.com/ispc/ispc.git"
- KEYWORDS=""
-else
- SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="BSD BSD-2 UoI-NCSA"
-SLOT="0"
-IUSE="examples"
-
-RDEPEND="
- >=sys-devel/clang-3.0
- >=sys-devel/llvm-3.0
- "
-DEPEND="
- ${RDEPEND}
- ${PYTHON_DEPS}
- sys-devel/bison
- sys-devel/flex
- "
-
-src_compile() {
- sed -i '/^\t@/s/@//' Makefile || die #make all slient commands ("@") verbose
- emake LDFLAGS="${LDFLAGS}" OPT="${CXXFLAGS}" CXX="$(tc-getCXX)" CPP="$(tc-getCPP)"
-}
-
-src_install() {
- dobin ispc
- dodoc README.rst
-
- if use examples; then
- insinto "/usr/share/doc/${PF}/examples"
- docompress -x "/usr/share/doc/${PF}/examples"
- doins -r examples/*
- fi
-}