summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-09 09:43:55 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-09 09:45:03 +0100
commitf967e15f780ea857acd1f2abab95978815f99683 (patch)
tree5c5223c37ca1365c90fad702ad85f57be56687ea /dev-lang
parentdev-lang/python: Remove 3.11.0a2 (diff)
downloadgentoo-f967e15f780ea857acd1f2abab95978815f99683.tar.gz
gentoo-f967e15f780ea857acd1f2abab95978815f99683.tar.bz2
gentoo-f967e15f780ea857acd1f2abab95978815f99683.zip
dev-lang/python: Add future python-exec dep to py3.11
Add a conditional dev-lang/python-exec dep to Python 3.11 that will be enabled once it leaves alpha stage. This will make sure we won't forget to add it. Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/python-3.11.0_alpha3.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/dev-lang/python/python-3.11.0_alpha3.ebuild b/dev-lang/python/python-3.11.0_alpha3.ebuild
index 2c4c7c470f65..68bc01ac1c4f 100644
--- a/dev-lang/python/python-3.11.0_alpha3.ebuild
+++ b/dev-lang/python/python-3.11.0_alpha3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -67,6 +67,8 @@ BDEPEND="
verify-sig? ( sec-keys/openpgp-keys-python )
!sys-devel/gcc[libffi(-)]"
RDEPEND+=" !build? ( app-misc/mime-types )"
+[[ ${PV} != *_alpha* ]] &&
+ RDEPEND+=" dev-lang/python-exec[python_targets_python${PYVER/./_}(-)]"
VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/python.org.asc