summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-06-07 14:40:23 +0200
committerDavid Seifert <soap@gentoo.org>2020-06-07 14:40:23 +0200
commit1c35cce1b3edeb2df6cba467900b34dd4f56f67a (patch)
tree323554355483cbb5ff97e4577acca757f11289e9 /dev-libs/boost
parentsys-fs/snapraid: 11.5 version bump. (diff)
downloadgentoo-1c35cce1b3edeb2df6cba467900b34dd4f56f67a.tar.gz
gentoo-1c35cce1b3edeb2df6cba467900b34dd4f56f67a.tar.bz2
gentoo-1c35cce1b3edeb2df6cba467900b34dd4f56f67a.zip
dev-libs/boost: Silence <boost/bind.hpp> warning
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-libs/boost')
-rw-r--r--dev-libs/boost/boost-1.73.0.ebuild2
-rw-r--r--dev-libs/boost/files/boost-1.73-property-tree-include.patch45
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-libs/boost/boost-1.73.0.ebuild b/dev-libs/boost/boost-1.73.0.ebuild
index 2ee4e6a8b005..ae462476523a 100644
--- a/dev-libs/boost/boost-1.73.0.ebuild
+++ b/dev-libs/boost/boost-1.73.0.ebuild
@@ -57,6 +57,8 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.73-boost-python-cleanup.patch
# Boost.MPI's __init__.py doesn't work on Py3
"${FILESDIR}"/${PN}-1.73-boost-mpi-python-PEP-328.patch
+ # Remove annoying #pragma message
+ "${FILESDIR}"/${PN}-1.73-property-tree-include.patch
)
python_bindings_needed() {
diff --git a/dev-libs/boost/files/boost-1.73-property-tree-include.patch b/dev-libs/boost/files/boost-1.73-property-tree-include.patch
new file mode 100644
index 000000000000..539388275bcc
--- /dev/null
+++ b/dev-libs/boost/files/boost-1.73-property-tree-include.patch
@@ -0,0 +1,45 @@
+From d1c8825a45a0717e1ad79583d3283b0e5e32831e Mon Sep 17 00:00:00 2001
+From: Andrey Semashev <Lastique@users.noreply.github.com>
+Date: Tue, 28 Apr 2020 22:03:04 +0300
+Subject: [PATCH] Fix usage of deprecated Boost.Bind features
+
+This fixes deprecation warnings generated by boost/bind.hpp.
+
+Also, use a more actual include path for ref.hpp.
+---
+ boost/property_tree/json_parser/detail/parser.hpp | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/boost/property_tree/json_parser/detail/parser.hpp b/boost/property_tree/json_parser/detail/parser.hpp
+index 5554990fb..6cf636394 100644
+--- a/boost/property_tree/json_parser/detail/parser.hpp
++++ b/boost/property_tree/json_parser/detail/parser.hpp
+@@ -3,8 +3,8 @@
+
+ #include <boost/property_tree/json_parser/error.hpp>
+
+-#include <boost/ref.hpp>
+-#include <boost/bind.hpp>
++#include <boost/core/ref.hpp>
++#include <boost/bind/bind.hpp>
+ #include <boost/format.hpp>
+
+ #include <iterator>
+@@ -214,7 +214,7 @@ namespace boost { namespace property_tree {
+ void process_codepoint(Sentinel end, EncodingErrorFn error_fn) {
+ encoding.transcode_codepoint(cur, end,
+ boost::bind(&Callbacks::on_code_unit,
+- boost::ref(callbacks), _1),
++ boost::ref(callbacks), boost::placeholders::_1),
+ error_fn);
+ }
+
+@@ -517,7 +517,7 @@ namespace boost { namespace property_tree {
+ void feed(unsigned codepoint) {
+ encoding.feed_codepoint(codepoint,
+ boost::bind(&Callbacks::on_code_unit,
+- boost::ref(callbacks), _1));
++ boost::ref(callbacks), boost::placeholders::_1));
+ }
+
+ Callbacks& callbacks;