summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2017-10-04 22:20:00 +0300
committerAlon Bar-Lev <alonbl@gentoo.org>2017-10-04 22:20:00 +0300
commit1e30fc072ccdc03f15660e9269bb63b3db3b0f8c (patch)
tree473499723ef48a7d45609a8ad9de65af81aea7c9 /dev-libs/botan
parentdev-libs/botan: add missing limits.h (diff)
downloadgentoo-1e30fc072ccdc03f15660e9269bb63b3db3b0f8c.tar.gz
gentoo-1e30fc072ccdc03f15660e9269bb63b3db3b0f8c.tar.bz2
gentoo-1e30fc072ccdc03f15660e9269bb63b3db3b0f8c.zip
dev-libs/botan: re-add support for libressl
Gentoo-Bug: 633466 Package-Manager: Portage-2.3.8, Repoman-2.3.1
Diffstat (limited to 'dev-libs/botan')
-rw-r--r--dev-libs/botan/botan-1.10.17.ebuild1
-rw-r--r--dev-libs/botan/files/botan-1.10.17-libressl.patch40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-libs/botan/botan-1.10.17.ebuild b/dev-libs/botan/botan-1.10.17.ebuild
index afa4eff4aa1..8d09da8321a 100644
--- a/dev-libs/botan/botan-1.10.17.ebuild
+++ b/dev-libs/botan/botan-1.10.17.ebuild
@@ -34,6 +34,7 @@ DEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}/${PN}-1.10.15-c++11.patch"
"${FILESDIR}/${P}-build.patch"
+ "${FILESDIR}/${P}-libressl.patch"
)
src_prepare() {
diff --git a/dev-libs/botan/files/botan-1.10.17-libressl.patch b/dev-libs/botan/files/botan-1.10.17-libressl.patch
new file mode 100644
index 00000000000..5913bfd3049
--- /dev/null
+++ b/dev-libs/botan/files/botan-1.10.17-libressl.patch
@@ -0,0 +1,40 @@
+From e61a5f56fb404db3655909be4ce23c3a816cbb60 Mon Sep 17 00:00:00 2001
+From: Alon Bar-Lev <alon.barlev@gmail.com>
+Date: Wed, 4 Oct 2017 22:16:31 +0300
+Subject: [PATCH] openssl: support libressl
+
+Signed-off-by: Alon Bar-Lev <alon.barlev@gmail.com>
+---
+ src/engine/openssl/ossl_bc.cpp | 2 +-
+ src/engine/openssl/ossl_md.cpp | 2 +-
+ 2 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/engine/openssl/ossl_bc.cpp b/src/engine/openssl/ossl_bc.cpp
+index 74660c7b5..cb184c202 100644
+--- a/src/engine/openssl/ossl_bc.cpp
++++ b/src/engine/openssl/ossl_bc.cpp
+@@ -8,7 +8,7 @@
+ #include <botan/internal/openssl_engine.h>
+ #include <openssl/evp.h>
+
+-#if OPENSSL_VERSION_NUMBER >= 0x10100000
++#if OPENSSL_VERSION_NUMBER >= 0x10100000 && !defined(LIBRESSL_VERSION_NUMBER)
+ #error "OpenSSL 1.1 API not supported in Botan 1.10, upgrade to 2.x"
+ #endif
+
+diff --git a/src/engine/openssl/ossl_md.cpp b/src/engine/openssl/ossl_md.cpp
+index 2fcb2b0e5..9c43d616e 100644
+--- a/src/engine/openssl/ossl_md.cpp
++++ b/src/engine/openssl/ossl_md.cpp
+@@ -8,7 +8,7 @@
+ #include <botan/internal/openssl_engine.h>
+ #include <openssl/evp.h>
+
+-#if OPENSSL_VERSION_NUMBER >= 0x10100000
++#if OPENSSL_VERSION_NUMBER >= 0x10100000 && !defined(LIBRESSL_VERSION_NUMBER)
+ #error "OpenSSL 1.1 API not supported in Botan 1.10, upgrade to 2.x"
+ #endif
+
+--
+2.13.6
+