summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2017-05-19 22:17:16 +0300
committerAlon Bar-Lev <alonbl@gentoo.org>2017-05-19 22:17:23 +0300
commitbf2e1823a5cfb26705c44288193f0a98277dd16c (patch)
treefdf02483accf9cb0cba738e48b05c1a865d1a605 /dev-libs/botan
parentdev-libs/botan: version bump (diff)
downloadgentoo-bf2e1823a5cfb26705c44288193f0a98277dd16c.tar.gz
gentoo-bf2e1823a5cfb26705c44288193f0a98277dd16c.tar.bz2
gentoo-bf2e1823a5cfb26705c44288193f0a98277dd16c.zip
dev-libs/botan: remove gcc version check
long since there was an issue with gcc C++11. Bug: 618958 Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'dev-libs/botan')
-rw-r--r--dev-libs/botan/botan-2.1.0.ebuild9
1 files changed, 0 insertions, 9 deletions
diff --git a/dev-libs/botan/botan-2.1.0.ebuild b/dev-libs/botan/botan-2.1.0.ebuild
index 65915b5a5e3..68a37543dcc 100644
--- a/dev-libs/botan/botan-2.1.0.ebuild
+++ b/dev-libs/botan/botan-2.1.0.ebuild
@@ -33,15 +33,6 @@ DEPEND="${RDEPEND}
dev-lang/python:*
doc? ( dev-python/sphinx )"
-pkg_pretend() {
- # Botan 1.11 requires -std=c++11
- if [[ ${MERGE_TYPE} != binary ]]; then
- [[ $(gcc-major-version) -lt 4 ]] || \
- ( [[ $(gcc-major-version) -eq 4 && $(gcc-minor-version) -lt 7 ]] ) \
- && die "Sorry, but gcc 4.7 or higher is required."
- fi
-}
-
src_prepare() {
default
use doc || sed \