summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-12-29 07:25:46 +0000
committerSam James <sam@gentoo.org>2020-12-29 07:26:52 +0000
commitb660e18863d717f74dd968bc4895221055b1e42f (patch)
tree586470a410885fb5b9128d36c866bede2a9ab97c /dev-libs/crypto++
parentdev-ruby/sinatra: amd64 stable, bug 761897 (diff)
downloadgentoo-b660e18863d717f74dd968bc4895221055b1e42f.tar.gz
gentoo-b660e18863d717f74dd968bc4895221055b1e42f.tar.bz2
gentoo-b660e18863d717f74dd968bc4895221055b1e42f.zip
dev-libs/crypto++: cleanup old
Package-Manager: Portage-3.0.12-prefix, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/crypto++')
-rw-r--r--dev-libs/crypto++/Manifest2
-rw-r--r--dev-libs/crypto++/crypto++-5.6.5-r1.ebuild60
-rw-r--r--dev-libs/crypto++/crypto++-7.0.0-r3.ebuild48
-rw-r--r--dev-libs/crypto++/crypto++-8.2.0.ebuild52
-rw-r--r--dev-libs/crypto++/files/crypto++-5.6.4-nonative.patch28
-rw-r--r--dev-libs/crypto++/files/crypto++-5.6.5-CVE-2017-9434.patch45
6 files changed, 0 insertions, 235 deletions
diff --git a/dev-libs/crypto++/Manifest b/dev-libs/crypto++/Manifest
index 579f5052492c..3b3e1db5c634 100644
--- a/dev-libs/crypto++/Manifest
+++ b/dev-libs/crypto++/Manifest
@@ -1,4 +1,2 @@
-DIST cryptopp565.zip 4220843 BLAKE2B 0c42da3564cdd175c2f2c5c4272caf826f21e47d2271c7f54acab86f5f79dcdad8d6cb946bc88f55fde6189bb2d24ad8fb03dda6b3b8c6f105434b55b8b217d0 SHA512 f13718d02ca69b0129aaf9e767c9d2e0333aa7538355f9c63d9eaf1ff369062084a18dc01489439ebf37797b3ea81b01beb072057d47ec962bfb824ddc72abc7
-DIST cryptopp700.zip 7296665 BLAKE2B 1b1a60e240a9d94b4edfea16beef0ec48ec26c61f7f9a3d89d29bd2e77b13a83ce942f81467bb90d3086253560a3c4acd6b89178dcb416ed4328340ad5222dfd SHA512 8fd8d680e5ceaf10b3c32cb1504bda4b32abc9fcaa2c6e61e3b5e67aca805c792579884bc6a749c29a99105304c421d03d7fe7909fc58f750b3155c7c5cec8ec
DIST cryptopp820.zip 8859815 BLAKE2B 67aa850b887ae7aa869c9485bb18784492f6eec6cb12bf7c7cf84c776731eabf3c31965b47a60287e4e5a79dd3e9f0928dcfb185a0010a76f7cb96d2c3e8c6ae SHA512 753513a4ec8dd0fff2f551853ce6bd265d82219c28b033565b565b5e567fbee17adb419f4cde58a97e62b7d6533f4099aa4996cd0ba4775c6a2e7ae63a879da5
DIST cryptopp830.zip 9120687 BLAKE2B 777ae6a0716793dbbf40594e5f910783852df15e1d6444ddb9505e9f00e6ead0c17fcf6eb5d0b4d58881595fefa79d285bd2db1f1789716ffb59624c50823c3d SHA512 ad5219a66c5924d330d3646d0ff996dd235006f6812074bc4eb9e8c662a4f000ba20449d377f24b133d19ce682f7b2a3b2eb4c08857ce0f5bb39743d1d425147
diff --git a/dev-libs/crypto++/crypto++-5.6.5-r1.ebuild b/dev-libs/crypto++/crypto++-5.6.5-r1.ebuild
deleted file mode 100644
index 0d60a1066e54..000000000000
--- a/dev-libs/crypto++/crypto++-5.6.5-r1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic toolchain-funcs
-
-DESCRIPTION="C++ class library of cryptographic schemes"
-HOMEPAGE="https://cryptopp.com"
-SRC_URI="https://www.cryptopp.com/cryptopp${PV//.}.zip"
-
-LICENSE="Boost-1.0"
-SLOT="0/5.6" # subslot is so version
-KEYWORDS="~alpha amd64 ~arm arm64 hppa ppc ppc64 sparc x86 ~x64-macos"
-IUSE="static-libs"
-
-BDEPEND="app-arch/unzip"
-
-S="${WORKDIR}"
-
-PATCHES=(
- "${FILESDIR}/${PN}-5.6.4-nonative.patch"
- "${FILESDIR}/${P}-CVE-2017-9434.patch"
-)
-
-pkg_setup() {
- export CXX="$(tc-getCXX)"
- export LIBDIR="${EPREFIX}/usr/$(get_libdir)"
- export PREFIX="${EPREFIX}/usr"
-}
-
-src_compile() {
- # higher optimizations cause problems
- replace-flags -O3 -O2
- # ASM isn't Darwin/Mach-O ready, #479554, buildsys doesn't grok CPPFLAGS
- [[ ${CHOST} == *-darwin* ]] && append-cxxflags -DCRYPTOPP_DISABLE_ASM
-
- emake -f GNUmakefile all shared
-}
-
-src_install() {
- default
-
- # remove leftovers as build system sucks
- rm -fr "${ED}"/usr/bin "${ED}"/usr/share/cryptopp
- use static-libs || rm -f "${ED}"/usr/$(get_libdir)/*.a
-
- # compatibility
- dosym cryptopp "${EPREFIX}"/usr/include/crypto++
- for f in "${ED}"/usr/$(get_libdir)/*; do
- ln -s "$(basename "${f}")" "$(echo "${f}" | sed 's/cryptopp/crypto++/')" || die
- done
-}
-
-pkg_preinst() {
- # we switched directory to symlink
- # make sure portage digests that
- rm -fr "${EROOT}/usr/include/crypto++"
- rm -fr "${EROOT}/usr/include/cryptopp"
-}
diff --git a/dev-libs/crypto++/crypto++-7.0.0-r3.ebuild b/dev-libs/crypto++/crypto++-7.0.0-r3.ebuild
deleted file mode 100644
index f1d8bcbf44c5..000000000000
--- a/dev-libs/crypto++/crypto++-7.0.0-r3.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-DESCRIPTION="C++ class library of cryptographic schemes"
-HOMEPAGE="https://cryptopp.com"
-SRC_URI="https://www.cryptopp.com/cryptopp${PV//.}.zip"
-
-LICENSE="Boost-1.0"
-SLOT="0/7" # subslot is so version
-KEYWORDS="~alpha amd64 ~arm arm64 hppa ppc ppc64 sparc x86 ~x64-macos"
-IUSE="+asm static-libs"
-
-BDEPEND="app-arch/unzip"
-
-S="${WORKDIR}"
-
-config_uncomment() {
- sed -i -e "s://\s*\(#define\s*$1\):\1:" config.h || die
-}
-
-pkg_setup() {
- export CXX="$(tc-getCXX)"
- export LIBDIR="${EPREFIX}/usr/$(get_libdir)"
- export PREFIX="${EPREFIX}/usr"
-}
-
-src_prepare() {
- default
-
- use asm || config_uncomment CRYPTOPP_DISABLE_ASM
-
- # ASM isn't Darwin/Mach-O ready, #479554, buildsys doesn't grok CPPFLAGS
- [[ ${CHOST} == *-darwin* ]] && config_uncomment CRYPTOPP_DISABLE_ASM
-}
-
-src_compile() {
- emake -f GNUmakefile all shared libcryptopp.pc
-}
-
-src_install() {
- default
-
- use static-libs || rm -f "${ED}"/usr/$(get_libdir)/*.a
-}
diff --git a/dev-libs/crypto++/crypto++-8.2.0.ebuild b/dev-libs/crypto++/crypto++-8.2.0.ebuild
deleted file mode 100644
index ec4e24855984..000000000000
--- a/dev-libs/crypto++/crypto++-8.2.0.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-DESCRIPTION="C++ class library of cryptographic schemes"
-HOMEPAGE="https://cryptopp.com"
-SRC_URI="https://www.cryptopp.com/cryptopp${PV//.}.zip"
-
-LICENSE="Boost-1.0"
-SLOT="0/8" # subslot is so version
-KEYWORDS="~alpha amd64 ~arm arm64 hppa ppc ppc64 sparc x86 ~x64-macos"
-IUSE="+asm static-libs"
-
-BDEPEND="app-arch/unzip"
-
-S="${WORKDIR}"
-
-PATCHES=(
- "${FILESDIR}/${P}-build.patch"
-)
-
-config_uncomment() {
- sed -i -e "s://\s*\(#define\s*$1\):\1:" config.h || die
-}
-
-pkg_setup() {
- export CXX="$(tc-getCXX)"
- export LIBDIR="${EPREFIX}/usr/$(get_libdir)"
- export PREFIX="${EPREFIX}/usr"
-}
-
-src_prepare() {
- default
-
- use asm || config_uncomment CRYPTOPP_DISABLE_ASM
-
- # ASM isn't Darwin/Mach-O ready, #479554, buildsys doesn't grok CPPFLAGS
- [[ ${CHOST} == *-darwin* ]] && config_uncomment CRYPTOPP_DISABLE_ASM
-}
-
-src_compile() {
- emake -f GNUmakefile all shared libcryptopp.pc
-}
-
-src_install() {
- default
-
- use static-libs || rm -f "${ED}"/usr/$(get_libdir)/*.a
-}
diff --git a/dev-libs/crypto++/files/crypto++-5.6.4-nonative.patch b/dev-libs/crypto++/files/crypto++-5.6.4-nonative.patch
deleted file mode 100644
index 77d74ee729e9..000000000000
--- a/dev-libs/crypto++/files/crypto++-5.6.4-nonative.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-Index: work/GNUmakefile
-===================================================================
---- work.orig/GNUmakefile
-+++ work/GNUmakefile
-@@ -125,23 +125,6 @@ ifeq ($(IS_X86)$(IS_X32)$(IS_CYGWIN)$(IS
- endif
- endif
-
--# Guard use of -march=native
--ifeq ($(GCC42_OR_LATER)$(IS_NETBSD),10)
-- CXXFLAGS += -march=native
--else ifneq ($(CLANG_COMPILER)$(INTEL_COMPILER),00)
-- CXXFLAGS += -march=native
--else
-- # GCC 3.3 and "unknown option -march="
-- # Ubuntu GCC 4.1 compiler crash with -march=native
-- # NetBSD GCC 4.8 compiler and "bad value (native) for -march= switch"
-- # Sun compiler is handled below
-- ifeq ($(SUN_COMPILER)$(IS_X64),01)
-- CXXFLAGS += -m64
-- else ifeq ($(SUN_COMPILER)$(IS_X86),01)
-- CXXFLAGS += -m32
-- endif # X86/X32/X64
--endif
--
- # Aligned access required for -O3 and above due to vectorization
- UNALIGNED_ACCESS := $(shell $(EGREP) -c "^[[:space:]]*//[[:space:]]*\#[[:space:]]*define[[:space:]]*CRYPTOPP_NO_UNALIGNED_DATA_ACCESS" config.h)
- ifneq ($(UNALIGNED_ACCESS),0)
diff --git a/dev-libs/crypto++/files/crypto++-5.6.5-CVE-2017-9434.patch b/dev-libs/crypto++/files/crypto++-5.6.5-CVE-2017-9434.patch
deleted file mode 100644
index 428f48901a31..000000000000
--- a/dev-libs/crypto++/files/crypto++-5.6.5-CVE-2017-9434.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-From 07dbcc3d9644b18e05c1776db2a57fe04d780965 Mon Sep 17 00:00:00 2001
-From: Jeffrey Walton <noloader@gmail.com>
-Date: Wed, 10 May 2017 18:17:12 -0400
-Subject: [PATCH] Add Inflator::BadDistanceErr exception (Issue 414) The
- improved validation and excpetion clears the Address Sanitizer and Undefined
- Behavior Sanitizer findings
-
----
- zinflate.cpp | 8 +++++++-
- zinflate.h | 4 ++++
- 3 files changed, 14 insertions(+), 4 deletions(-)
-
-diff --git a/zinflate.cpp b/zinflate.cpp
-index 664efe6..fbd7505 100644
---- a/zinflate.cpp
-+++ b/zinflate.cpp
-@@ -550,12 +550,16 @@ bool Inflator::DecodeBody()
- break;
- }
- case DISTANCE_BITS:
-+ if (m_distance >= COUNTOF(distanceExtraBits))
-+ throw BadDistanceErr();
- bits = distanceExtraBits[m_distance];
- if (!m_reader.FillBuffer(bits))
- {
- m_nextDecode = DISTANCE_BITS;
- break;
- }
-+ if (m_distance >= COUNTOF(distanceStarts))
-+ throw BadDistanceErr();
- m_distance = m_reader.GetBits(bits) + distanceStarts[m_distance];
- OutputPast(m_literal, m_distance);
- }
-diff --git a/zinflate.h b/zinflate.h
-index e2fd237..c47d2f6 100644
---- a/zinflate.h
-+++ b/zinflate.h
-@@ -96,6 +96,7 @@ public:
- };
- class UnexpectedEndErr : public Err {public: UnexpectedEndErr() : Err(INVALID_DATA_FORMAT, "Inflator: unexpected end of compressed block") {}};
- class BadBlockErr : public Err {public: BadBlockErr() : Err(INVALID_DATA_FORMAT, "Inflator: error in compressed block") {}};
-+ class BadDistanceErr : public Err {public: BadDistanceErr() : Err(INVALID_DATA_FORMAT, "Inflator: error in bit distance") {}};
-
- //! \brief RFC 1951 Decompressor
- //! \param attachment the filter's attached transformation