summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/eet
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/eet')
-rw-r--r--dev-libs/eet/Manifest3
-rw-r--r--dev-libs/eet/eet-1.7.10.ebuild75
-rw-r--r--dev-libs/eet/eet-1.7.8.ebuild75
-rw-r--r--dev-libs/eet/eet-1.7.9.ebuild75
-rw-r--r--dev-libs/eet/eet-9999.ebuild75
-rw-r--r--dev-libs/eet/metadata.xml23
6 files changed, 326 insertions, 0 deletions
diff --git a/dev-libs/eet/Manifest b/dev-libs/eet/Manifest
new file mode 100644
index 000000000000..6f40057ab699
--- /dev/null
+++ b/dev-libs/eet/Manifest
@@ -0,0 +1,3 @@
+DIST eet-1.7.10.tar.bz2 573420 SHA256 c3de7be3b0f72f154e40fb2ef794e26541722b9d9d93d5a356dc76c42f5d7c13 SHA512 4e4cee77ed8ece65f482ab2535ffc033d06837e8e9f8d109c9ea90eeeaa07f2cac0519a563bd715c7442837b703d55b18222535bd06d9a1c0319dfec2966e1f8 WHIRLPOOL dfa22424945c53014c1ca347a2cd87457a0b3b43a74139899493df519f8d83a8ed951f32ca08481f63a914ca29ce92713e71c32136a65743b8d61e2a22f94899
+DIST eet-1.7.8.tar.bz2 573161 SHA256 fd075dcd083d814e81d0ad7888de13ffc6f4a5453fedf905e650ab40369c773b SHA512 d5d781b32313f77310fd2273d79955004c985eacef3324ca8ad56c22be235a657a1366cb2f53ee93c16bd19fbc895e8db3b5d4563f7645f552360cb0e06720b1 WHIRLPOOL 60e66cd9641bcdf8ccb1904766612fef563550c9df0492bd1d70dc41085d84e55d21a235ded67430a47b09ebf6c7a0f8dd466a2b9dc0e16a89c94dcc64f5897f
+DIST eet-1.7.9.tar.bz2 572885 SHA256 5d8a6e2becfc4bf77d02b823e145568f7a76ada24486486443602126f1710682 SHA512 4d06f6defff1938ecf3ce1bb911736d305b1fea46132c241e2fdd84ff027b52afbddcafe83f45a932c727006f70118eac18a08a7e386df3373a2ce64ae1280a3 WHIRLPOOL f892a13c233cc48af496c8f868fcdd005eaab444744c4fd4077af38bb339e74720872e8af25a5aec98bbcfa4667d9b6d85f515d33e042372af673fd7429768f9
diff --git a/dev-libs/eet/eet-1.7.10.ebuild b/dev-libs/eet/eet-1.7.10.ebuild
new file mode 100644
index 000000000000..1663c0e82fcb
--- /dev/null
+++ b/dev-libs/eet/eet-1.7.10.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_SUB_PROJECT="legacy"
+ EGIT_URI_APPEND=${PN}
+ EGIT_BRANCH=${PN}-1.7
+else
+ SRC_URI="http://download.enlightenment.org/releases/${P}.tar.bz2"
+ EKEY_STATE="snap"
+fi
+
+inherit enlightenment
+
+DESCRIPTION="E file chunk reading/writing library"
+HOMEPAGE="http://trac.enlightenment.org/e/wiki/Eet"
+
+LICENSE="BSD-2"
+IUSE="debug examples gnutls ssl static-libs test"
+
+RDEPEND=">=dev-libs/eina-${PV}
+ virtual/jpeg
+ sys-libs/zlib
+ gnutls? (
+ net-libs/gnutls
+ dev-libs/libgcrypt:0
+ )
+ !gnutls? ( ssl? ( dev-libs/openssl ) )"
+DEPEND="${RDEPEND}
+ test? (
+ dev-libs/check
+ dev-util/lcov
+ )"
+
+src_configure() {
+ E_ECONF=(
+ $(use_enable debug assert)
+ $(use_enable doc)
+ $(use_enable examples build-examples)
+ $(use_enable examples install-examples)
+ $(use_enable test tests)
+ )
+
+ if use gnutls; then
+ if use ssl; then
+ ewarn "You have enabled both 'ssl' and 'gnutls', so we will use"
+ ewarn "gnutls and not openssl for cipher and signature support"
+ fi
+ E_ECONF+=(
+ --enable-cipher
+ --enable-signature
+ --disable-openssl
+ --enable-gnutls
+ )
+ elif use ssl; then
+ E_ECONF+=(
+ --enable-cipher
+ --enable-signature
+ --enable-openssl
+ --disable-gnutls
+ )
+ else
+ E_ECONF+=(
+ --disable-cipher
+ --disable-signature
+ --disable-openssl
+ --disable-gnutls
+ )
+ fi
+
+ enlightenment_src_configure
+}
diff --git a/dev-libs/eet/eet-1.7.8.ebuild b/dev-libs/eet/eet-1.7.8.ebuild
new file mode 100644
index 000000000000..305388f76a7e
--- /dev/null
+++ b/dev-libs/eet/eet-1.7.8.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_SUB_PROJECT="legacy"
+ EGIT_URI_APPEND=${PN}
+ EGIT_BRANCH=${PN}-1.7
+else
+ SRC_URI="http://download.enlightenment.org/releases/${P}.tar.bz2"
+ EKEY_STATE="snap"
+fi
+
+inherit enlightenment
+
+DESCRIPTION="E file chunk reading/writing library"
+HOMEPAGE="http://trac.enlightenment.org/e/wiki/Eet"
+
+LICENSE="BSD-2"
+IUSE="debug examples gnutls ssl static-libs test"
+
+RDEPEND=">=dev-libs/eina-${PV}
+ virtual/jpeg
+ sys-libs/zlib
+ gnutls? (
+ net-libs/gnutls
+ dev-libs/libgcrypt:0
+ )
+ !gnutls? ( ssl? ( dev-libs/openssl ) )"
+DEPEND="${RDEPEND}
+ test? (
+ dev-libs/check
+ dev-util/lcov
+ )"
+
+src_configure() {
+ E_ECONF=(
+ $(use_enable debug assert)
+ $(use_enable doc)
+ $(use_enable examples build-examples)
+ $(use_enable examples install-examples)
+ $(use_enable test tests)
+ )
+
+ if use gnutls; then
+ if use ssl; then
+ ewarn "You have enabled both 'ssl' and 'gnutls', so we will use"
+ ewarn "gnutls and not openssl for cipher and signature support"
+ fi
+ E_ECONF+=(
+ --enable-cipher
+ --enable-signature
+ --disable-openssl
+ --enable-gnutls
+ )
+ elif use ssl; then
+ E_ECONF+=(
+ --enable-cipher
+ --enable-signature
+ --enable-openssl
+ --disable-gnutls
+ )
+ else
+ E_ECONF+=(
+ --disable-cipher
+ --disable-signature
+ --disable-openssl
+ --disable-gnutls
+ )
+ fi
+
+ enlightenment_src_configure
+}
diff --git a/dev-libs/eet/eet-1.7.9.ebuild b/dev-libs/eet/eet-1.7.9.ebuild
new file mode 100644
index 000000000000..305388f76a7e
--- /dev/null
+++ b/dev-libs/eet/eet-1.7.9.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_SUB_PROJECT="legacy"
+ EGIT_URI_APPEND=${PN}
+ EGIT_BRANCH=${PN}-1.7
+else
+ SRC_URI="http://download.enlightenment.org/releases/${P}.tar.bz2"
+ EKEY_STATE="snap"
+fi
+
+inherit enlightenment
+
+DESCRIPTION="E file chunk reading/writing library"
+HOMEPAGE="http://trac.enlightenment.org/e/wiki/Eet"
+
+LICENSE="BSD-2"
+IUSE="debug examples gnutls ssl static-libs test"
+
+RDEPEND=">=dev-libs/eina-${PV}
+ virtual/jpeg
+ sys-libs/zlib
+ gnutls? (
+ net-libs/gnutls
+ dev-libs/libgcrypt:0
+ )
+ !gnutls? ( ssl? ( dev-libs/openssl ) )"
+DEPEND="${RDEPEND}
+ test? (
+ dev-libs/check
+ dev-util/lcov
+ )"
+
+src_configure() {
+ E_ECONF=(
+ $(use_enable debug assert)
+ $(use_enable doc)
+ $(use_enable examples build-examples)
+ $(use_enable examples install-examples)
+ $(use_enable test tests)
+ )
+
+ if use gnutls; then
+ if use ssl; then
+ ewarn "You have enabled both 'ssl' and 'gnutls', so we will use"
+ ewarn "gnutls and not openssl for cipher and signature support"
+ fi
+ E_ECONF+=(
+ --enable-cipher
+ --enable-signature
+ --disable-openssl
+ --enable-gnutls
+ )
+ elif use ssl; then
+ E_ECONF+=(
+ --enable-cipher
+ --enable-signature
+ --enable-openssl
+ --disable-gnutls
+ )
+ else
+ E_ECONF+=(
+ --disable-cipher
+ --disable-signature
+ --disable-openssl
+ --disable-gnutls
+ )
+ fi
+
+ enlightenment_src_configure
+}
diff --git a/dev-libs/eet/eet-9999.ebuild b/dev-libs/eet/eet-9999.ebuild
new file mode 100644
index 000000000000..305388f76a7e
--- /dev/null
+++ b/dev-libs/eet/eet-9999.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_SUB_PROJECT="legacy"
+ EGIT_URI_APPEND=${PN}
+ EGIT_BRANCH=${PN}-1.7
+else
+ SRC_URI="http://download.enlightenment.org/releases/${P}.tar.bz2"
+ EKEY_STATE="snap"
+fi
+
+inherit enlightenment
+
+DESCRIPTION="E file chunk reading/writing library"
+HOMEPAGE="http://trac.enlightenment.org/e/wiki/Eet"
+
+LICENSE="BSD-2"
+IUSE="debug examples gnutls ssl static-libs test"
+
+RDEPEND=">=dev-libs/eina-${PV}
+ virtual/jpeg
+ sys-libs/zlib
+ gnutls? (
+ net-libs/gnutls
+ dev-libs/libgcrypt:0
+ )
+ !gnutls? ( ssl? ( dev-libs/openssl ) )"
+DEPEND="${RDEPEND}
+ test? (
+ dev-libs/check
+ dev-util/lcov
+ )"
+
+src_configure() {
+ E_ECONF=(
+ $(use_enable debug assert)
+ $(use_enable doc)
+ $(use_enable examples build-examples)
+ $(use_enable examples install-examples)
+ $(use_enable test tests)
+ )
+
+ if use gnutls; then
+ if use ssl; then
+ ewarn "You have enabled both 'ssl' and 'gnutls', so we will use"
+ ewarn "gnutls and not openssl for cipher and signature support"
+ fi
+ E_ECONF+=(
+ --enable-cipher
+ --enable-signature
+ --disable-openssl
+ --enable-gnutls
+ )
+ elif use ssl; then
+ E_ECONF+=(
+ --enable-cipher
+ --enable-signature
+ --enable-openssl
+ --disable-gnutls
+ )
+ else
+ E_ECONF+=(
+ --disable-cipher
+ --disable-signature
+ --disable-openssl
+ --disable-gnutls
+ )
+ fi
+
+ enlightenment_src_configure
+}
diff --git a/dev-libs/eet/metadata.xml b/dev-libs/eet/metadata.xml
new file mode 100644
index 000000000000..74563a36db2a
--- /dev/null
+++ b/dev-libs/eet/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>enlightenment</herd>
+<longdescription>
+EET is a tiny library designed to write an arbitary set of chunks of data to a file
+and optionally compress each chunk (very much like a zip file) and allow fast
+random-access reading of the file later on. It does not do zip as a zip itself has
+more complexity than is needed, and it was much simpler to impliment this once here.
+
+Eet is extremely fast, small and simple. Eet files can be very small and highly
+compressed, making them very optimal for just sending across the internet without
+having to archive, compress or decompress and install them. They allow for
+lightning-fast random-acess reads once created, making them perfect for storing data
+that is written once (or rarely) and read many times, but the program does not want
+to have to read it all in at once.
+
+It also can encode and decode data structures in memory, as well as image data for
+saving to Eet files or sending across the network to other machines, or just writing
+to arbitary files on the system. All data is encoded in a platform independant way
+and can be written and read by any architecture.
+</longdescription>
+</pkgmetadata>