summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/embryo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/embryo')
-rw-r--r--dev-libs/embryo/Manifest1
-rw-r--r--dev-libs/embryo/embryo-1.7.10.ebuild24
-rw-r--r--dev-libs/embryo/embryo-9999.ebuild24
-rw-r--r--dev-libs/embryo/metadata.xml19
4 files changed, 68 insertions, 0 deletions
diff --git a/dev-libs/embryo/Manifest b/dev-libs/embryo/Manifest
new file mode 100644
index 000000000000..fea9e2fbc76c
--- /dev/null
+++ b/dev-libs/embryo/Manifest
@@ -0,0 +1 @@
+DIST embryo-1.7.10.tar.bz2 456473 SHA256 ed98018f6ef394eda29fe5f0abc040a4fea191b60ea05b50ef09e21fcb5b65c2 SHA512 7be2171b9035d560a21aa232027d2afc46db44293e0d0ab0fdc6d3451a8a750956f09043edf851823ecc9de8c03c554205d84eddabd52f4fbe5938f5fd94d254 WHIRLPOOL 93a0f6a9084fa4869a03bf35e9fd0655820a618b43654a215e0b62c334581c49caa2222b6735335fb5fe4b18e876bca2fcbc0c69596c438450e650a680c848d9
diff --git a/dev-libs/embryo/embryo-1.7.10.ebuild b/dev-libs/embryo/embryo-1.7.10.ebuild
new file mode 100644
index 000000000000..d83379f555ca
--- /dev/null
+++ b/dev-libs/embryo/embryo-1.7.10.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_SUB_PROJECT="legacy"
+ EGIT_URI_APPEND=${PN}
+ EGIT_BRANCH=${PN}-1.7
+else
+ SRC_URI="http://download.enlightenment.org/releases/${P}.tar.bz2"
+ EKEY_STATE="snap"
+fi
+
+inherit enlightenment
+
+DESCRIPTION="load and control programs compiled in embryo language (small/pawn variant)"
+
+LICENSE="BSD-2 ZLIB"
+IUSE="static-libs"
+
+DEPEND=">=dev-libs/eina-${PV}"
+RDEPEND="${DEPEND}"
diff --git a/dev-libs/embryo/embryo-9999.ebuild b/dev-libs/embryo/embryo-9999.ebuild
new file mode 100644
index 000000000000..d83379f555ca
--- /dev/null
+++ b/dev-libs/embryo/embryo-9999.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_SUB_PROJECT="legacy"
+ EGIT_URI_APPEND=${PN}
+ EGIT_BRANCH=${PN}-1.7
+else
+ SRC_URI="http://download.enlightenment.org/releases/${P}.tar.bz2"
+ EKEY_STATE="snap"
+fi
+
+inherit enlightenment
+
+DESCRIPTION="load and control programs compiled in embryo language (small/pawn variant)"
+
+LICENSE="BSD-2 ZLIB"
+IUSE="static-libs"
+
+DEPEND=">=dev-libs/eina-${PV}"
+RDEPEND="${DEPEND}"
diff --git a/dev-libs/embryo/metadata.xml b/dev-libs/embryo/metadata.xml
new file mode 100644
index 000000000000..d75dabcf86ba
--- /dev/null
+++ b/dev-libs/embryo/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>enlightenment</herd>
+<longdescription>
+Embryo is primarily a shared library that gives you an API to load and control
+interpredted programs compiled into the abstract machine bytecode that it
+understands. This abstrac (or virtual) machine is imilar to a real machine
+with a CPU, but it is emulated in software. The architecture is simple and is
+the same as the abstract machine (AMX) in the
+SMALL (http://www.compuphase.com/small.htm) language as it is based
+on exactly the same code. Embryo has modified the code for the AMX extensively
+and has made it smaller and more portable. It is VERY small. The total size
+of the virtual machine code AND header files is less than 2500 lines of code.
+It includes the floating point library support by default as well. This makes
+it one of the smallest interpreting engines around, and thus makes is very
+efficient to use in code.
+</longdescription>
+</pkgmetadata>