summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-10-13 11:05:40 +0300
committerMart Raudsepp <leio@gentoo.org>2019-10-13 11:23:35 +0300
commit6f628f98e81f5a15a33fd01b6b4e8ee3a8bb34dc (patch)
tree42f5f56d3f83a5f16b431e1afd0c5c070221e11f /dev-libs/fribidi/fribidi-1.0.7.ebuild
parentdev-ruby/rest-client: add 2.1.0 (diff)
downloadgentoo-6f628f98e81f5a15a33fd01b6b4e8ee3a8bb34dc.tar.gz
gentoo-6f628f98e81f5a15a33fd01b6b4e8ee3a8bb34dc.tar.bz2
gentoo-6f628f98e81f5a15a33fd01b6b4e8ee3a8bb34dc.zip
dev-libs/fribidi: bump to 1.0.7
Closes: https://bugs.gentoo.org/696786 Closes: https://bugs.gentoo.org/662658 Package-Manager: Portage-2.3.69, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'dev-libs/fribidi/fribidi-1.0.7.ebuild')
-rw-r--r--dev-libs/fribidi/fribidi-1.0.7.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-libs/fribidi/fribidi-1.0.7.ebuild b/dev-libs/fribidi/fribidi-1.0.7.ebuild
new file mode 100644
index 000000000000..ec4204eaddb6
--- /dev/null
+++ b/dev-libs/fribidi/fribidi-1.0.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal
+
+DESCRIPTION="A free implementation of the unicode bidirectional algorithm"
+HOMEPAGE="https://fribidi.org/"
+SRC_URI="https://github.com/fribidi/fribidi/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+RDEPEND=""
+DEPEND=""
+BDEPEND="
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+"
+
+DOCS=( AUTHORS NEWS ChangeLog THANKS ) # README points at README.md which wasn't disted with EAPI-7
+
+multilib_src_configure() {
+ local myeconfargs=(
+ --enable-shared
+ $(use_enable static-libs static)
+ --disable-debug
+ )
+ ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${ED}" -name '*.la' -delete || die
+}