summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/gmime
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/gmime')
-rw-r--r--dev-libs/gmime/Manifest1
-rw-r--r--dev-libs/gmime/gmime-2.6.20.ebuild70
-rw-r--r--dev-libs/gmime/metadata.xml5
3 files changed, 76 insertions, 0 deletions
diff --git a/dev-libs/gmime/Manifest b/dev-libs/gmime/Manifest
new file mode 100644
index 000000000000..8e9f0df120ad
--- /dev/null
+++ b/dev-libs/gmime/Manifest
@@ -0,0 +1 @@
+DIST gmime-2.6.20.tar.xz 740696 SHA256 e0a170fb264c2ae4cecd852f4e7aaddb8d58e8f3f0b569ce2d2a4704f55bdf65 SHA512 8a43cc57fb2884a0d0979dd42775aa0946d11f460beb33fc7f7a166bcabb81b9590426072eeb606e2d5423ac4d68ff73d619fee96f33669f62069fcccfaf0a10 WHIRLPOOL efa42a42f4e3a1b92609307f8b9d26e7d93d42cf5545f988a8ecf1f2a6c574ecb6957cc4ed1d62aa60540e8aa802a4b2dba816677c23aa1f0d3a0e8228eb5b22
diff --git a/dev-libs/gmime/gmime-2.6.20.ebuild b/dev-libs/gmime/gmime-2.6.20.ebuild
new file mode 100644
index 000000000000..004d7c6c93be
--- /dev/null
+++ b/dev-libs/gmime/gmime-2.6.20.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+VALA_USE_DEPEND="vapigen"
+
+inherit eutils mono-env gnome2 vala
+
+DESCRIPTION="Utilities for creating and parsing messages using MIME"
+HOMEPAGE="http://spruce.sourceforge.net/gmime/ http://developer.gnome.org/gmime/stable/"
+
+SLOT="2.6"
+LICENSE="LGPL-2.1"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="doc mono static-libs vala"
+
+RDEPEND="
+ >=dev-libs/glib-2.18:2
+ sys-libs/zlib
+ >=app-crypt/gpgme-1.1.6
+ mono? (
+ dev-lang/mono
+ >=dev-dotnet/glib-sharp-2.4.0:2 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.8
+ virtual/pkgconfig
+ doc? ( app-text/docbook-sgml-utils )
+ mono? ( dev-dotnet/gtk-sharp-gapi:2 )
+ vala? (
+ $(vala_depend)
+ >=dev-libs/gobject-introspection-1.30.0 )
+"
+
+pkg_setup() {
+ use mono && mono-env_pkg_setup
+}
+
+src_prepare() {
+ gnome2_src_prepare
+ use vala && vala_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --enable-cryptography \
+ --disable-strict-parser \
+ $(use_enable mono) \
+ $(use_enable static-libs static) \
+ $(use_enable vala)
+}
+
+src_compile() {
+ MONO_PATH="${S}" gnome2_src_compile
+ if use doc; then
+ emake -C docs/tutorial html
+ fi
+}
+
+src_install() {
+ GACUTIL_FLAGS="/root '${ED}/usr/$(get_libdir)' /gacdir '${EPREFIX}/usr/$(get_libdir)' /package ${PN}" \
+ gnome2_src_install
+
+ if use doc ; then
+ docinto tutorial
+ dodoc docs/tutorial/html/*
+ fi
+}
diff --git a/dev-libs/gmime/metadata.xml b/dev-libs/gmime/metadata.xml
new file mode 100644
index 000000000000..da6fd63d0085
--- /dev/null
+++ b/dev-libs/gmime/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>