summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernardo Meurer <bernardo@standard.ai>2019-09-06 14:11:39 -0700
committerJoonas Niilola <juippis@gentoo.org>2019-09-07 11:11:06 +0300
commit73a70b2440838a24eb598e7a5a5381f4dafd3f92 (patch)
treedad93b95c53e2eabb7d2ece3085d0b3ac5deaee6 /dev-libs/granite
parentsys-apps/nix: drop old (diff)
downloadgentoo-73a70b2440838a24eb598e7a5a5381f4dafd3f92.tar.gz
gentoo-73a70b2440838a24eb598e7a5a5381f4dafd3f92.tar.bz2
gentoo-73a70b2440838a24eb598e7a5a5381f4dafd3f92.zip
dev-libs/granite: bump 5.2.5
Closes: https://bugs.gentoo.org/693628 Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: Bernardo Meurer <bernardo@standard.ai> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-libs/granite')
-rw-r--r--dev-libs/granite/Manifest1
-rw-r--r--dev-libs/granite/granite-5.2.5.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-libs/granite/Manifest b/dev-libs/granite/Manifest
index 9b7e8b61fc73..cd405f81d987 100644
--- a/dev-libs/granite/Manifest
+++ b/dev-libs/granite/Manifest
@@ -1,2 +1,3 @@
DIST granite-0.5.0.tar.gz 365015 BLAKE2B 47b88d0b08a300fecc561161e1722cc1a544f58580d21244b6584f6aba7756afe6548dd663620fe9a09406fc0be2766b1d1093a21d262a5ab001992f309239ed SHA512 6042f40c1338768281ab3e6ad0bfdd8c5c69fc4951a069b0779a22b8999b35110ea8f09cf025dd88bafef7eca6cc0d076a608d55f01c078186e150908f8e4650
DIST granite-5.2.4.tar.gz 390145 BLAKE2B 30abee1669bf2211aa776a5ddf38b914bc95e466f2853f4e852b77947b666c06ce8ac77a47b22bce0cdbf8e6804935007b5cef700c49db302528b7bbb0063543 SHA512 3a52a92a49f887bb802754b99b7c9c3fd13c197c74da7c25f1fd4c03b76d916197079b813909d2cceb11cb10b26e9f64978563b95319d0c744c5b612c50ce306
+DIST granite-5.2.5.tar.gz 392987 BLAKE2B 507c3b810b750257a66195b45842a7664eb544f86a8606124d30d277c03680296f1ace7a9233d6e094ad5ce3357564e13b61d946f8ed926ccf22a5d9b5e98648 SHA512 64a08293bc4b33d77206c7070b4e2002dd8e2da8a358e43074b681a9228790dcb342d3a705cfc0309a7e1e7f498a2a656e972c2fee085ba99fb5214e33758fc3
diff --git a/dev-libs/granite/granite-5.2.5.ebuild b/dev-libs/granite/granite-5.2.5.ebuild
new file mode 100644
index 000000000000..29e4040c1284
--- /dev/null
+++ b/dev-libs/granite/granite-5.2.5.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+VALA_MIN_API_VERSION=0.40
+
+inherit meson vala xdg-utils
+
+DESCRIPTION="Elementary OS library that extends GTK+"
+HOMEPAGE="https://github.com/elementary/granite"
+SRC_URI="https://github.com/elementary/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+# FIXME: Figure out issues with enabling doc.
+# See https://github.com/gentoo/gentoo/pull/12690#issuecomment-525027164
+IUSE="test"
+
+BDEPEND="
+ $(vala_depend)
+ >=dev-util/meson-0.48.2
+ virtual/pkgconfig
+"
+DEPEND="
+ >=dev-libs/glib-2.50:2
+ dev-libs/libgee:0.8[introspection]
+ >=x11-libs/gtk+-3.22:3[introspection]
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ vala_src_prepare
+ eapply_user
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}