summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-13 03:09:29 +0100
committerSam James <sam@gentoo.org>2022-10-13 03:09:29 +0100
commitc62cc75cdbc276c37bf8d2c2af9b2cbbe88928a1 (patch)
tree8e284b2d5ae4275a6b72b3361df7e2897b9b5e4f /dev-libs/http-fetcher/http-fetcher-1.1.0-r2.ebuild
parentwww-client/elinks: add 0.15.1 (diff)
downloadgentoo-c62cc75cdbc276c37bf8d2c2af9b2cbbe88928a1.tar.gz
gentoo-c62cc75cdbc276c37bf8d2c2af9b2cbbe88928a1.tar.bz2
gentoo-c62cc75cdbc276c37bf8d2c2af9b2cbbe88928a1.zip
dev-libs/http-fetcher: fix underquoted http-fetcher.m4 macro again
Bug: https://bugs.gentoo.org/299940 Closes: https://bugs.gentoo.org/876911 Fixes: 9c3bfee419467b417400fe45921205b502e17d68 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/http-fetcher/http-fetcher-1.1.0-r2.ebuild')
-rw-r--r--dev-libs/http-fetcher/http-fetcher-1.1.0-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-libs/http-fetcher/http-fetcher-1.1.0-r2.ebuild b/dev-libs/http-fetcher/http-fetcher-1.1.0-r2.ebuild
new file mode 100644
index 000000000000..97ad5484327a
--- /dev/null
+++ b/dev-libs/http-fetcher/http-fetcher-1.1.0-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+MY_P="${P/-/_}"
+
+DESCRIPTION="Library for downloading files via HTTP using the GET method"
+HOMEPAGE="http://http-fetcher.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha amd64 ppc x86"
+IUSE="debug"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.0-underquoted-http-fetcher-macro.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-strict \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+ dodoc -r docs/html/*.html docs/index.html README ChangeLog CREDITS INSTALL
+
+ find "${ED}" -name '*.la' -delete || die
+}