summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2024-06-23 22:49:09 +0200
committerDavid Seifert <soap@gentoo.org>2024-06-23 22:49:09 +0200
commit522f8c2869ba4b57ed3b0e6cd2afbe528df27a11 (patch)
tree5f5da458eefa2ad4a73be8f09bda3af0a7f827e5 /dev-libs/igraph
parentsci-chemistry/gromacs: Add ~riscv keyword (diff)
downloadgentoo-522f8c2869ba4b57ed3b0e6cd2afbe528df27a11.tar.gz
gentoo-522f8c2869ba4b57ed3b0e6cd2afbe528df27a11.tar.bz2
gentoo-522f8c2869ba4b57ed3b0e6cd2afbe528df27a11.zip
dev-libs/igraph: drop 0.10.4-r1, 0.10.10
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-libs/igraph')
-rw-r--r--dev-libs/igraph/Manifest2
-rw-r--r--dev-libs/igraph/files/808c083fbe661207ee8f0fcd3be5096b5dc17d0d.patch35
-rw-r--r--dev-libs/igraph/igraph-0.10.10.ebuild54
-rw-r--r--dev-libs/igraph/igraph-0.10.4-r1.ebuild55
4 files changed, 0 insertions, 146 deletions
diff --git a/dev-libs/igraph/Manifest b/dev-libs/igraph/Manifest
index 4c0c33ccd640..aa681c39ebf0 100644
--- a/dev-libs/igraph/Manifest
+++ b/dev-libs/igraph/Manifest
@@ -1,4 +1,2 @@
-DIST igraph-0.10.10.tar.gz 4336247 BLAKE2B cef87afe544d09446c999894c44e1d56120cac74b6af5d749835fbf60e5ae0f1676d6754e084f167d23718c6ce9f7b8cee159d3d670d1d5f1f495775c7b0d2f0 SHA512 d4b8d29f9c39f8390c442877183e64c442fccbc6a02b3aed5c1d8871ca5998d1a168f392f8dde26a8c3593ed6c09a66a200ac1155fbde87d368b101011bb122c
DIST igraph-0.10.11.tar.gz 4349830 BLAKE2B 3aae088115148d1f965a52f01c950000097520fb0a150d2ad1fabb96cff434a9b548a6c17a10b9e0ebad3a577c2423ac5260cd28223147d3dc71b0d4fe139a95 SHA512 d6978589f12ed20b87777394b46f47b4ffc045ef693e5b4fc90163b9482361b2bf0ed2bb04aa99bf4a0653f7e4355cd480b0a165213d90ff7188ef6c86147c86
DIST igraph-0.10.12.tar.gz 4373463 BLAKE2B b7fdd7046185bf501c9302721f6606e6affc0d91c16d195c6bd69e0b32f9dca7af701a963fd4a8b8558ac843fe4a5136c7fce2fe5595db469818e514db2325ac SHA512 1a7b055ab2148fdf04187d785895b930ae2a54ae0240ea9656e129a38347b1caeb28dda5a3a7e34282462363150d7afd25acf8cd335577ed441b8a5cecc0dd25
-DIST igraph-0.10.4.tar.gz 4279321 BLAKE2B 4e1fc8e8d6dd38cdb24ec564f51f2924e457376c258497b51d7dd4cec88d2226d5b202cdcfa69560e43fdb3cbd49656511178acd2ed705b4af26b1947a92f1ab SHA512 71bcec5f0ba100aae7614753f9232a4221580b822b4dc120e3a80eab59d70c42aedddb00728eb13faf7e522332c514c2e030314c416ded8a70e5de990ea8039b
diff --git a/dev-libs/igraph/files/808c083fbe661207ee8f0fcd3be5096b5dc17d0d.patch b/dev-libs/igraph/files/808c083fbe661207ee8f0fcd3be5096b5dc17d0d.patch
deleted file mode 100644
index 4bf0f2c6c3a9..000000000000
--- a/dev-libs/igraph/files/808c083fbe661207ee8f0fcd3be5096b5dc17d0d.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-From 808c083fbe661207ee8f0fcd3be5096b5dc17d0d Mon Sep 17 00:00:00 2001
-From: David Seifert <soap@gentoo.org>
-Date: Tue, 5 Mar 2024 14:54:46 +0100
-Subject: [PATCH] Fix `-Wstrict-aliasing`
-
-* Casting a `uint64_t*` to `double*` invokes undefined behavior, since
- it violates the strict aliasing rules of ISO C. Instead of casting
- pointers, let's read through a union which is supported by C and
- yields the same performant assembly code.
-
-Closes: https://bugs.gentoo.org/924864
----
- src/random/random.c | 9 +++++++--
- 1 file changed, 7 insertions(+), 2 deletions(-)
-
-diff --git a/src/random/random.c b/src/random/random.c
-index 8f2d0898aa..b5b44451ae 100644
---- a/src/random/random.c
-+++ b/src/random/random.c
-@@ -681,8 +681,13 @@ igraph_real_t igraph_rng_get_unif01(igraph_rng_t *rng) {
- * Then we subtract 1 to arrive at the [0; 1) interval. This is fast
- * but we lose one bit of precision as there are 2^53 possible doubles
- * between 0 and 1. */
-- uint64_t r = (igraph_i_rng_get_random_bits_uint64(rng, 52) & 0xFFFFFFFFFFFFFull) | 0x3FF0000000000000ull;
-- return *(double *)(&r) - 1.0;
-+ union {
-+ uint64_t as_uint64_t;
-+ double as_double;
-+ } value;
-+ value.as_uint64_t =
-+ (igraph_i_rng_get_random_bits_uint64(rng, 52) & 0xFFFFFFFFFFFFFull) | 0x3FF0000000000000ull;
-+ return value.as_double - 1.0;
- }
- }
-
diff --git a/dev-libs/igraph/igraph-0.10.10.ebuild b/dev-libs/igraph/igraph-0.10.10.ebuild
deleted file mode 100644
index 7f5111f0726e..000000000000
--- a/dev-libs/igraph/igraph-0.10.10.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="Creating and manipulating undirected and directed graphs"
-HOMEPAGE="https://igraph.org/"
-SRC_URI="https://github.com/igraph/igraph/releases/download/${PV}/${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0/0"
-KEYWORDS="~amd64 ~x86"
-
-IUSE="debug test threads"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-libs/gmp:0=
- dev-libs/libxml2
- sci-libs/arpack
- sci-mathematics/glpk:=
- sci-mathematics/plfit
- virtual/blas
- virtual/lapack"
-DEPEND="${RDEPEND}"
-
-PATCHES=(
- # backport fix for strict-aliasing
- "${FILESDIR}"/808c083fbe661207ee8f0fcd3be5096b5dc17d0d.patch
-)
-
-src_configure() {
- local mycmakeargs=(
- -DUSE_CCACHE=OFF
- -DIGRAPH_GLPK_SUPPORT=ON
- -DIGRAPH_GRAPHML_SUPPORT=ON
- -DIGRAPH_USE_INTERNAL_ARPACK=OFF
- -DIGRAPH_USE_INTERNAL_BLAS=OFF
- -DIGRAPH_USE_INTERNAL_GLPK=OFF
- -DIGRAPH_USE_INTERNAL_GMP=OFF
- -DIGRAPH_USE_INTERNAL_LAPACK=OFF
- -DIGRAPH_USE_INTERNAL_PLFIT=OFF
- -DIGRAPH_ENABLE_TLS=$(usex threads)
- -DIGRAPH_WARNINGS_AS_ERRORS=OFF
- -DBUILD_TESTING=$(usex test)
- )
- cmake_src_configure
-}
-
-src_test() {
- cmake_build check
-}
diff --git a/dev-libs/igraph/igraph-0.10.4-r1.ebuild b/dev-libs/igraph/igraph-0.10.4-r1.ebuild
deleted file mode 100644
index a8d0b8c64efd..000000000000
--- a/dev-libs/igraph/igraph-0.10.4-r1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake flag-o-matic
-
-DESCRIPTION="Creating and manipulating undirected and directed graphs"
-HOMEPAGE="https://igraph.org/"
-SRC_URI="https://github.com/igraph/igraph/releases/download/${PV}/${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0/0"
-KEYWORDS="amd64 x86"
-
-IUSE="debug test threads"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-libs/gmp:0=
- dev-libs/libxml2
- sci-libs/arpack
- sci-mathematics/glpk:=
- sci-mathematics/plfit
- virtual/blas
- virtual/lapack"
-DEPEND="${RDEPEND}"
-
-src_configure() {
- # -Werror=strict-aliasing
- #
- # Fixed in upstream git master.
- append-flags -fno-strict-aliasing
- filter-lto
-
- local mycmakeargs=(
- -DUSE_CCACHE=OFF
- -DIGRAPH_GLPK_SUPPORT=ON
- -DIGRAPH_GRAPHML_SUPPORT=ON
- -DIGRAPH_USE_INTERNAL_ARPACK=OFF
- -DIGRAPH_USE_INTERNAL_BLAS=OFF
- -DIGRAPH_USE_INTERNAL_GLPK=OFF
- -DIGRAPH_USE_INTERNAL_GMP=OFF
- -DIGRAPH_USE_INTERNAL_LAPACK=OFF
- -DIGRAPH_USE_INTERNAL_PLFIT=OFF
- -DIGRAPH_ENABLE_TLS=$(usex threads)
- -DIGRAPH_WARNINGS_AS_ERRORS=OFF
- -DBUILD_TESTING=$(usex test)
- )
- cmake_src_configure
-}
-
-src_test() {
- cmake_build check
-}