summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Parborg <sebastian@blender.org>2024-07-15 12:23:41 +0200
committerSam James <sam@gentoo.org>2024-07-16 08:04:02 +0100
commit0714fbf442a91ed7c66bbb9cc1fb0ded03bb1c3c (patch)
tree506a5a2c77eb1500ebae3884f6019923a2b1254c /dev-libs/immer
parentdev-libs/zug: Add missing boost dependency, fix Werror added per default (diff)
downloadgentoo-0714fbf442a91ed7c66bbb9cc1fb0ded03bb1c3c.tar.gz
gentoo-0714fbf442a91ed7c66bbb9cc1fb0ded03bb1c3c.tar.bz2
gentoo-0714fbf442a91ed7c66bbb9cc1fb0ded03bb1c3c.zip
dev-libs/immer: Add missing libfmt dep for tests
Closes: https://bugs.gentoo.org/936024 Signed-off-by: Sebastian Parborg <darkdefende@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/immer')
-rw-r--r--dev-libs/immer/immer-0.8.1-r1.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-libs/immer/immer-0.8.1-r1.ebuild b/dev-libs/immer/immer-0.8.1-r1.ebuild
new file mode 100644
index 000000000000..65da2ecbf6f6
--- /dev/null
+++ b/dev-libs/immer/immer-0.8.1-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Library of persistent and immutable data structures written in C++"
+HOMEPAGE="https://sinusoid.es/immer/"
+SRC_URI="https://github.com/arximboldi/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-libs/boehm-gc
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ test? (
+ <dev-cpp/catch-3:0
+ dev-libs/libfmt
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-dvector-test.patch
+)
+
+src_configure() {
+ local mycmakeargs=(
+ -DCCACHE=no
+ -Dimmer_BUILD_DOCS=OFF # Recheck if documentation is in a better state when bumping
+ -Dimmer_BUILD_EXAMPLES=OFF
+ -Dimmer_BUILD_EXTRAS=OFF
+ -Dimmer_BUILD_TESTS=$(usex test)
+ -DDISABLE_WERROR=ON
+ )
+ cmake_src_configure
+}
+
+src_compile() {
+ cmake_src_compile
+ if use test; then
+ cmake_build tests
+ fi
+}