summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars <polynomial-c@gentoo.org>2016-11-03 11:57:34 +0100
committerLars Wendler <polynomial-c@gentoo.org>2016-11-03 16:31:58 +0100
commitfd6313631179bba8b0e2b9d9cedeadc2d2151ad1 (patch)
tree1e3ce8e71eda924c9f30e853776eaf7d8938ee7c /dev-libs/jansson
parentdev-ruby/actionview: revert accidental stablisation (diff)
downloadgentoo-fd6313631179bba8b0e2b9d9cedeadc2d2151ad1.tar.gz
gentoo-fd6313631179bba8b0e2b9d9cedeadc2d2151ad1.tar.bz2
gentoo-fd6313631179bba8b0e2b9d9cedeadc2d2151ad1.zip
dev-libs/jansson: Bump to version 2.9 (bug #598832) and to EAPI-6.
Added multilib support (bug 570006). This release also fixes the security issue reported in bug #581954. Closes: https://github.com/gentoo/gentoo/pull/2728 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-libs/jansson')
-rw-r--r--dev-libs/jansson/Manifest1
-rw-r--r--dev-libs/jansson/jansson-2.9.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-libs/jansson/Manifest b/dev-libs/jansson/Manifest
index b8cfed493122..de26676daf1a 100644
--- a/dev-libs/jansson/Manifest
+++ b/dev-libs/jansson/Manifest
@@ -1 +1,2 @@
DIST jansson-2.7.tar.gz 445179 SHA256 7905e6590fb316c0ff943df3dc6a21cd81a59cff7a6d12514054c359d04d78d7 SHA512 657b715868c2fbf8da1e41befee2691524190e12255214c472652ca3e3793b03e2b384dc3aedb1071b67b0b8cb57fd495103979983fe21a2404f12cd70295a28 WHIRLPOOL 684c0a1cae8cbd86d1a4e19bcfa59f36bf6094853ce5e18bd600fcb27fb1afac250e52c1983f888fcae06437c6e142b2ea3823c911b5a2923f4775494d26690f
+DIST jansson-2.9.tar.gz 485095 SHA256 0ad0d074ca049a36637e7abef755d40849ad73e926b93914ce294927b97bd2a5 SHA512 ae239e1a825c252d7a3b0ee97004c129a0968f7e9da8679dc665a8e54a34c073b0c274bd5af004700b442f7b703bcc76f5e3360ab82172da7203b3458a5e9cb9 WHIRLPOOL 2b9103702680f0e03f5220530938dfcd8fb1b793383bf459200e0e05fffcfd5ec7cecd904ba7fc3c55f237d98f94b6a97c26c3f89b5b26ebcaa830e2eecd4b1f
diff --git a/dev-libs/jansson/jansson-2.9.ebuild b/dev-libs/jansson/jansson-2.9.ebuild
new file mode 100644
index 000000000000..c353e571bc7c
--- /dev/null
+++ b/dev-libs/jansson/jansson-2.9.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools multilib-minimal
+
+DESCRIPTION="C library for encoding, decoding and manipulating JSON data"
+HOMEPAGE="http://www.digip.org/jansson/"
+SRC_URI="http://www.digip.org/jansson/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc static-libs"
+
+DEPEND="doc? ( >=dev-python/sphinx-1.0.4 )"
+RDEPEND=""
+
+src_prepare() {
+ default
+ sed -ie 's/-Werror//' src/Makefile.am || die
+ eautoreconf
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" \
+ econf \
+ $(use_enable static-libs static)
+}
+
+multilib_src_compile() {
+ default
+
+ if multilib_is_native_abi && use doc ; then
+ emake html
+ HTML_DOCS=( "${BUILD_DIR}"/doc/_build/html/. )
+ fi
+}