summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <mthode@mthode.org>2015-08-27 16:20:34 -0500
committerMatthew Thode <mthode@mthode.org>2015-08-27 16:22:01 -0500
commit56240c05e5e9fcbeabef53b465f01dadda09b4bb (patch)
tree200bdf9eccfefcdc558ca0af4cf2bf14f850fdf1 /dev-libs/jerasure/jerasure-0.0.0.ebuild
parentdev-lisp/sbcl: bump to version 1.2.14 (diff)
downloadgentoo-56240c05e5e9fcbeabef53b465f01dadda09b4bb.tar.gz
gentoo-56240c05e5e9fcbeabef53b465f01dadda09b4bb.tar.bz2
gentoo-56240c05e5e9fcbeabef53b465f01dadda09b4bb.zip
herd/openstack: Split out libs from dev-python/PyECLib
gentoo-bug: 558884 gentoo-bug: 558886
Diffstat (limited to 'dev-libs/jerasure/jerasure-0.0.0.ebuild')
-rw-r--r--dev-libs/jerasure/jerasure-0.0.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-libs/jerasure/jerasure-0.0.0.ebuild b/dev-libs/jerasure/jerasure-0.0.0.ebuild
new file mode 100644
index 000000000000..458a416eef93
--- /dev/null
+++ b/dev-libs/jerasure/jerasure-0.0.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="A Library in C Facilitating Erasure Coding for Storage Applications"
+HOMEPAGE="http://jerasure.org/"
+SRC_URI="https://dev.gentoo.org/~prometheanfire/dist/${P}.tar.gz"
+S="${WORKDIR}/${PN}.git"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/gf-complete"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e 's/ $(SIMD_FLAGS)//g' src/Makefile.am Examples/Makefile.am || die
+ eautoreconf
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}