summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-20 22:51:58 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-20 22:53:07 +0100
commit789eeda52dd189206a7e15faf9e0eeb4a9897a00 (patch)
tree54b06f82f766309853a0b667e6baeeed0f5b8ee7 /dev-libs/jsoncpp
parentmedia-sound/rosegarden: bump 19.12 (diff)
downloadgentoo-789eeda52dd189206a7e15faf9e0eeb4a9897a00.tar.gz
gentoo-789eeda52dd189206a7e15faf9e0eeb4a9897a00.tar.bz2
gentoo-789eeda52dd189206a7e15faf9e0eeb4a9897a00.zip
dev-libs/jsoncpp: Switch to meson
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-libs/jsoncpp')
-rw-r--r--dev-libs/jsoncpp/jsoncpp-1.9.2-r2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-libs/jsoncpp/jsoncpp-1.9.2-r2.ebuild b/dev-libs/jsoncpp/jsoncpp-1.9.2-r2.ebuild
new file mode 100644
index 000000000000..311eab1e8127
--- /dev/null
+++ b/dev-libs/jsoncpp/jsoncpp-1.9.2-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} )
+
+inherit meson python-any-r1
+
+DESCRIPTION="C++ JSON reader and writer"
+HOMEPAGE="https://github.com/open-source-parsers/jsoncpp"
+SRC_URI="https://github.com/open-source-parsers/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( public-domain MIT )"
+SLOT="0/22"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ ${PYTHON_DEPS}
+ doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+src_configure() {
+ local emesonargs=(
+ # Follow Debian, Ubuntu, Arch convention for headers location
+ # bug #452234
+ --includedir include/jsoncpp
+ )
+ meson_src_configure
+}
+
+src_compile() {
+ meson_src_compile
+
+ if use doc; then
+ cp "${BUILD_DIR}"/version . || die
+ "${EPYTHON}" doxybuild.py --doxygen="${EPREFIX}"/usr/bin/doxygen || die
+ HTML_DOCS=( dist/doxygen/jsoncpp*/. )
+ fi
+}