summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-04-18 13:47:44 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-04-18 17:25:20 +0200
commit06758ca37f450c97e6eb5bcdee1d9538e032f251 (patch)
tree97c555eacd13b04e942a0ddfb1718796797ef806 /dev-libs/libcdio-paranoia
parentdev-libs/libcdio-paranoia: Bump to version 2.0.0 (diff)
downloadgentoo-06758ca37f450c97e6eb5bcdee1d9538e032f251.tar.gz
gentoo-06758ca37f450c97e6eb5bcdee1d9538e032f251.tar.bz2
gentoo-06758ca37f450c97e6eb5bcdee1d9538e032f251.zip
dev-libs/libcdio-paranoia: Removed old.
Package-Manager: Portage-2.3.63, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-libs/libcdio-paranoia')
-rw-r--r--dev-libs/libcdio-paranoia/Manifest1
-rw-r--r--dev-libs/libcdio-paranoia/libcdio-paranoia-0.93_p1-r1.ebuild66
-rw-r--r--dev-libs/libcdio-paranoia/libcdio-paranoia-0.94_p1-r1.ebuild71
3 files changed, 0 insertions, 138 deletions
diff --git a/dev-libs/libcdio-paranoia/Manifest b/dev-libs/libcdio-paranoia/Manifest
index e4b1ed9ce4f..7fce00f8b7d 100644
--- a/dev-libs/libcdio-paranoia/Manifest
+++ b/dev-libs/libcdio-paranoia/Manifest
@@ -1,5 +1,4 @@
DIST libcdio-paranoia-10.2+0.90+1.tar.gz 634050 BLAKE2B 10a7f8b2a45e5605afa6961132f0bf949ba51222a6c23b7a933032e3e430e60104eae8f7d49fc6ec18894fe0e826e9387f67f186af0ba277a9e7341484aa8ac3 SHA512 c3d00b57f22deb19be929ba87f41bbd83fc51ca66e8ccc1da7acb4131d85449fdd38161cc3ec0f1714fc0571e219d72029b5a72f853c139aa479695df783aad6
DIST libcdio-paranoia-10.2+0.93+1.tar.gz 686055 BLAKE2B 5b4c30687c907cc8dd0917263c20e3d55e425cb7fb2a935a79ec6c5cc82c6165a5504fe71b77e314bd4a828b0c652f948cce62fecf94341d20c920c66450d97a SHA512 2bb418c99ef037aeb90ba3db841ea9182c5bc401e74c6f4b552730e6c8561552f7d3e27be71ef4fbb07b4fcd9db418a4fe330d5278e8f41cdd99c757aa4b8bc6
-DIST libcdio-paranoia-10.2+0.94+1.tar.gz 703424 BLAKE2B 592ac7704f60e7701cff4edb7e4dc532cb35603ef47c159c84c6aa8bfa69bdc41e435ac566fd0483cee2a2fd1d03a31202382fc1ccaf179c9183f324d5605d80 SHA512 9b2381491271090bac08594cb1d84de98e9f0a5afc6a2c98e9ffcf4b95addc3adcd0f0b9adeb928dfbf8178356ad6a7ccfeb048685c823d138b2af232f0b4c93
DIST libcdio-paranoia-10.2+0.94+2.tar.gz 704560 BLAKE2B babb912a7252b25b1d32f7d3cc80d73235383170b16118c4f6fcddd58ded534b2e5a8bb61aa8ca784270fc4631ea3e53cdc88d03b0a7686f74ab1cef7ca35980 SHA512 0e4ed5cc52d0758e945ac7f956c1ca870068f6444df912e2ba5f597947962c471d1c526b5cdab4e092fecb924ecb317667df454497b2e515a4e985693cd86f47
DIST libcdio-paranoia-10.2+2.0.0.tar.bz2 588472 BLAKE2B 5593c967cc91e7db922c30a0e4fd6a71c81625527b3e3cd19494328c545237c64c6332969e6964ae27cce70b0a7ed9678c2dcf0cf675ea6ea81602071b5a9e1b SHA512 0398617f9af63632d74c5a93c4efae1bc69d339fb7ab2e36dbfa6d19c0940f3bf27ea3ed482698d2842838d2034df3e40304774f1648db8c274d441130ef40a2
diff --git a/dev-libs/libcdio-paranoia/libcdio-paranoia-0.93_p1-r1.ebuild b/dev-libs/libcdio-paranoia/libcdio-paranoia-0.93_p1-r1.ebuild
deleted file mode 100644
index 4e154159b78..00000000000
--- a/dev-libs/libcdio-paranoia/libcdio-paranoia-0.93_p1-r1.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-MY_P=${PN}-10.2+${PV/_p/+}
-
-inherit autotools multilib-minimal flag-o-matic
-
-DESCRIPTION="an advanced CDDA reader with error correction"
-HOMEPAGE="https://www.gnu.org/software/libcdio/"
-SRC_URI="mirror://gnu/${PN%-*}/${MY_P}.tar.gz"
-
-# COPYING-GPL from cdparanoia says "2 or later"
-# COPYING-LGPL from cdparanoia says "2.1 or later" but 2 files are without the
-# clause "or later" so we use LGPL-2.1 without +
-LICENSE="GPL-3+ GPL-2+ LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE="+cxx static-libs test"
-
-RDEPEND="app-eselect/eselect-cdparanoia
- >=dev-libs/libcdio-0.93:0=[${MULTILIB_USEDEP}]
- >=virtual/libiconv-0-r1[${MULTILIB_USEDEP}]
-"
-
-DEPEND="${RDEPEND}
- sys-devel/gettext
- virtual/pkgconfig
- test? ( dev-lang/perl )"
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS=( AUTHORS ChangeLog NEWS README THANKS )
-
-PATCHES=("${FILESDIR}"/${PN}-0.90-oos-tests.patch)
-
-src_prepare() {
- default
- sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.ac || die #466410
- eautoreconf
-
- [[ ${CC} == *clang* ]] && append-flags -std=gnu89
-}
-
-multilib_src_configure() {
- local myeconfargs=(
- --disable-maintainer-mode
- --disable-example-progs
- $(use_enable cxx)
- --disable-cpp-progs
- --with-cd-paranoia-name=libcdio-paranoia
- )
- # Darwin linker doesn't get this
- [[ ${CHOST} == *-darwin* ]] && myeconfargs+=( --without-versioned-libs )
- ECONF_SOURCE="${S}" \
- econf "${myeconfargs[@]}"
-}
-
-pkg_postinst() {
- eselect cdparanoia update ifunset
-}
-
-pkg_postrm() {
- eselect cdparanoia update ifunset
-}
diff --git a/dev-libs/libcdio-paranoia/libcdio-paranoia-0.94_p1-r1.ebuild b/dev-libs/libcdio-paranoia/libcdio-paranoia-0.94_p1-r1.ebuild
deleted file mode 100644
index 0fe60647a42..00000000000
--- a/dev-libs/libcdio-paranoia/libcdio-paranoia-0.94_p1-r1.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-MY_P=${PN}-10.2+${PV/_p/+}
-
-inherit eutils autotools multilib-minimal flag-o-matic
-
-DESCRIPTION="an advanced CDDA reader with error correction"
-HOMEPAGE="https://www.gnu.org/software/libcdio/"
-SRC_URI="mirror://gnu/${PN%-*}/${MY_P}.tar.gz"
-
-# COPYING-GPL from cdparanoia says "2 or later"
-# COPYING-LGPL from cdparanoia says "2.1 or later" but 2 files are without the
-# clause "or later" so we use LGPL-2.1 without +
-LICENSE="GPL-3+ GPL-2+ LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE="+cxx static-libs test"
-
-RDEPEND="app-eselect/eselect-cdparanoia
- >=dev-libs/libcdio-0.94:0=[${MULTILIB_USEDEP}]
- >=virtual/libiconv-0-r1[${MULTILIB_USEDEP}]
-"
-
-DEPEND="${RDEPEND}
- sys-devel/gettext
- virtual/pkgconfig
- test? ( dev-lang/perl )"
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS=( AUTHORS ChangeLog NEWS README.md THANKS )
-
-PATCHES=("${FILESDIR}"/${PN}-0.90-oos-tests.patch)
-
-src_prepare() {
- default
- sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.ac || die #466410
- eautoreconf
-
- [[ ${CC} == *clang* ]] && append-flags -std=gnu89
-}
-
-multilib_src_configure() {
- local myeconfargs=(
- --disable-maintainer-mode
- --disable-example-progs
- $(use_enable cxx)
- --disable-cpp-progs
- --with-cd-paranoia-name=libcdio-paranoia
- # upstream accidentally default-disabled it
- # reenable it to preserve ABI compat with previous versions
- # https://bugs.gentoo.org/616054
- # https://savannah.gnu.org/bugs/index.php?50978
- --enable-ld-version-script
- )
- # Darwin linker doesn't get this
- [[ ${CHOST} == *-darwin* ]] && myeconfargs+=( --disable-ld-version-script )
- ECONF_SOURCE="${S}" \
- econf "${myeconfargs[@]}"
-}
-
-pkg_postinst() {
- eselect cdparanoia update ifunset
-}
-
-pkg_postrm() {
- eselect cdparanoia update ifunset
-}