summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2018-03-27 23:39:04 -0500
committerPatrice Clement <monsieurp@gentoo.org>2018-04-12 00:47:24 +0200
commitff29e090446ea61eb4e960f31f61df189be37e4a (patch)
tree8cbf041ae85820b31d2875dd1d03d406130f26ec /dev-libs/libcdio-paranoia
parentdev-python/elasticsearch-py: version bump to 6.2.0. (diff)
downloadgentoo-ff29e090446ea61eb4e960f31f61df189be37e4a.tar.gz
gentoo-ff29e090446ea61eb4e960f31f61df189be37e4a.tar.bz2
gentoo-ff29e090446ea61eb4e960f31f61df189be37e4a.zip
dev-libs/libcdio-paranoia: removed emul-linux-x86 references.
Also removed eutils, changed autotools-multilib to autotools+multilib-minimal, replaced epatch with PATCHES=() array and default, alphabetized eclass inheritance, and standardized some of the quoting and indentation. Package-Manager: Portage-2.3.24, Repoman-2.3.6 Closes: https://github.com/gentoo/gentoo/pull/7677
Diffstat (limited to 'dev-libs/libcdio-paranoia')
-rw-r--r--dev-libs/libcdio-paranoia/files/libcdio-paranoia-0.90-mkdir_p.patch8
-rw-r--r--dev-libs/libcdio-paranoia/libcdio-paranoia-0.90_p1-r1.ebuild26
-rw-r--r--dev-libs/libcdio-paranoia/libcdio-paranoia-0.93_p1-r1.ebuild13
-rw-r--r--dev-libs/libcdio-paranoia/libcdio-paranoia-0.93_p1.ebuild25
-rw-r--r--dev-libs/libcdio-paranoia/libcdio-paranoia-0.94_p1-r1.ebuild7
-rw-r--r--dev-libs/libcdio-paranoia/libcdio-paranoia-0.94_p2.ebuild15
6 files changed, 53 insertions, 41 deletions
diff --git a/dev-libs/libcdio-paranoia/files/libcdio-paranoia-0.90-mkdir_p.patch b/dev-libs/libcdio-paranoia/files/libcdio-paranoia-0.90-mkdir_p.patch
index 0ff4f5a6a21..98681d0a08f 100644
--- a/dev-libs/libcdio-paranoia/files/libcdio-paranoia-0.90-mkdir_p.patch
+++ b/dev-libs/libcdio-paranoia/files/libcdio-paranoia-0.90-mkdir_p.patch
@@ -2,8 +2,8 @@ http://bugs.gentoo.org/455374
http://github.com/rocky/libcdio-paranoia/issues/1
https://savannah.gnu.org/bugs/index.php?38273
---- configure.ac
-+++ configure.ac
+--- a/configure.ac
++++ b/configure.ac
@@ -74,6 +74,8 @@
dnl Checks for programs.
AC_AIX
@@ -13,8 +13,8 @@ https://savannah.gnu.org/bugs/index.php?38273
if test "x$GCC" != "xyes"
then
AC_MSG_WARN([
---- doc/ja/Makefile.am
-+++ doc/ja/Makefile.am
+--- a/doc/ja/Makefile.am
++++ b/doc/ja/Makefile.am
@@ -25,7 +25,7 @@
install-man1: $(man_MANS)
diff --git a/dev-libs/libcdio-paranoia/libcdio-paranoia-0.90_p1-r1.ebuild b/dev-libs/libcdio-paranoia/libcdio-paranoia-0.90_p1-r1.ebuild
index 2b1cbc19471..ed391732a87 100644
--- a/dev-libs/libcdio-paranoia/libcdio-paranoia-0.90_p1-r1.ebuild
+++ b/dev-libs/libcdio-paranoia/libcdio-paranoia-0.90_p1-r1.ebuild
@@ -1,12 +1,11 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-MY_P=${PN}-10.2+${PV/_p/+}
+EAPI=6
-AUTOTOOLS_AUTORECONF=yes
+MY_P=${PN}-10.2+${PV/_p/+}
-inherit eutils autotools-multilib
+inherit autotools multilib-minimal
DESCRIPTION="an advanced CDDA reader with error correction"
HOMEPAGE="https://www.gnu.org/software/libcdio/"
@@ -23,24 +22,28 @@ IUSE="+cxx static-libs test"
RDEPEND="app-eselect/eselect-cdparanoia
>=dev-libs/libcdio-0.90-r1[${MULTILIB_USEDEP}]
>=virtual/libiconv-0-r1[${MULTILIB_USEDEP}]
- abi_x86_32? ( !<=app-emulation/emul-linux-x86-medialibs-20130224-r10
- !app-emulation/emul-linux-x86-medialibs[-abi_x86_32(-)] )"
+"
+
DEPEND="${RDEPEND}
sys-devel/gettext
virtual/pkgconfig
test? ( dev-lang/perl )"
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
DOCS=( AUTHORS ChangeLog NEWS README THANKS )
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.90-mkdir_p.patch
+)
+
src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.90-mkdir_p.patch
+ default
sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.ac || die #466410
- autotools-multilib_src_prepare
+ eautoreconf
}
-src_configure() {
+multilib_src_configure() {
local myeconfargs=(
--disable-maintainer-mode
--disable-example-progs
@@ -48,7 +51,8 @@ src_configure() {
--disable-cpp-progs
--with-cd-paranoia-name=libcdio-paranoia
)
- autotools-multilib_src_configure
+ ECONF_SOURCE="${S}" \
+ econf "${myeconfargs[@]}"
}
pkg_postinst() {
diff --git a/dev-libs/libcdio-paranoia/libcdio-paranoia-0.93_p1-r1.ebuild b/dev-libs/libcdio-paranoia/libcdio-paranoia-0.93_p1-r1.ebuild
index 9aaba499157..4e154159b78 100644
--- a/dev-libs/libcdio-paranoia/libcdio-paranoia-0.93_p1-r1.ebuild
+++ b/dev-libs/libcdio-paranoia/libcdio-paranoia-0.93_p1-r1.ebuild
@@ -2,9 +2,10 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+
MY_P=${PN}-10.2+${PV/_p/+}
-inherit eutils autotools multilib-minimal flag-o-matic
+inherit autotools multilib-minimal flag-o-matic
DESCRIPTION="an advanced CDDA reader with error correction"
HOMEPAGE="https://www.gnu.org/software/libcdio/"
@@ -21,22 +22,22 @@ IUSE="+cxx static-libs test"
RDEPEND="app-eselect/eselect-cdparanoia
>=dev-libs/libcdio-0.93:0=[${MULTILIB_USEDEP}]
>=virtual/libiconv-0-r1[${MULTILIB_USEDEP}]
- abi_x86_32? ( !<=app-emulation/emul-linux-x86-medialibs-20130224-r10
- !app-emulation/emul-linux-x86-medialibs[-abi_x86_32(-)] )"
+"
+
DEPEND="${RDEPEND}
sys-devel/gettext
virtual/pkgconfig
test? ( dev-lang/perl )"
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
DOCS=( AUTHORS ChangeLog NEWS README THANKS )
PATCHES=("${FILESDIR}"/${PN}-0.90-oos-tests.patch)
src_prepare() {
- sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.ac || die #466410
default
+ sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.ac || die #466410
eautoreconf
[[ ${CC} == *clang* ]] && append-flags -std=gnu89
@@ -53,7 +54,7 @@ multilib_src_configure() {
# Darwin linker doesn't get this
[[ ${CHOST} == *-darwin* ]] && myeconfargs+=( --without-versioned-libs )
ECONF_SOURCE="${S}" \
- econf "${myeconfargs[@]}"
+ econf "${myeconfargs[@]}"
}
pkg_postinst() {
diff --git a/dev-libs/libcdio-paranoia/libcdio-paranoia-0.93_p1.ebuild b/dev-libs/libcdio-paranoia/libcdio-paranoia-0.93_p1.ebuild
index 70d769becf4..d10701c912c 100644
--- a/dev-libs/libcdio-paranoia/libcdio-paranoia-0.93_p1.ebuild
+++ b/dev-libs/libcdio-paranoia/libcdio-paranoia-0.93_p1.ebuild
@@ -1,12 +1,11 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-MY_P=${PN}-10.2+${PV/_p/+}
+EAPI=6
-AUTOTOOLS_AUTORECONF=yes
+MY_P=${PN}-10.2+${PV/_p/+}
-inherit eutils autotools-multilib flag-o-matic
+inherit autotools flag-o-matic multilib-minimal
DESCRIPTION="an advanced CDDA reader with error correction"
HOMEPAGE="https://www.gnu.org/software/libcdio/"
@@ -23,27 +22,30 @@ IUSE="+cxx static-libs test"
RDEPEND="app-eselect/eselect-cdparanoia
>=dev-libs/libcdio-0.93[${MULTILIB_USEDEP}]
>=virtual/libiconv-0-r1[${MULTILIB_USEDEP}]
- abi_x86_32? ( !<=app-emulation/emul-linux-x86-medialibs-20130224-r10
- !app-emulation/emul-linux-x86-medialibs[-abi_x86_32(-)] )"
+"
+
DEPEND="${RDEPEND}
sys-devel/gettext
virtual/pkgconfig
test? ( dev-lang/perl )"
-S=${WORKDIR}/${MY_P}
+S="${WORKDIR}/${MY_P}"
DOCS=( AUTHORS ChangeLog NEWS README THANKS )
-PATCHES=("${FILESDIR}"/${PN}-0.90-oos-tests.patch)
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.90-oos-tests.patch
+)
src_prepare() {
+ default
sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.ac || die #466410
- autotools-multilib_src_prepare
+ eautoreconf
[[ ${CC} == *clang* ]] && append-flags -std=gnu89
}
-src_configure() {
+multilib_src_configure() {
local myeconfargs=(
--disable-maintainer-mode
--disable-example-progs
@@ -53,7 +55,8 @@ src_configure() {
)
# Darwin linker doesn't get this
[[ ${CHOST} == *-darwin* ]] && myeconfargs+=( --without-versioned-libs )
- autotools-multilib_src_configure
+ ECONF_SOURCE="${S}" \
+ econf "${myeconfargs[@]}"
}
pkg_postinst() {
diff --git a/dev-libs/libcdio-paranoia/libcdio-paranoia-0.94_p1-r1.ebuild b/dev-libs/libcdio-paranoia/libcdio-paranoia-0.94_p1-r1.ebuild
index 2ff7a7f56e5..0fe60647a42 100644
--- a/dev-libs/libcdio-paranoia/libcdio-paranoia-0.94_p1-r1.ebuild
+++ b/dev-libs/libcdio-paranoia/libcdio-paranoia-0.94_p1-r1.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+
MY_P=${PN}-10.2+${PV/_p/+}
inherit eutils autotools multilib-minimal flag-o-matic
@@ -21,8 +22,8 @@ IUSE="+cxx static-libs test"
RDEPEND="app-eselect/eselect-cdparanoia
>=dev-libs/libcdio-0.94:0=[${MULTILIB_USEDEP}]
>=virtual/libiconv-0-r1[${MULTILIB_USEDEP}]
- abi_x86_32? ( !<=app-emulation/emul-linux-x86-medialibs-20130224-r10
- !app-emulation/emul-linux-x86-medialibs[-abi_x86_32(-)] )"
+"
+
DEPEND="${RDEPEND}
sys-devel/gettext
virtual/pkgconfig
@@ -35,8 +36,8 @@ DOCS=( AUTHORS ChangeLog NEWS README.md THANKS )
PATCHES=("${FILESDIR}"/${PN}-0.90-oos-tests.patch)
src_prepare() {
- sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.ac || die #466410
default
+ sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.ac || die #466410
eautoreconf
[[ ${CC} == *clang* ]] && append-flags -std=gnu89
diff --git a/dev-libs/libcdio-paranoia/libcdio-paranoia-0.94_p2.ebuild b/dev-libs/libcdio-paranoia/libcdio-paranoia-0.94_p2.ebuild
index 2ff7a7f56e5..086fc986f70 100644
--- a/dev-libs/libcdio-paranoia/libcdio-paranoia-0.94_p2.ebuild
+++ b/dev-libs/libcdio-paranoia/libcdio-paranoia-0.94_p2.ebuild
@@ -2,9 +2,10 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+
MY_P=${PN}-10.2+${PV/_p/+}
-inherit eutils autotools multilib-minimal flag-o-matic
+inherit autotools multilib-minimal flag-o-matic
DESCRIPTION="an advanced CDDA reader with error correction"
HOMEPAGE="https://www.gnu.org/software/libcdio/"
@@ -21,8 +22,8 @@ IUSE="+cxx static-libs test"
RDEPEND="app-eselect/eselect-cdparanoia
>=dev-libs/libcdio-0.94:0=[${MULTILIB_USEDEP}]
>=virtual/libiconv-0-r1[${MULTILIB_USEDEP}]
- abi_x86_32? ( !<=app-emulation/emul-linux-x86-medialibs-20130224-r10
- !app-emulation/emul-linux-x86-medialibs[-abi_x86_32(-)] )"
+"
+
DEPEND="${RDEPEND}
sys-devel/gettext
virtual/pkgconfig
@@ -32,11 +33,13 @@ S="${WORKDIR}/${MY_P}"
DOCS=( AUTHORS ChangeLog NEWS README.md THANKS )
-PATCHES=("${FILESDIR}"/${PN}-0.90-oos-tests.patch)
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.90-oos-tests.patch
+)
src_prepare() {
- sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.ac || die #466410
default
+ sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.ac || die #466410
eautoreconf
[[ ${CC} == *clang* ]] && append-flags -std=gnu89
@@ -58,7 +61,7 @@ multilib_src_configure() {
# Darwin linker doesn't get this
[[ ${CHOST} == *-darwin* ]] && myeconfargs+=( --disable-ld-version-script )
ECONF_SOURCE="${S}" \
- econf "${myeconfargs[@]}"
+ econf "${myeconfargs[@]}"
}
pkg_postinst() {