summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libdaemon
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libdaemon')
-rw-r--r--dev-libs/libdaemon/Manifest1
-rw-r--r--dev-libs/libdaemon/libdaemon-0.14-r1.ebuild58
-rw-r--r--dev-libs/libdaemon/libdaemon-0.14-r2.ebuild69
-rw-r--r--dev-libs/libdaemon/metadata.xml7
4 files changed, 135 insertions, 0 deletions
diff --git a/dev-libs/libdaemon/Manifest b/dev-libs/libdaemon/Manifest
new file mode 100644
index 000000000000..5d4aaee7301e
--- /dev/null
+++ b/dev-libs/libdaemon/Manifest
@@ -0,0 +1 @@
+DIST libdaemon-0.14.tar.gz 340474 SHA256 fd23eb5f6f986dcc7e708307355ba3289abe03cc381fc47a80bca4a50aa6b834 SHA512 a96b25c09bd63cc192c1c5f8b5bf34cc6ad0c32d42ac14b520add611423b6ad3d64091a47e0c7ab9a94476a5e645529abccea3ed6b23596567163fba88131ff2 WHIRLPOOL e1f57dbf3089c666cf068c1e3113c01e68566545198b36f82b8174e5b6f52c466d8e5586ed818b5ccedeec9dba461ee2e878621b95e45962f62e9d7602f8f575
diff --git a/dev-libs/libdaemon/libdaemon-0.14-r1.ebuild b/dev-libs/libdaemon/libdaemon-0.14-r1.ebuild
new file mode 100644
index 000000000000..77f82a3c1dd5
--- /dev/null
+++ b/dev-libs/libdaemon/libdaemon-0.14-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit libtool eutils
+
+DESCRIPTION="Simple library for creating daemon processes in C"
+HOMEPAGE="http://0pointer.de/lennart/projects/libdaemon/"
+SRC_URI="http://0pointer.de/lennart/projects/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="doc examples static-libs"
+
+RDEPEND=""
+DEPEND="doc? ( app-doc/doxygen )"
+
+DOCS=( "README" )
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --localstatedir=/var \
+ --disable-examples \
+ --disable-lynx \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake
+
+ if use doc ; then
+ einfo "Building documentation"
+ emake doxygen
+ fi
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -exec rm -f {} +
+
+ if use doc; then
+ ln -sf doc/reference/html reference
+ dohtml -r doc/README.html doc/style.css reference
+ doman doc/reference/man/man*/*
+ fi
+
+ if use examples; then
+ docinto examples
+ dodoc examples/testd.c
+ fi
+
+ rm -rf "${ED}"/usr/share/doc/${PF}/{README.html,style.css} || die "rm failed"
+}
diff --git a/dev-libs/libdaemon/libdaemon-0.14-r2.ebuild b/dev-libs/libdaemon/libdaemon-0.14-r2.ebuild
new file mode 100644
index 000000000000..78569d7cb8a9
--- /dev/null
+++ b/dev-libs/libdaemon/libdaemon-0.14-r2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit libtool eutils multilib-minimal
+
+DESCRIPTION="Simple library for creating daemon processes in C"
+HOMEPAGE="http://0pointer.de/lennart/projects/libdaemon/"
+SRC_URI="http://0pointer.de/lennart/projects/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="doc examples static-libs"
+
+RDEPEND=""
+DEPEND="doc? ( app-doc/doxygen )"
+
+DOCS=( "README" )
+
+src_prepare() {
+ epatch_user
+
+ # doxygen is broken with out-of-source builds
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --localstatedir=/var \
+ --disable-examples \
+ --disable-lynx \
+ $(use_enable static-libs static)
+}
+
+multilib_src_compile() {
+ emake
+
+ if multilib_is_native_abi && use doc; then
+ einfo "Building documentation"
+ emake doxygen
+ fi
+}
+
+multilib_src_install() {
+ emake DESTDIR="${D}" install
+
+ if multilib_is_native_abi && use doc; then
+ ln -sf doc/reference/html reference
+ dohtml -r doc/README.html doc/style.css reference
+ doman doc/reference/man/man*/*
+ fi
+
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ prune_libtool_files --all
+
+ if use examples; then
+ docinto examples
+ dodoc examples/testd.c
+ fi
+
+ rm "${ED}"/usr/share/doc/${PF}/{README.html,style.css} || die "rm failed"
+}
diff --git a/dev-libs/libdaemon/metadata.xml b/dev-libs/libdaemon/metadata.xml
new file mode 100644
index 000000000000..2b43b61bb059
--- /dev/null
+++ b/dev-libs/libdaemon/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>eva@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>