summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libdivsufsort
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libdivsufsort')
-rw-r--r--dev-libs/libdivsufsort/Manifest1
-rw-r--r--dev-libs/libdivsufsort/libdivsufsort-2.0.1.ebuild21
-rw-r--r--dev-libs/libdivsufsort/libdivsufsort-9999.ebuild31
-rw-r--r--dev-libs/libdivsufsort/metadata.xml8
4 files changed, 61 insertions, 0 deletions
diff --git a/dev-libs/libdivsufsort/Manifest b/dev-libs/libdivsufsort/Manifest
new file mode 100644
index 000000000000..e8af15873b19
--- /dev/null
+++ b/dev-libs/libdivsufsort/Manifest
@@ -0,0 +1 @@
+DIST libdivsufsort-2.0.1.tar.bz2 263931 SHA256 55c02c86ea1763f581e0f50440008c554b8da2272129adee4ac84cb1362018bc SHA512 cfdcaeabcc5d785533a2532b5fccd72dec36dd8dd9925ef8752b75086da6ee2a93f6a907a881091253ae3155eff29337ce127d3daa42e3867212a3399052f6ef WHIRLPOOL ce88988baf91ad17d64c7b90fbbc1c3f277a84d09a7dc81cb99f567a15e48a0e19efdef90b0e7aae5fb1d8ddd2572b7fd9f7965f88a8f1ce1c46b0a139c023a6
diff --git a/dev-libs/libdivsufsort/libdivsufsort-2.0.1.ebuild b/dev-libs/libdivsufsort/libdivsufsort-2.0.1.ebuild
new file mode 100644
index 000000000000..b09621e241c0
--- /dev/null
+++ b/dev-libs/libdivsufsort/libdivsufsort-2.0.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit cmake-utils multilib
+
+DESCRIPTION="Suffix-sorting library (for BWT)"
+HOMEPAGE="http://code.google.com/p/libdivsufsort/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ # will appreciate saner approach, if there is any
+ sed -i -e "s:\(DESTINATION \)lib:\1$(get_libdir):" \
+ */CMakeLists.txt || die
+}
diff --git a/dev-libs/libdivsufsort/libdivsufsort-9999.ebuild b/dev-libs/libdivsufsort/libdivsufsort-9999.ebuild
new file mode 100644
index 000000000000..1e6905313683
--- /dev/null
+++ b/dev-libs/libdivsufsort/libdivsufsort-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit cmake-utils multilib
+
+#if LIVE
+ESVN_REPO_URI="http://libdivsufsort.googlecode.com/svn/trunk/"
+inherit subversion
+#endif
+
+DESCRIPTION="Suffix-sorting library (for BWT)"
+HOMEPAGE="http://code.google.com/p/libdivsufsort/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+#if LIVE
+KEYWORDS=
+SRC_URI=
+#endif
+
+src_prepare() {
+ # will appreciate saner approach, if there is any
+ sed -i -e "s:\(DESTINATION \)lib:\1$(get_libdir):" \
+ */CMakeLists.txt || die
+}
diff --git a/dev-libs/libdivsufsort/metadata.xml b/dev-libs/libdivsufsort/metadata.xml
new file mode 100644
index 000000000000..5cb9324943ab
--- /dev/null
+++ b/dev-libs/libdivsufsort/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+</pkgmetadata>