summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-libs/libdshconfig
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-libs/libdshconfig')
-rw-r--r--dev-libs/libdshconfig/Manifest2
-rw-r--r--dev-libs/libdshconfig/libdshconfig-0.20.12.ebuild20
-rw-r--r--dev-libs/libdshconfig/libdshconfig-0.20.13.ebuild30
-rw-r--r--dev-libs/libdshconfig/metadata.xml5
4 files changed, 57 insertions, 0 deletions
diff --git a/dev-libs/libdshconfig/Manifest b/dev-libs/libdshconfig/Manifest
new file mode 100644
index 000000000000..0c460d99f3c9
--- /dev/null
+++ b/dev-libs/libdshconfig/Manifest
@@ -0,0 +1,2 @@
+DIST libdshconfig-0.20.12.tar.gz 316955 SHA256 aa7d7a2ec78ea03a7776fbf1899edbcc79477833c7c79c54d2bfa0106e3e359e SHA512 6ee7e813599715c2217f05212e0efb94d9588f71db3f3f470e50e9fbde93be3fd3ce3b8164251ea647e76ba9fd0db502985b5fc1e3afffdf9074a00ee9900b64 WHIRLPOOL 8cebd2327e6636b2476530c5eb35919bef11212d14989ff26658714ad34848c81dddc0bddeebbe8fbd1ab03e13071f9d2d22c588776b6f018e682c2fda1fc400
+DIST libdshconfig-0.20.13.tar.gz 323720 SHA256 6f372686c5d8d721820995d2b60d2fda33fdb17cdddee9fce34795e7e98c5384 SHA512 04f3580bf1e1dbac130d350eb4c6e86a980f2ae8636a206821813ed0e14db07dc7ea720ebb3816455a4a939294caa2f2247b7348ecea72769a6f05bee0dbf19a WHIRLPOOL 401f791c88bf5048a0b296ec32ec75128322b2db61b94e82221ce7f1b18c4feba6fd573eed1a2356ca9b56a09ce7a63157dcd54585c0e6dba5214de15a2f1fbf
diff --git a/dev-libs/libdshconfig/libdshconfig-0.20.12.ebuild b/dev-libs/libdshconfig/libdshconfig-0.20.12.ebuild
new file mode 100644
index 000000000000..b3124d38b91c
--- /dev/null
+++ b/dev-libs/libdshconfig/libdshconfig-0.20.12.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="Library for parsing dsh.style configuration files"
+HOMEPAGE="http://www.netfort.gr.jp/~dancer/software/downloads/"
+SRC_URI="http://www.netfort.gr.jp/~dancer/software/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~m68k-mint"
+IUSE=""
+
+DEPEND=""
+RDEPEND="virtual/ssh"
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc ChangeLog
+}
diff --git a/dev-libs/libdshconfig/libdshconfig-0.20.13.ebuild b/dev-libs/libdshconfig/libdshconfig-0.20.13.ebuild
new file mode 100644
index 000000000000..0de2a4002cab
--- /dev/null
+++ b/dev-libs/libdshconfig/libdshconfig-0.20.13.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="Library for parsing dsh.style configuration files"
+HOMEPAGE="http://www.netfort.gr.jp/~dancer/software/downloads/"
+SRC_URI="http://www.netfort.gr.jp/~dancer/software/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux ~m68k-mint"
+IUSE="static-libs"
+
+DEPEND=""
+RDEPEND="virtual/ssh"
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ prune_libtool_files --all
+}
diff --git a/dev-libs/libdshconfig/metadata.xml b/dev-libs/libdshconfig/metadata.xml
new file mode 100644
index 000000000000..348e6c4de815
--- /dev/null
+++ b/dev-libs/libdshconfig/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>cluster</herd>
+</pkgmetadata>