summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-06-05 15:11:54 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-06-05 15:25:27 +0200
commitfa53e9d7a0c77755c414c1fa012329c98e8c6705 (patch)
tree0499bdf6346da84b6a68843201e665de7ee99595 /dev-libs/libestr/libestr-0.1.11-r1.ebuild
parentdev-libs/libestr: take up maintainership; update metadata (diff)
downloadgentoo-fa53e9d7a0c77755c414c1fa012329c98e8c6705.tar.gz
gentoo-fa53e9d7a0c77755c414c1fa012329c98e8c6705.tar.bz2
gentoo-fa53e9d7a0c77755c414c1fa012329c98e8c6705.zip
dev-libs/libestr: bump to EAPI 8; minor tweaks
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-libs/libestr/libestr-0.1.11-r1.ebuild')
-rw-r--r--dev-libs/libestr/libestr-0.1.11-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-libs/libestr/libestr-0.1.11-r1.ebuild b/dev-libs/libestr/libestr-0.1.11-r1.ebuild
new file mode 100644
index 000000000000..ad8ff4a5ae64
--- /dev/null
+++ b/dev-libs/libestr/libestr-0.1.11-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Library for some string essentials"
+HOMEPAGE="https://libestr.adiscon.com/"
+SRC_URI="https://libestr.adiscon.com/files/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 ~hppa x86"
+IUSE="debug static-libs test"
+RESTRICT="!test? ( test )"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ $(use_enable static-libs static)
+ $(use_enable test testbench)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ find "${ED}"/usr/lib* -name '*.la' -delete || die
+}