summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-11-20 20:14:46 +0100
committerManuel Rüger <mrueg@gentoo.org>2017-11-20 20:15:52 +0100
commit67fee746e6f72f4ba4c0d8b50840074a12088c81 (patch)
tree1409547a11ea9c61825e3bea746da8d431e117f1 /dev-libs/libinput
parentdev-python/jinja: Version bump to 2.10 (diff)
downloadgentoo-67fee746e6f72f4ba4c0d8b50840074a12088c81.tar.gz
gentoo-67fee746e6f72f4ba4c0d8b50840074a12088c81.tar.bz2
gentoo-67fee746e6f72f4ba4c0d8b50840074a12088c81.zip
dev-libs/libinput: Version bump to 1.9.2
Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'dev-libs/libinput')
-rw-r--r--dev-libs/libinput/Manifest1
-rw-r--r--dev-libs/libinput/libinput-1.9.2.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-libs/libinput/Manifest b/dev-libs/libinput/Manifest
index 06224b8afd3e..bea7d6bef054 100644
--- a/dev-libs/libinput/Manifest
+++ b/dev-libs/libinput/Manifest
@@ -3,3 +3,4 @@ DIST libinput-1.7.3.tar.xz 922464 SHA256 096d612d2711f0caa2de544976ff3729e623351
DIST libinput-1.8.3.tar.xz 941832 SHA256 2fe2e2f52f0971a9c43541b8f26582ca8df6ed4bb9050e85eb40d4ff6b13142d SHA512 88006d217e3507858fa6b9ac1f25c267255fb51d1bcf1208d2afd423bf2a9292944bc5526ea91f27fad3ff04c2f9f43ab3aa25fd9fb7ace1231ecd33ddf18de6 WHIRLPOOL ebe128f8e9bce71dc7e878cd7dd7815cb0a358f91945ea47945568a1994f1a80c2d6f8db7d5f8f9c5e554c22fcc13733ca4bdcb68b47a72e16e55098904a93e2
DIST libinput-1.9.0.tar.xz 455248 SHA256 fd717b1f9cf867b2ca1763a5a4638423af178f3a70aa34d278e8bf42777d108e SHA512 4111dd02ef7778c246da28ead284a77014f6eaa4b7f90f36ee124af809e31c70ac065216ef5648d1d2dc525355176e2aa22788bfbb19f5f6d25276fbba42e150 WHIRLPOOL 7a6da661226ef8721bbad446a75be75a3d556d9e886cf44d2296a0fe17207ac181ebd4a4f25dca7ae4072d97cb9759d626d26a1572f007c6b1e9499a0d71beaf
DIST libinput-1.9.1.tar.xz 456772 SHA256 f0780de4211b3d09f86c17f619f936261a213ca532f8c9ec8f8e7e43422a65f8 SHA512 e60c401cdec6b862c6c7186e636bba285e229b82998d9f86940659806bb64c295ec1060b5e8065345668e4b3ff95457bd01327351520d9f6cf8cbc98b9b95da0 WHIRLPOOL 3a2b679d5d0f1671281fd689a842ccca1f1750f5af6d004d767364daaf17edc7dd8ec17413f1c05c28d162d03036a2719ac2db02bd253f051a9f82c6a667698d
+DIST libinput-1.9.2.tar.xz 460388 SHA256 dd6853241ffe1f1d83b5a375a2f1c17b2901fdbba5d302c67987cc0f4101de3b SHA512 99719ab26be8ed35937ce91307459fa8c4aa7c383a555f1012a058ba98ca1d1c5df0d9b5e6a45046341c6dbae496dc29512b487ac7873b6ec67cab1176ee04ac WHIRLPOOL fdb281e7a0fdf4bb3feca06c7baaa3f9095265b6e65ed810a20f98e9aac2a89f7f740375296fd0ff9209475d548aa0d3ffcac8b8607c9fea7d7298af487bb682
diff --git a/dev-libs/libinput/libinput-1.9.2.ebuild b/dev-libs/libinput/libinput-1.9.2.ebuild
new file mode 100644
index 000000000000..89bf24d7c505
--- /dev/null
+++ b/dev-libs/libinput/libinput-1.9.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit meson udev
+
+DESCRIPTION="Library to handle input devices in Wayland"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/libinput/"
+SRC_URI="https://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0/10"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc input_devices_wacom test"
+# Tests require write access to udev rules directory which is a no-no for live system.
+# Other tests are just about logs, exported symbols and autotest of the test library.
+RESTRICT="test"
+
+RDEPEND="
+ input_devices_wacom? ( >=dev-libs/libwacom-0.20 )
+ >=dev-libs/libevdev-1.3
+ >=sys-libs/mtdev-1.1
+ virtual/libudev
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? (
+ >=app-doc/doxygen-1.8.3
+ >=media-gfx/graphviz-2.38.0
+ )
+"
+# test? (
+# >=dev-libs/check-0.9.10
+# dev-util/valgrind
+# sys-libs/libunwind )
+
+src_configure() {
+ # gui can be built but will not be installed
+ local emesonargs=(
+ -Ddebug-gui=false
+ -Ddocumentation="$(usex doc true false)"
+ -Dlibwacom="$(usex input_devices_wacom true false)"
+ -Dtests="$(usex test true false)"
+ -Dudev-dir="$(get_udevdir)"
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ if use doc ; then
+ docinto html
+ dodoc -r "${BUILD_DIR}"/html/.
+ fi
+ find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
+}