summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-03-11 11:33:31 -0700
committerMatt Turner <mattst88@gentoo.org>2020-03-11 11:41:40 -0700
commit8d2a156f8c6b00749cd6e9b0efd23bf08b670ab5 (patch)
tree540ac307d74cc600bf481fbbc9e7ea60c1d72dc0 /dev-libs/libinput
parentnet-wireless/bluez: Make repoman happy (diff)
downloadgentoo-8d2a156f8c6b00749cd6e9b0efd23bf08b670ab5.tar.gz
gentoo-8d2a156f8c6b00749cd6e9b0efd23bf08b670ab5.tar.bz2
gentoo-8d2a156f8c6b00749cd6e9b0efd23bf08b670ab5.zip
dev-libs/libinput: Drop old versions
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs/libinput')
-rw-r--r--dev-libs/libinput/Manifest1
-rw-r--r--dev-libs/libinput/libinput-1.14.3.ebuild78
2 files changed, 0 insertions, 79 deletions
diff --git a/dev-libs/libinput/Manifest b/dev-libs/libinput/Manifest
index d01b4ce3f02d..511eed6d257d 100644
--- a/dev-libs/libinput/Manifest
+++ b/dev-libs/libinput/Manifest
@@ -1,3 +1,2 @@
-DIST libinput-1.14.3.tar.xz 567560 BLAKE2B 76d38b795a5e721a73062e9c37b23bf6739291549cadc66401ef47b1a9afd5766f1d0ed855fc66912e4257fae4b1b813946c67246adb8d8566d5ad9478079636 SHA512 f01d1bd1b25b8060519575644597d35f0c89de5386d298441f440128ceee3e57549921a058adec31adc8b33dbdedf4c0bd12c76905a69f752859d3136e26336d
DIST libinput-1.15.2.tar.xz 580624 BLAKE2B a13bf121b12c58d904f3505fe2fa60ea32eee78a057ac1fe9e64d3017fa840bb92af053f472d2b163d46a958f2a3a5039154efbb9558eddabda3b2422cafb2ca SHA512 f6b50dbdf6ee6b65f88e020c4292c94c3178125d58629f27c2e52f92b658ccd67e0c5604fbf0b303621ff0386637ce1e291daaa991761d4145e8bcda4dd128a2
DIST libinput-1.15.3.tar.xz 580408 BLAKE2B d5d462f81303e408f295fbc958609363ec9e3f4eb20494aa8fa977a458283619f321309f88167c70069ac7bd07dc782d948e9a75583ae6e930524f63dad5cafe SHA512 6636fd618e2b9cfa5ee44701207dc98f2639adc53eb3ef135509d936fb19b2cedf5184eab58e887798d9cf8ee65f35bc9062f7e3630080bcbe45a90a8b631ef2
diff --git a/dev-libs/libinput/libinput-1.14.3.ebuild b/dev-libs/libinput/libinput-1.14.3.ebuild
deleted file mode 100644
index 7a369d3cd2dd..000000000000
--- a/dev-libs/libinput/libinput-1.14.3.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 2014-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit meson python-any-r1 udev
-
-DESCRIPTION="Library to handle input devices in Wayland"
-HOMEPAGE="https://www.freedesktop.org/wiki/Software/libinput/ https://gitlab.freedesktop.org/libinput/libinput"
-SRC_URI="https://www.freedesktop.org/software/${PN}/${P}.tar.xz"
-
-LICENSE="MIT"
-SLOT="0/10"
-KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ppc ppc64 ~s390 sparc x86"
-IUSE="doc input_devices_wacom"
-# Tests require write access to udev rules directory which is a no-no for live system.
-# Other tests are just about logs, exported symbols and autotest of the test library.
-RESTRICT="test"
-
-BDEPEND="
- virtual/pkgconfig
- doc? (
- $(python_gen_any_dep '
- dev-python/commonmark[${PYTHON_USEDEP}]
- dev-python/recommonmark[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- >=dev-python/sphinx_rtd_theme-0.2.4[${PYTHON_USEDEP}]
- ')
- >=app-doc/doxygen-1.8.3
- >=media-gfx/graphviz-2.38.0
- )
-"
-# test? ( dev-util/valgrind )
-RDEPEND="
- input_devices_wacom? ( >=dev-libs/libwacom-0.20 )
- >=dev-libs/libevdev-1.3
- >=sys-libs/mtdev-1.1
- virtual/libudev:=
- virtual/udev
-"
-DEPEND="${RDEPEND}"
-# test? ( >=dev-libs/check-0.9.10 )
-
-python_check_deps() {
- has_version "dev-python/commonmark[${PYTHON_USEDEP}]" && \
- has_version "dev-python/recommonmark[${PYTHON_USEDEP}]" && \
- has_version "dev-python/sphinx[${PYTHON_USEDEP}]" && \
- has_version ">=dev-python/sphinx_rtd_theme-0.2.4[${PYTHON_USEDEP}]"
-}
-
-pkg_setup() {
- use doc && python-any-r1_pkg_setup
-}
-
-src_configure() {
- # gui can be built but will not be installed
- local emesonargs=(
- -Ddebug-gui=false
- $(meson_use doc documentation)
- $(meson_use input_devices_wacom libwacom)
- -Dtests=false # tests are restricted
- -Dudev-dir="${EPREFIX}$(get_udevdir)"
- )
- meson_src_configure
-}
-
-src_install() {
- meson_src_install
- if use doc ; then
- docinto html
- dodoc -r "${BUILD_DIR}"/Documentation/.
- fi
-}
-
-pkg_postinst() {
- udevadm hwdb --update --root="${ROOT}"
-}